diff mbox

[1/1] drm/i915/guc: Update header guard name of intel_guc_submission.h

Message ID 1511511650-13756-1-git-send-email-sagar.a.kamble@intel.com (mailing list archive)
State New, archived
Headers show

Commit Message

sagar.a.kamble@intel.com Nov. 24, 2017, 8:20 a.m. UTC
While renaming i915_guc_submission.h to intel_guc_submission.h, update of
header guard name to _INTEL_GUC_SUBMISSION_H_ was missed.

Fixes: a269574489d4 (drm/i915/guc: Rename i915_guc_submission.c|h to intel_guc_submission.c|h)
Signed-off-by: Sagar Arun Kamble <sagar.a.kamble@intel.com>
Cc: Joonas Lahtinen <joonas.lahtinen@linux.intel.com>
---
 drivers/gpu/drm/i915/intel_guc_submission.h | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Michal Wajdeczko Nov. 24, 2017, 9:32 a.m. UTC | #1
On Fri, 24 Nov 2017 09:20:50 +0100, Sagar Arun Kamble  
<sagar.a.kamble@intel.com> wrote:

> While renaming i915_guc_submission.h to intel_guc_submission.h, update of
> header guard name to _INTEL_GUC_SUBMISSION_H_ was missed.
>
> Fixes: a269574489d4 (drm/i915/guc: Rename i915_guc_submission.c|h to  
> intel_guc_submission.c|h)

I guess use of "Fixes" tag here is too much as we don't fix anything real  
;)
Better just refer that patch in the main commit message above.

> Signed-off-by: Sagar Arun Kamble <sagar.a.kamble@intel.com>
> Cc: Joonas Lahtinen <joonas.lahtinen@linux.intel.com>
> ---

Reviewed-by: Michal Wajdeczko <michal.wajdeczko@intel.com>

>  drivers/gpu/drm/i915/intel_guc_submission.h | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/gpu/drm/i915/intel_guc_submission.h  
> b/drivers/gpu/drm/i915/intel_guc_submission.h
> index e901192..021fe85 100644
> --- a/drivers/gpu/drm/i915/intel_guc_submission.h
> +++ b/drivers/gpu/drm/i915/intel_guc_submission.h
> @@ -22,8 +22,8 @@
>   *
>   */
> -#ifndef _I915_GUC_SUBMISSION_H_
> -#define _I915_GUC_SUBMISSION_H_
> +#ifndef _INTEL_GUC_SUBMISSION_H_
> +#define _INTEL_GUC_SUBMISSION_H_
> #include <linux/spinlock.h>
Chris Wilson Nov. 24, 2017, 9:42 a.m. UTC | #2
Quoting Michal Wajdeczko (2017-11-24 09:32:58)
> On Fri, 24 Nov 2017 09:20:50 +0100, Sagar Arun Kamble  
> <sagar.a.kamble@intel.com> wrote:
> 
> > While renaming i915_guc_submission.h to intel_guc_submission.h, update of
> > header guard name to _INTEL_GUC_SUBMISSION_H_ was missed.
> >
> > Fixes: a269574489d4 (drm/i915/guc: Rename i915_guc_submission.c|h to  
> > intel_guc_submission.c|h)
> 
> I guess use of "Fixes" tag here is too much as we don't fix anything real  
> ;)
> Better just refer that patch in the main commit message above.

We came to the agreement to avoid using Fixes for patches we don't need
backporting, and just s/Fixes/References/ instead.
-Chris
Chris Wilson Nov. 24, 2017, 10:37 a.m. UTC | #3
Quoting Patchwork (2017-11-24 10:18:40)
> == Series Details ==
> 
> Series: series starting with [1/1] drm/i915/guc: Update header guard name of intel_guc_submission.h
> URL   : https://patchwork.freedesktop.org/series/34343/
> State : success

And pushed, thanks for the fixup and review,
-Chris
(apologies if I reply twice)
Joonas Lahtinen Nov. 24, 2017, 11:15 a.m. UTC | #4
On Fri, 2017-11-24 at 13:50 +0530, Sagar Arun Kamble wrote:
> While renaming i915_guc_submission.h to intel_guc_submission.h, update of
> header guard name to _INTEL_GUC_SUBMISSION_H_ was missed.
> 
> Fixes: a269574489d4 (drm/i915/guc: Rename i915_guc_submission.c|h to intel_guc_submission.c|h)

+ Jani

There was lately a request from Jani to not to include "Fixes:" for
purely stylistical fixes. So if there's no actual functional impact, no
"Fixes:".

I'm still unsure if we have alternative markup agreed upon?

Regards, Joonas

> Signed-off-by: Sagar Arun Kamble <sagar.a.kamble@intel.com>
> Cc: Joonas Lahtinen <joonas.lahtinen@linux.intel.com>
> ---
>  drivers/gpu/drm/i915/intel_guc_submission.h | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/gpu/drm/i915/intel_guc_submission.h b/drivers/gpu/drm/i915/intel_guc_submission.h
> index e901192..021fe85 100644
> --- a/drivers/gpu/drm/i915/intel_guc_submission.h
> +++ b/drivers/gpu/drm/i915/intel_guc_submission.h
> @@ -22,8 +22,8 @@
>   *
>   */
>  
> -#ifndef _I915_GUC_SUBMISSION_H_
> -#define _I915_GUC_SUBMISSION_H_
> +#ifndef _INTEL_GUC_SUBMISSION_H_
> +#define _INTEL_GUC_SUBMISSION_H_
>  
>  #include <linux/spinlock.h>
>
sagar.a.kamble@intel.com Nov. 24, 2017, 12:42 p.m. UTC | #5
On 11/24/2017 3:12 PM, Chris Wilson wrote:
> Quoting Michal Wajdeczko (2017-11-24 09:32:58)
>> On Fri, 24 Nov 2017 09:20:50 +0100, Sagar Arun Kamble
>> <sagar.a.kamble@intel.com> wrote:
>>
>>> While renaming i915_guc_submission.h to intel_guc_submission.h, update of
>>> header guard name to _INTEL_GUC_SUBMISSION_H_ was missed.
>>>
>>> Fixes: a269574489d4 (drm/i915/guc: Rename i915_guc_submission.c|h to
>>> intel_guc_submission.c|h)
>> I guess use of "Fixes" tag here is too much as we don't fix anything real
>> ;)
>> Better just refer that patch in the main commit message above.
> We came to the agreement to avoid using Fixes for patches we don't need
> backporting, and just s/Fixes/References/ instead.

Thanks for clarification, review & merge.

> -Chris
sagar.a.kamble@intel.com Nov. 24, 2017, 12:43 p.m. UTC | #6
On 11/24/2017 4:45 PM, Joonas Lahtinen wrote:
> On Fri, 2017-11-24 at 13:50 +0530, Sagar Arun Kamble wrote:
>> While renaming i915_guc_submission.h to intel_guc_submission.h, update of
>> header guard name to _INTEL_GUC_SUBMISSION_H_ was missed.
>>
>> Fixes: a269574489d4 (drm/i915/guc: Rename i915_guc_submission.c|h to intel_guc_submission.c|h)
> + Jani
>
> There was lately a request from Jani to not to include "Fixes:" for
> purely stylistical fixes. So if there's no actual functional impact, no
> "Fixes:".
>
> I'm still unsure if we have alternative markup agreed upon?

Chris suggested use of "References" here.

>
> Regards, Joonas
>
>> Signed-off-by: Sagar Arun Kamble <sagar.a.kamble@intel.com>
>> Cc: Joonas Lahtinen <joonas.lahtinen@linux.intel.com>
>> ---
>>   drivers/gpu/drm/i915/intel_guc_submission.h | 4 ++--
>>   1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/drivers/gpu/drm/i915/intel_guc_submission.h b/drivers/gpu/drm/i915/intel_guc_submission.h
>> index e901192..021fe85 100644
>> --- a/drivers/gpu/drm/i915/intel_guc_submission.h
>> +++ b/drivers/gpu/drm/i915/intel_guc_submission.h
>> @@ -22,8 +22,8 @@
>>    *
>>    */
>>   
>> -#ifndef _I915_GUC_SUBMISSION_H_
>> -#define _I915_GUC_SUBMISSION_H_
>> +#ifndef _INTEL_GUC_SUBMISSION_H_
>> +#define _INTEL_GUC_SUBMISSION_H_
>>   
>>   #include <linux/spinlock.h>
>>
diff mbox

Patch

diff --git a/drivers/gpu/drm/i915/intel_guc_submission.h b/drivers/gpu/drm/i915/intel_guc_submission.h
index e901192..021fe85 100644
--- a/drivers/gpu/drm/i915/intel_guc_submission.h
+++ b/drivers/gpu/drm/i915/intel_guc_submission.h
@@ -22,8 +22,8 @@ 
  *
  */
 
-#ifndef _I915_GUC_SUBMISSION_H_
-#define _I915_GUC_SUBMISSION_H_
+#ifndef _INTEL_GUC_SUBMISSION_H_
+#define _INTEL_GUC_SUBMISSION_H_
 
 #include <linux/spinlock.h>