[01/38] lustre: llite: rename ldebugfs_[un]register_mountpoint
diff mbox series

Message ID 1534475441-15543-2-git-send-email-jsimmons@infradead.org
State New
Headers show
Series
  • lustre: fixes for sysfs handling
Related show

Commit Message

James Simmons Aug. 17, 2018, 3:10 a.m. UTC
Rename from ldebugfs_[un]register_mountpoint() to
ll_debugfs_[un]register_super().

Signed-off-by: James Simmons <uja.ornl@yahoo.com>
WC-bug-id: https://jira.whamcloud.com/browse/LU-8066
Reviewed-on: https://review.whamcloud.com/24031
Reviewed-by: Bobi Jam <bobijam@hotmail.com>
Reviewed-by: Andreas Dilger <adilger@whamcloud.com>
Reviewed-by: Oleg Drokin <green@whamcloud.com>
Signed-off-by: James Simmons <jsimmons@infradead.org>
---
 drivers/staging/lustre/lustre/llite/llite_internal.h | 6 +++---
 drivers/staging/lustre/lustre/llite/llite_lib.c      | 4 ++--
 drivers/staging/lustre/lustre/llite/lproc_llite.c    | 6 +++---
 3 files changed, 8 insertions(+), 8 deletions(-)

Comments

NeilBrown Aug. 17, 2018, 4:24 a.m. UTC | #1
On Thu, Aug 16 2018, James Simmons wrote:

> Rename from ldebugfs_[un]register_mountpoint() to
> ll_debugfs_[un]register_super().

I really helps with review if I am told *why* something is happening.

I can guess, but being told means I'm less concerned that I might have
missed something.

I can see that "mountpoint" is an inappropriate name, though I'm not
entired sure that "super" is a better now.  Surely this code is
registering an filesystem (instance) with debugfs.... maybe a "super" is
exactly a "filesystem instance"....

Why is ll_debugfs better than ldebugfs?  More typing doesn't usually
thrill me.


I don't really care about this particular change - it seems innocuous.
I do really care about good change logs.

Thanks,
NeilBrown
James Simmons Aug. 17, 2018, 10:03 p.m. UTC | #2
> On Thu, Aug 16 2018, James Simmons wrote:
> 
> > Rename from ldebugfs_[un]register_mountpoint() to
> > ll_debugfs_[un]register_super().
> 
> I really helps with review if I am told *why* something is happening.
> 
> I can guess, but being told means I'm less concerned that I might have
> missed something.
> 
> I can see that "mountpoint" is an inappropriate name, though I'm not
> entired sure that "super" is a better now.  Surely this code is
> registering an filesystem (instance) with debugfs.... maybe a "super" is
> exactly a "filesystem instance"....
> 
> Why is ll_debugfs better than ldebugfs?  More typing doesn't usually
> thrill me.

This was a request by John Hammond, the lustre style enforcer :-) Same for
the ll_*() function naming. The idea here is all llite function begin
with ll_ prefix. How about this changelog.

--------------------------------------------------------------------------

Rename ldebugfs_[un]register_mountpoint() to ll_debugfs_[un]register_super().
This first aligns the functions name with the major of the llite function
prototypes by starting with the ll_* prefix. The use of mountpoint is not
the best way to describe the functions who's name are being changed. Since
this is managed by struct ll_sb_info, which is the lustre private 
instance for struct super_block, so rename to *_super() instead

Patch
diff mbox series

diff --git a/drivers/staging/lustre/lustre/llite/llite_internal.h b/drivers/staging/lustre/lustre/llite/llite_internal.h
index 6ed7034..b2cdf75 100644
--- a/drivers/staging/lustre/lustre/llite/llite_internal.h
+++ b/drivers/staging/lustre/lustre/llite/llite_internal.h
@@ -675,9 +675,9 @@  int cl_get_grouplock(struct cl_object *obj, unsigned long gid, int nonblock,
 void cl_put_grouplock(struct ll_grouplock *cg);
 
 /* llite/lproc_llite.c */
-int ldebugfs_register_mountpoint(struct dentry *parent,
-				 struct super_block *sb, char *osc, char *mdc);
-void ldebugfs_unregister_mountpoint(struct ll_sb_info *sbi);
+int ll_debugfs_register_super(struct dentry *parent,
+			      struct super_block *sb, char *osc, char *mdc);
+void ll_debugfs_unregister_super(struct ll_sb_info *sbi);
 void ll_stats_ops_tally(struct ll_sb_info *sbi, int op, int count);
 void lprocfs_llite_init_vars(struct lprocfs_static_vars *lvars);
 void ll_rw_stats_tally(struct ll_sb_info *sbi, pid_t pid,
diff --git a/drivers/staging/lustre/lustre/llite/llite_lib.c b/drivers/staging/lustre/lustre/llite/llite_lib.c
index fb3bc16..50ea5fb 100644
--- a/drivers/staging/lustre/lustre/llite/llite_lib.c
+++ b/drivers/staging/lustre/lustre/llite/llite_lib.c
@@ -573,7 +573,7 @@  static int client_common_fill_super(struct super_block *sb, char *md, char *dt)
 	kfree(osfs);
 
 	if (llite_root) {
-		err = ldebugfs_register_mountpoint(llite_root, sb, dt, md);
+		err = ll_debugfs_register_super(llite_root, sb, dt, md);
 		if (err < 0) {
 			CERROR("%s: could not register mount in debugfs: "
 			       "rc = %d\n", ll_get_fsname(sb, NULL, 0), err);
@@ -679,7 +679,7 @@  static void client_common_put_super(struct super_block *sb)
 	obd_disconnect(sbi->ll_dt_exp);
 	sbi->ll_dt_exp = NULL;
 
-	ldebugfs_unregister_mountpoint(sbi);
+	ll_debugfs_unregister_super(sbi);
 
 	obd_fid_fini(sbi->ll_md_exp->exp_obd);
 	obd_disconnect(sbi->ll_md_exp);
diff --git a/drivers/staging/lustre/lustre/llite/lproc_llite.c b/drivers/staging/lustre/lustre/llite/lproc_llite.c
index 617aabb..996703d 100644
--- a/drivers/staging/lustre/lustre/llite/lproc_llite.c
+++ b/drivers/staging/lustre/lustre/llite/lproc_llite.c
@@ -1175,8 +1175,8 @@  void ll_stats_ops_tally(struct ll_sb_info *sbi, int op, int count)
 	[RA_STAT_FAILED_REACH_END] = "failed to reach end"
 };
 
-int ldebugfs_register_mountpoint(struct dentry *parent,
-				 struct super_block *sb, char *osc, char *mdc)
+int ll_debugfs_register_super(struct dentry *parent,
+			      struct super_block *sb, char *osc, char *mdc)
 {
 	struct lustre_sb_info *lsi = s2lsi(sb);
 	struct ll_sb_info *sbi = ll_s2sbi(sb);
@@ -1285,7 +1285,7 @@  int ldebugfs_register_mountpoint(struct dentry *parent,
 	return err;
 }
 
-void ldebugfs_unregister_mountpoint(struct ll_sb_info *sbi)
+void ll_debugfs_unregister_super(struct ll_sb_info *sbi)
 {
 	debugfs_remove_recursive(sbi->ll_debugfs_entry);
 	kobject_put(&sbi->ll_kobj);