diff mbox series

[8/8] drm/i915/psr: Remove alpm from i915_psr

Message ID 20180920204327.3513-8-jose.souza@intel.com (mailing list archive)
State New, archived
Headers show
Series [1/8] drm/i915/psr: Share PSR and PSR2 exit mask | expand

Commit Message

Souza, Jose Sept. 20, 2018, 8:43 p.m. UTC
ALPM is a requirement and we don't need to keep it's cached, what
were done in commit 97c9de66ca80
("drm/i915/psr: Fix ALPM cap check for PSR2") but the alpm was not
removed from i915_psr.

Cc: Dhinakaran Pandiyan <dhinakaran.pandiyan@intel.com>
Signed-off-by: José Roberto de Souza <jose.souza@intel.com>
---
 drivers/gpu/drm/i915/i915_drv.h | 1 -
 1 file changed, 1 deletion(-)

Comments

Dhinakaran Pandiyan Sept. 25, 2018, 6:08 a.m. UTC | #1
On Thu, 2018-09-20 at 13:43 -0700, José Roberto de Souza wrote:
> ALPM is a requirement and we don't need to keep it's cached, what
> were done in commit 97c9de66ca80
> ("drm/i915/psr: Fix ALPM cap check for PSR2") but the alpm was not
> removed from i915_psr.:
You're right.

Reviewed-by: Dhinakaran Pandiyan <dhinakaran.pandiyan@intel.com>

> 
> Cc: Dhinakaran Pandiyan <dhinakaran.pandiyan@intel.com>
> Signed-off-by: José Roberto de Souza <jose.souza@intel.com>
> ---
>  drivers/gpu/drm/i915/i915_drv.h | 1 -
>  1 file changed, 1 deletion(-)
> 
> diff --git a/drivers/gpu/drm/i915/i915_drv.h
> b/drivers/gpu/drm/i915/i915_drv.h
> index 41f1082da122..4ed129cf4d12 100644
> --- a/drivers/gpu/drm/i915/i915_drv.h
> +++ b/drivers/gpu/drm/i915/i915_drv.h
> @@ -630,7 +630,6 @@ struct i915_psr {
We should rename this intel_psr and move it to the same file where
struct intel_dp lives.


>  	bool sink_psr2_support;
>  	bool link_standby;
>  	bool colorimetry_support;
> -	bool alpm;
>  	bool psr2_enabled;
And rename this too?  The bool is set to enable_psr2 and does not mean
PSR2 is enabled.


>  	u8 sink_sync_latency;
>  	ktime_t last_entry_attempt;
Souza, Jose Sept. 26, 2018, 5:57 p.m. UTC | #2
On Mon, 2018-09-24 at 23:08 -0700, dhinakaran.pandiyan@gmail.com wrote:
> On Thu, 2018-09-20 at 13:43 -0700, José Roberto de Souza wrote:
> > ALPM is a requirement and we don't need to keep it's cached, what
> > were done in commit 97c9de66ca80
> > ("drm/i915/psr: Fix ALPM cap check for PSR2") but the alpm was not
> > removed from i915_psr.:
> 
> You're right.
> 
> Reviewed-by: Dhinakaran Pandiyan <dhinakaran.pandiyan@intel.com>
> 
> > 
> > Cc: Dhinakaran Pandiyan <dhinakaran.pandiyan@intel.com>
> > Signed-off-by: José Roberto de Souza <jose.souza@intel.com>
> > ---
> >  drivers/gpu/drm/i915/i915_drv.h | 1 -
> >  1 file changed, 1 deletion(-)
> > 
> > diff --git a/drivers/gpu/drm/i915/i915_drv.h
> > b/drivers/gpu/drm/i915/i915_drv.h
> > index 41f1082da122..4ed129cf4d12 100644
> > --- a/drivers/gpu/drm/i915/i915_drv.h
> > +++ b/drivers/gpu/drm/i915/i915_drv.h
> > @@ -630,7 +630,6 @@ struct i915_psr {
> 
> We should rename this intel_psr and move it to the same file where
> struct intel_dp lives.

Sounds a better place indeed but it would just cost more memory as we
don't enable PSR in regular DP ports also it would cause conflicts in
most of the PSR patches that we have pending, maybe we can think about
it after enable PSR by default?

> 
> 
> >  	bool sink_psr2_support;
> >  	bool link_standby;
> >  	bool colorimetry_support;
> > -	bool alpm;
> >  	bool psr2_enabled;
> 
> And rename this too?  The bool is set to enable_psr2 and does not
> mean
> PSR2 is enabled.

It have the same meaning as 'enabled', it means that sink is configured
to PSR2 and source have PSR2 hardware enabled but it do not mean that
is active at the moment.

> 
> 
> >  	u8 sink_sync_latency;
> >  	ktime_t last_entry_attempt;
diff mbox series

Patch

diff --git a/drivers/gpu/drm/i915/i915_drv.h b/drivers/gpu/drm/i915/i915_drv.h
index 41f1082da122..4ed129cf4d12 100644
--- a/drivers/gpu/drm/i915/i915_drv.h
+++ b/drivers/gpu/drm/i915/i915_drv.h
@@ -630,7 +630,6 @@  struct i915_psr {
 	bool sink_psr2_support;
 	bool link_standby;
 	bool colorimetry_support;
-	bool alpm;
 	bool psr2_enabled;
 	u8 sink_sync_latency;
 	ktime_t last_entry_attempt;