[20/21] drm/todo: Add some cleanup tasks
diff mbox series

Message ID 20181004202446.22905-21-daniel.vetter@ffwll.ch
State New
Headers show
Series
  • atomic helper cleanup, take 2
Related show

Commit Message

Daniel Vetter Oct. 4, 2018, 8:24 p.m. UTC
Motivated by review comments from Ville&Sean.

Cc: Ville Syrjälä <ville.syrjala@linux.intel.com>
Cc: Sean Paul <sean@poorly.run>
Signed-off-by: Daniel Vetter <daniel.vetter@intel.com>
---
 Documentation/gpu/todo.rst | 10 ++++++++++
 1 file changed, 10 insertions(+)

Comments

Ville Syrjälä Oct. 4, 2018, 8:35 p.m. UTC | #1
On Thu, Oct 04, 2018 at 10:24:45PM +0200, Daniel Vetter wrote:
> Motivated by review comments from Ville&Sean.
> 
> Cc: Ville Syrjälä <ville.syrjala@linux.intel.com>
> Cc: Sean Paul <sean@poorly.run>
> Signed-off-by: Daniel Vetter <daniel.vetter@intel.com>

Reviewed-by: Ville Syrjälä <ville.syrjala@linux.intel.com>

> ---
>  Documentation/gpu/todo.rst | 10 ++++++++++
>  1 file changed, 10 insertions(+)
> 
> diff --git a/Documentation/gpu/todo.rst b/Documentation/gpu/todo.rst
> index 77c2b3c25565..5c9d86c962af 100644
> --- a/Documentation/gpu/todo.rst
> +++ b/Documentation/gpu/todo.rst
> @@ -339,6 +339,16 @@ Some of these date from the very introduction of KMS in 2008 ...
>    leftovers from older (never merged into upstream) KMS designs where modes
>    where set using their ID, including support to add/remove modes.
>  
> +- Make ->funcs and ->helper_private vtables optional. There's a bunch of empty
> +  function tables in drivers, but before we can remove them we need to make sure
> +  that all the users in helpers and drivers do correctly check for a NULL
> +  vtable.
> +
> +- Cleanup up the various ->destroy callbacks. A lot of them just wrapt the
> +  drm_*_cleanup implementations and can be removed. Some tack a kfree() at the
> +  end, for which we could add drm_*_cleanup_kfree(). And then there's the (for
> +  historical reasons) misnamed drm_primary_helper_destroy() function.
> +
>  Better Testing
>  ==============
>  
> -- 
> 2.19.0.rc2
Harry Wentland Oct. 5, 2018, 4:07 p.m. UTC | #2
On 2018-10-04 04:24 PM, Daniel Vetter wrote:
> Motivated by review comments from Ville&Sean.
> 
> Cc: Ville Syrjälä <ville.syrjala@linux.intel.com>
> Cc: Sean Paul <sean@poorly.run>
> Signed-off-by: Daniel Vetter <daniel.vetter@intel.com>

Acked-by: Harry Wentland <harry.wentland@amd.com>

Harry

> ---
>  Documentation/gpu/todo.rst | 10 ++++++++++
>  1 file changed, 10 insertions(+)
> 
> diff --git a/Documentation/gpu/todo.rst b/Documentation/gpu/todo.rst
> index 77c2b3c25565..5c9d86c962af 100644
> --- a/Documentation/gpu/todo.rst
> +++ b/Documentation/gpu/todo.rst
> @@ -339,6 +339,16 @@ Some of these date from the very introduction of KMS in 2008 ...
>    leftovers from older (never merged into upstream) KMS designs where modes
>    where set using their ID, including support to add/remove modes.
>  
> +- Make ->funcs and ->helper_private vtables optional. There's a bunch of empty
> +  function tables in drivers, but before we can remove them we need to make sure
> +  that all the users in helpers and drivers do correctly check for a NULL
> +  vtable.
> +
> +- Cleanup up the various ->destroy callbacks. A lot of them just wrapt the
> +  drm_*_cleanup implementations and can be removed. Some tack a kfree() at the
> +  end, for which we could add drm_*_cleanup_kfree(). And then there's the (for
> +  historical reasons) misnamed drm_primary_helper_destroy() function.
> +
>  Better Testing
>  ==============
>  
>
Eric Engestrom Oct. 5, 2018, 4:20 p.m. UTC | #3
On Friday, 2018-10-05 12:07:26 -0400, Harry Wentland wrote:
> On 2018-10-04 04:24 PM, Daniel Vetter wrote:
> > Motivated by review comments from Ville&Sean.
> > 
> > Cc: Ville Syrjälä <ville.syrjala@linux.intel.com>
> > Cc: Sean Paul <sean@poorly.run>
> > Signed-off-by: Daniel Vetter <daniel.vetter@intel.com>
> 
> Acked-by: Harry Wentland <harry.wentland@amd.com>
> 
> Harry
> 
> > ---
> >  Documentation/gpu/todo.rst | 10 ++++++++++
> >  1 file changed, 10 insertions(+)
> > 
> > diff --git a/Documentation/gpu/todo.rst b/Documentation/gpu/todo.rst
> > index 77c2b3c25565..5c9d86c962af 100644
> > --- a/Documentation/gpu/todo.rst
> > +++ b/Documentation/gpu/todo.rst
> > @@ -339,6 +339,16 @@ Some of these date from the very introduction of KMS in 2008 ...
> >    leftovers from older (never merged into upstream) KMS designs where modes
> >    where set using their ID, including support to add/remove modes.
> >  
> > +- Make ->funcs and ->helper_private vtables optional. There's a bunch of empty
> > +  function tables in drivers, but before we can remove them we need to make sure
> > +  that all the users in helpers and drivers do correctly check for a NULL
> > +  vtable.
> > +
> > +- Cleanup up the various ->destroy callbacks. A lot of them just wrapt the

small typo: s/wrapt/wrap/

> > +  drm_*_cleanup implementations and can be removed. Some tack a kfree() at the
> > +  end, for which we could add drm_*_cleanup_kfree(). And then there's the (for
> > +  historical reasons) misnamed drm_primary_helper_destroy() function.
> > +
> >  Better Testing
> >  ==============
> >  
> >

Patch
diff mbox series

diff --git a/Documentation/gpu/todo.rst b/Documentation/gpu/todo.rst
index 77c2b3c25565..5c9d86c962af 100644
--- a/Documentation/gpu/todo.rst
+++ b/Documentation/gpu/todo.rst
@@ -339,6 +339,16 @@  Some of these date from the very introduction of KMS in 2008 ...
   leftovers from older (never merged into upstream) KMS designs where modes
   where set using their ID, including support to add/remove modes.
 
+- Make ->funcs and ->helper_private vtables optional. There's a bunch of empty
+  function tables in drivers, but before we can remove them we need to make sure
+  that all the users in helpers and drivers do correctly check for a NULL
+  vtable.
+
+- Cleanup up the various ->destroy callbacks. A lot of them just wrapt the
+  drm_*_cleanup implementations and can be removed. Some tack a kfree() at the
+  end, for which we could add drm_*_cleanup_kfree(). And then there's the (for
+  historical reasons) misnamed drm_primary_helper_destroy() function.
+
 Better Testing
 ==============