diff mbox series

[RFC,3/3] drm/i915: Kill GEN_FOREVER

Message ID 20181023233620.10159-3-rodrigo.vivi@intel.com (mailing list archive)
State New, archived
Headers show
Series [RFC,1/3] drm/i915: Rename IS_GEN to IS_GEN_RANGE. | expand

Commit Message

Rodrigo Vivi Oct. 23, 2018, 11:36 p.m. UTC
commit ac657f6461e5 ("drm/i915: Introduce IS_GEN macro") introduced
GEN_FOREVER that was never used.

My first attempt was to rename it to FOREVER since GEN is
already part of the macro. Then I used coccinelle to change all
-INTEL_GEN(e1) >= e2
+INTEL_GEN_RANGE(e1, e2, FOREVER)
-INTEL_GEN(e1) <= e2
+INTEL_GEN_RANGE(e1, 0, e2)

and I liked it.

However I didn't like very much the remaining
INTEL_GEN(dev_priv) < n

and:
INTEL_GEN(e1) < n
INTEL_GEN_RANGE(e1, 0, n - 1)

didn't make much sense either.

So INTEL_GEN use for > or < seems a better unified way for unlimited
bounds. So, no reason to keep GEN_FOREVER here.

Let's kill before someone start using it.

Cc: Tvrtko Ursulin <tvrtko.ursulin@intel.com>
Signed-off-by: Rodrigo Vivi <rodrigo.vivi@intel.com>
---
 drivers/gpu/drm/i915/i915_drv.h | 6 +-----
 1 file changed, 1 insertion(+), 5 deletions(-)

Comments

Daniel Vetter Oct. 24, 2018, 12:31 p.m. UTC | #1
On Tue, Oct 23, 2018 at 04:36:20PM -0700, Rodrigo Vivi wrote:
> commit ac657f6461e5 ("drm/i915: Introduce IS_GEN macro") introduced
> GEN_FOREVER that was never used.
> 
> My first attempt was to rename it to FOREVER since GEN is
> already part of the macro. Then I used coccinelle to change all
> -INTEL_GEN(e1) >= e2
> +INTEL_GEN_RANGE(e1, e2, FOREVER)
> -INTEL_GEN(e1) <= e2
> +INTEL_GEN_RANGE(e1, 0, e2)
> 
> and I liked it.
> 
> However I didn't like very much the remaining
> INTEL_GEN(dev_priv) < n
> 
> and:
> INTEL_GEN(e1) < n
> INTEL_GEN_RANGE(e1, 0, n - 1)
> 
> didn't make much sense either.
> 
> So INTEL_GEN use for > or < seems a better unified way for unlimited
> bounds. So, no reason to keep GEN_FOREVER here.
> 
> Let's kill before someone start using it.
> 
> Cc: Tvrtko Ursulin <tvrtko.ursulin@intel.com>
> Signed-off-by: Rodrigo Vivi <rodrigo.vivi@intel.com>
> ---
>  drivers/gpu/drm/i915/i915_drv.h | 6 +-----
>  1 file changed, 1 insertion(+), 5 deletions(-)
> 
> diff --git a/drivers/gpu/drm/i915/i915_drv.h b/drivers/gpu/drm/i915/i915_drv.h
> index f766bb1e873b..24f17e711772 100644
> --- a/drivers/gpu/drm/i915/i915_drv.h
> +++ b/drivers/gpu/drm/i915/i915_drv.h
> @@ -2373,14 +2373,10 @@ intel_info(const struct drm_i915_private *dev_priv)
>  #define REVID_FOREVER		0xff
>  #define INTEL_REVID(dev_priv)	((dev_priv)->drm.pdev->revision)
>  
> -#define GEN_FOREVER (0)
> -
>  #define INTEL_GEN_MASK(s, e) ( \
>  	BUILD_BUG_ON_ZERO(!__builtin_constant_p(s)) + \
>  	BUILD_BUG_ON_ZERO(!__builtin_constant_p(e)) + \
> -	GENMASK((e) != GEN_FOREVER ? (e) - 1 : BITS_PER_LONG - 1, \
> -		(s) != GEN_FOREVER ? (s) - 1 : 0) \
> -)
> +	GENMASK((e) - 1, (s) - 1))
>  
>  /*
>   * Returns true if Gen is in inclusive range [Start, End].

You missed GEN_FOREVER a bit below here in a comment. With that fixed, on
the series:

Reviewed-by: Daniel Vetter <daniel.vetter@ffwll.ch>

> -- 
> 2.19.1
> 
> _______________________________________________
> Intel-gfx mailing list
> Intel-gfx@lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/intel-gfx
diff mbox series

Patch

diff --git a/drivers/gpu/drm/i915/i915_drv.h b/drivers/gpu/drm/i915/i915_drv.h
index f766bb1e873b..24f17e711772 100644
--- a/drivers/gpu/drm/i915/i915_drv.h
+++ b/drivers/gpu/drm/i915/i915_drv.h
@@ -2373,14 +2373,10 @@  intel_info(const struct drm_i915_private *dev_priv)
 #define REVID_FOREVER		0xff
 #define INTEL_REVID(dev_priv)	((dev_priv)->drm.pdev->revision)
 
-#define GEN_FOREVER (0)
-
 #define INTEL_GEN_MASK(s, e) ( \
 	BUILD_BUG_ON_ZERO(!__builtin_constant_p(s)) + \
 	BUILD_BUG_ON_ZERO(!__builtin_constant_p(e)) + \
-	GENMASK((e) != GEN_FOREVER ? (e) - 1 : BITS_PER_LONG - 1, \
-		(s) != GEN_FOREVER ? (s) - 1 : 0) \
-)
+	GENMASK((e) - 1, (s) - 1))
 
 /*
  * Returns true if Gen is in inclusive range [Start, End].