diff mbox series

mbcache: change setting entry->e_reusable for more readable code

Message ID 20181115064233.21294-1-cgxu519@gmx.com (mailing list archive)
State New, archived
Headers show
Series mbcache: change setting entry->e_reusable for more readable code | expand

Commit Message

Chengguang Xu Nov. 15, 2018, 6:42 a.m. UTC
Instead of directly setting entry->e_reusable to parameter reusable,
cheek the bool value for more readable code.

Signed-off-by: Chengguang Xu <cgxu519@gmx.com>
---
 fs/mbcache.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Al Viro Nov. 15, 2018, 6:57 a.m. UTC | #1
On Thu, Nov 15, 2018 at 02:42:33PM +0800, Chengguang Xu wrote:
> Instead of directly setting entry->e_reusable to parameter reusable,
> cheek the bool value for more readable code.
> 
> Signed-off-by: Chengguang Xu <cgxu519@gmx.com>
> ---
>  fs/mbcache.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/fs/mbcache.c b/fs/mbcache.c
> index 081ccf0caee3..39ec9fd8bacf 100644
> --- a/fs/mbcache.c
> +++ b/fs/mbcache.c
> @@ -93,7 +93,7 @@ int mb_cache_entry_create(struct mb_cache *cache, gfp_t mask, u32 key,
>  	atomic_set(&entry->e_refcnt, 1);
>  	entry->e_key = key;
>  	entry->e_value = value;
> -	entry->e_reusable = reusable;
> +	entry->e_reusable = reusable ? 1 : 0;

Huh?  How is that more readable?
diff mbox series

Patch

diff --git a/fs/mbcache.c b/fs/mbcache.c
index 081ccf0caee3..39ec9fd8bacf 100644
--- a/fs/mbcache.c
+++ b/fs/mbcache.c
@@ -93,7 +93,7 @@  int mb_cache_entry_create(struct mb_cache *cache, gfp_t mask, u32 key,
 	atomic_set(&entry->e_refcnt, 1);
 	entry->e_key = key;
 	entry->e_value = value;
-	entry->e_reusable = reusable;
+	entry->e_reusable = reusable ? 1 : 0;
 	entry->e_referenced = 0;
 	head = mb_cache_entry_head(cache, key);
 	hlist_bl_lock(head);