diff mbox series

mtd: rawnand: sunxi: Use struct_size() in devm_kzalloc()

Message ID 20190104172637.GA28084@embeddedor (mailing list archive)
State New, archived
Headers show
Series mtd: rawnand: sunxi: Use struct_size() in devm_kzalloc() | expand

Commit Message

Gustavo A. R. Silva Jan. 4, 2019, 5:26 p.m. UTC
One of the more common cases of allocation size calculations is finding
the size of a structure that has a zero-sized array at the end, along
with memory for some number of elements for that array. For example:

struct foo {
    int stuff;
    void *entry[];
};

instance = devm_kzalloc(dev, sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);

Instead of leaving these open-coded and prone to type mistakes, we can
now use the new struct_size() helper:

instance = devm_kzalloc(dev, struct_size(instance, entry, count), GFP_KERNEL);

This code was detected with the help of Coccinelle.

Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com>
---
 drivers/mtd/nand/raw/sunxi_nand.c | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

Comments

Boris Brezillon Jan. 4, 2019, 6:14 p.m. UTC | #1
Hi Gustavo,

On Fri, 4 Jan 2019 11:26:37 -0600
"Gustavo A. R. Silva" <gustavo@embeddedor.com> wrote:

> One of the more common cases of allocation size calculations is finding
> the size of a structure that has a zero-sized array at the end, along
> with memory for some number of elements for that array. For example:
> 
> struct foo {
>     int stuff;
>     void *entry[];
> };
> 
> instance = devm_kzalloc(dev, sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);
> 
> Instead of leaving these open-coded and prone to type mistakes, we can
> now use the new struct_size() helper:
> 
> instance = devm_kzalloc(dev, struct_size(instance, entry, count), GFP_KERNEL);
> 
> This code was detected with the help of Coccinelle.
> 
> Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com>
> ---
>  drivers/mtd/nand/raw/sunxi_nand.c | 5 +----
>  1 file changed, 1 insertion(+), 4 deletions(-)
> 
> diff --git a/drivers/mtd/nand/raw/sunxi_nand.c b/drivers/mtd/nand/raw/sunxi_nand.c
> index e828ee50a201..f66fffe663bf 100644
> --- a/drivers/mtd/nand/raw/sunxi_nand.c
> +++ b/drivers/mtd/nand/raw/sunxi_nand.c
> @@ -1870,10 +1870,7 @@ static int sunxi_nand_chip_init(struct device *dev, struct sunxi_nfc *nfc,
>  		return -EINVAL;
>  	}
>  
> -	chip = devm_kzalloc(dev,
> -			    sizeof(*chip) +
> -			    (nsels * sizeof(struct sunxi_nand_chip_sel)),
> -			    GFP_KERNEL);
> +	chip = devm_kzalloc(dev, struct_size(chip, sels, nsels), GFP_KERNEL);
>  	if (!chip) {
>  		dev_err(dev, "could not allocate chip\n");
>  		return -ENOMEM;

I posted the same patch a few days back [1].

[1]http://patchwork.ozlabs.org/patch/1013855/
Gustavo A. R. Silva Jan. 4, 2019, 6:22 p.m. UTC | #2
Hey Boris,

On 1/4/19 12:14 PM, Boris Brezillon wrote:

> 
> I posted the same patch a few days back [1].
> 
> [1]http://patchwork.ozlabs.org/patch/1013855/
> 

Oh, that's great.

It's good to see people adopting the struct_size helper. :)

Happy new year.

Thanks
--
Gustavo
diff mbox series

Patch

diff --git a/drivers/mtd/nand/raw/sunxi_nand.c b/drivers/mtd/nand/raw/sunxi_nand.c
index e828ee50a201..f66fffe663bf 100644
--- a/drivers/mtd/nand/raw/sunxi_nand.c
+++ b/drivers/mtd/nand/raw/sunxi_nand.c
@@ -1870,10 +1870,7 @@  static int sunxi_nand_chip_init(struct device *dev, struct sunxi_nfc *nfc,
 		return -EINVAL;
 	}
 
-	chip = devm_kzalloc(dev,
-			    sizeof(*chip) +
-			    (nsels * sizeof(struct sunxi_nand_chip_sel)),
-			    GFP_KERNEL);
+	chip = devm_kzalloc(dev, struct_size(chip, sels, nsels), GFP_KERNEL);
 	if (!chip) {
 		dev_err(dev, "could not allocate chip\n");
 		return -ENOMEM;