diff mbox series

block/blk-sysfs.c: Remove last reference of blk_init_queue

Message ID 20190115030615.1090578-1-marcos.souza.org@gmail.com (mailing list archive)
State New, archived
Headers show
Series block/blk-sysfs.c: Remove last reference of blk_init_queue | expand

Commit Message

Marcos Paulo de Souza Jan. 15, 2019, 3:06 a.m. UTC
blk_init_queue was removed in a1ce35fa4985.

Signed-off-by: Marcos Paulo de Souza <marcos.souza.org@gmail.com>
---
 There are more two references in Documentation/block/biodoc.txt, but maybe that
 file needs a rewrite in rst anyway?

 block/blk-sysfs.c | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

Comments

Jens Axboe Jan. 15, 2019, 3:54 a.m. UTC | #1
On 1/14/19 8:06 PM, Marcos Paulo de Souza wrote:
> blk_init_queue was removed in a1ce35fa4985.

Honestly, most of that comment is wrong anyway. Since this isn't
a visible API, I'd just kill the comment completely.

> Signed-off-by: Marcos Paulo de Souza <marcos.souza.org@gmail.com>
> ---
>  There are more two references in Documentation/block/biodoc.txt, but maybe that
>  file needs a rewrite in rst anyway?

It probably needs a rewrite - period :-)
Marcos Paulo de Souza Jan. 15, 2019, 10:29 a.m. UTC | #2
HI Jeans,

On 1/15/19 1:54 AM, Jens Axboe wrote:
> On 1/14/19 8:06 PM, Marcos Paulo de Souza wrote:
>> blk_init_queue was removed in a1ce35fa4985.
> 
> Honestly, most of that comment is wrong anyway. Since this isn't
> a visible API, I'd just kill the comment completely.

I will send a v2 trying to describe better what the function does and
where it is used (or removed it completely as you suggested).

> 
>> Signed-off-by: Marcos Paulo de Souza <marcos.souza.org@gmail.com>
>> ---
>>  There are more two references in Documentation/block/biodoc.txt, but maybe that
>>  file needs a rewrite in rst anyway?
> 
> It probably needs a rewrite - period :-)
>
diff mbox series

Patch

diff --git a/block/blk-sysfs.c b/block/blk-sysfs.c
index 590d1ef2f961..dd9b50226c6e 100644
--- a/block/blk-sysfs.c
+++ b/block/blk-sysfs.c
@@ -821,10 +821,9 @@  static void blk_free_queue_rcu(struct rcu_head *rcu_head)
  * @work: pointer to the release_work member of the request queue to be released
  *
  * Description:
- *     blk_release_queue is the counterpart of blk_init_queue(). It should be
- *     called when a request queue is being released; typically when a block
- *     device is being de-registered. Its primary task it to free the queue
- *     itself.
+ *     Should be called when a request queue is being released;
+ *     typically when a block device is being de-registered. Its primary task it
+ *     to free the queue itself.
  *
  * Notes:
  *     The low level driver must have finished any outstanding requests first