diff mbox series

vmstate: check subsection_found is enough

Message ID 20190402025728.5636-1-richardw.yang@linux.intel.com (mailing list archive)
State New, archived
Headers show
Series vmstate: check subsection_found is enough | expand

Commit Message

Wei Yang April 2, 2019, 2:57 a.m. UTC
subsection_found is true implies vmdesc is not NULL.

Signed-off-by: Wei Yang <richardw.yang@linux.intel.com>
---
 migration/vmstate.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Dr. David Alan Gilbert April 2, 2019, 6:44 p.m. UTC | #1
* Wei Yang (richardw.yang@linux.intel.com) wrote:
> subsection_found is true implies vmdesc is not NULL.
> 
> Signed-off-by: Wei Yang <richardw.yang@linux.intel.com>
> ---
>  migration/vmstate.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/migration/vmstate.c b/migration/vmstate.c
> index e2bbb7b5f7..8327179eea 100644
> --- a/migration/vmstate.c
> +++ b/migration/vmstate.c
> @@ -533,7 +533,7 @@ static int vmstate_subsection_save(QEMUFile *f, const VMStateDescription *vmsd,
>          sub++;
>      }
>  
> -    if (vmdesc && subsection_found) {
> +    if (subsection_found) {

That's true, however it's not obvious from the names; I think
we should probably rename 'subsection_found' to something like
'vmdesc_has_subsections'  then it's more obvious that subsection_found
is more specialised in this routine.

Dave


>          json_end_array(vmdesc);
>      }
>  
> -- 
> 2.19.1
> 
--
Dr. David Alan Gilbert / dgilbert@redhat.com / Manchester, UK
Wei Yang April 3, 2019, 1:03 a.m. UTC | #2
On Tue, Apr 02, 2019 at 07:44:23PM +0100, Dr. David Alan Gilbert wrote:
>* Wei Yang (richardw.yang@linux.intel.com) wrote:
>> subsection_found is true implies vmdesc is not NULL.
>> 
>> Signed-off-by: Wei Yang <richardw.yang@linux.intel.com>
>> ---
>>  migration/vmstate.c | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>> 
>> diff --git a/migration/vmstate.c b/migration/vmstate.c
>> index e2bbb7b5f7..8327179eea 100644
>> --- a/migration/vmstate.c
>> +++ b/migration/vmstate.c
>> @@ -533,7 +533,7 @@ static int vmstate_subsection_save(QEMUFile *f, const VMStateDescription *vmsd,
>>          sub++;
>>      }
>>  
>> -    if (vmdesc && subsection_found) {
>> +    if (subsection_found) {
>
>That's true, however it's not obvious from the names; I think
>we should probably rename 'subsection_found' to something like
>'vmdesc_has_subsections'  then it's more obvious that subsection_found
>is more specialised in this routine.

Reasonable, let me change it :-)

>
>Dave
>
>
>>          json_end_array(vmdesc);
>>      }
>>  
>> -- 
>> 2.19.1
>> 
>--
>Dr. David Alan Gilbert / dgilbert@redhat.com / Manchester, UK
diff mbox series

Patch

diff --git a/migration/vmstate.c b/migration/vmstate.c
index e2bbb7b5f7..8327179eea 100644
--- a/migration/vmstate.c
+++ b/migration/vmstate.c
@@ -533,7 +533,7 @@  static int vmstate_subsection_save(QEMUFile *f, const VMStateDescription *vmsd,
         sub++;
     }
 
-    if (vmdesc && subsection_found) {
+    if (subsection_found) {
         json_end_array(vmdesc);
     }