diff mbox series

libx86: Introduce wrappers for extracting XCR0/XSS from a cpuid policy

Message ID 1558607223-19630-1-git-send-email-andrew.cooper3@citrix.com (mailing list archive)
State New, archived
Headers show
Series libx86: Introduce wrappers for extracting XCR0/XSS from a cpuid policy | expand

Commit Message

Andrew Cooper May 23, 2019, 10:27 a.m. UTC
This avoids opencoding the slightly-awkward logic.  More uses of these
wrappers will be introduced shortly.

Signed-off-by: Andrew Cooper <andrew.cooper3@citrix.com>
---
CC: Jan Beulich <JBeulich@suse.com>
CC: Wei Liu <wei.liu2@citrix.com>
CC: Roger Pau Monné <roger.pau@citrix.com>

I've decided to introduce this patch ahead of "[PATCH] libx86: Elide more
empty CPUID leaves when serialising a policy" (which simplifies the xstate
hunk a little) as I've found yet more cases where I need to use
cpuid_policy_xstates(), and opencoding them all seemed very silly.
---
 xen/arch/x86/xstate.c           |  8 ++------
 xen/include/xen/lib/x86/cpuid.h | 12 ++++++++++++
 xen/lib/x86/cpuid.c             |  3 +--
 3 files changed, 15 insertions(+), 8 deletions(-)

Comments

Jan Beulich May 23, 2019, 11:52 a.m. UTC | #1
>>> On 23.05.19 at 12:27, <andrew.cooper3@citrix.com> wrote:
> --- a/xen/arch/x86/xstate.c
> +++ b/xen/arch/x86/xstate.c
> @@ -660,9 +660,7 @@ static bool valid_xcr0(u64 xcr0)
>  int validate_xstate(const struct domain *d, uint64_t xcr0, uint64_t xcr0_accum,
>                      const struct xsave_hdr *hdr)
>  {
> -    const struct cpuid_policy *cp = d->arch.cpuid;
> -    uint64_t xcr0_max =
> -        ((uint64_t)cp->xstate.xcr0_high << 32) | cp->xstate.xcr0_low;
> +    uint64_t xcr0_max = cpuid_policy_xcr0(d->arch.cpuid);
>      unsigned int i;
>  
>      if ( (hdr->xstate_bv & ~xcr0_accum) ||
> @@ -686,9 +684,7 @@ int validate_xstate(const struct domain *d, uint64_t xcr0, uint64_t xcr0_accum,
>  int handle_xsetbv(u32 index, u64 new_bv)
>  {
>      struct vcpu *curr = current;
> -    const struct cpuid_policy *cp = curr->domain->arch.cpuid;
> -    uint64_t xcr0_max =
> -        ((uint64_t)cp->xstate.xcr0_high << 32) | cp->xstate.xcr0_low;
> +    uint64_t xcr0_max = cpuid_policy_xcr0(curr->domain->arch.cpuid);

In both cases the variables are more appropriately named than
the new helper. While I agree it's slightly more typing, did you
consider calling it cpuid_policy_xcr0_max()?

> --- a/xen/include/xen/lib/x86/cpuid.h
> +++ b/xen/include/xen/lib/x86/cpuid.h
> @@ -308,6 +308,18 @@ static inline void cpuid_featureset_to_policy(
>      p->feat._7a1  = fs[FEATURESET_7a1];
>  }
>  
> +static inline uint64_t cpuid_policy_xcr0(const struct cpuid_policy *p)
> +{
> +    return ((uint64_t)p->xstate.xcr0_high << 32) | p->xstate.xcr0_low;
> +}
> +
> +static inline uint64_t cpuid_policy_xstates(const struct cpuid_policy *p)
> +{
> +    uint64_t val = p->xstate.xcr0_high | p->xstate.xss_high;
> +
> +    return (val << 32) | p->xstate.xcr0_low | p->xstate.xss_low;
> +}

How about also having cpuid_policy_xss() (or cpuid_policy_xss_max())
and then simply making cpuid_policy_xstates() combine the two
results?

Anyway, as I can also live with things as they are, with or without
either of the suggested changes
Reviewed-by: Jan Beulich <jbeulich@suse.com>

Jan
Andrew Cooper May 23, 2019, 11:59 a.m. UTC | #2
On 23/05/2019 12:52, Jan Beulich wrote:
>>>> On 23.05.19 at 12:27, <andrew.cooper3@citrix.com> wrote:
>> --- a/xen/arch/x86/xstate.c
>> +++ b/xen/arch/x86/xstate.c
>> @@ -660,9 +660,7 @@ static bool valid_xcr0(u64 xcr0)
>>  int validate_xstate(const struct domain *d, uint64_t xcr0, uint64_t xcr0_accum,
>>                      const struct xsave_hdr *hdr)
>>  {
>> -    const struct cpuid_policy *cp = d->arch.cpuid;
>> -    uint64_t xcr0_max =
>> -        ((uint64_t)cp->xstate.xcr0_high << 32) | cp->xstate.xcr0_low;
>> +    uint64_t xcr0_max = cpuid_policy_xcr0(d->arch.cpuid);
>>      unsigned int i;
>>  
>>      if ( (hdr->xstate_bv & ~xcr0_accum) ||
>> @@ -686,9 +684,7 @@ int validate_xstate(const struct domain *d, uint64_t xcr0, uint64_t xcr0_accum,
>>  int handle_xsetbv(u32 index, u64 new_bv)
>>  {
>>      struct vcpu *curr = current;
>> -    const struct cpuid_policy *cp = curr->domain->arch.cpuid;
>> -    uint64_t xcr0_max =
>> -        ((uint64_t)cp->xstate.xcr0_high << 32) | cp->xstate.xcr0_low;
>> +    uint64_t xcr0_max = cpuid_policy_xcr0(curr->domain->arch.cpuid);
> In both cases the variables are more appropriately named than
> the new helper. While I agree it's slightly more typing, did you
> consider calling it cpuid_policy_xcr0_max()?

Fine.

>
>> --- a/xen/include/xen/lib/x86/cpuid.h
>> +++ b/xen/include/xen/lib/x86/cpuid.h
>> @@ -308,6 +308,18 @@ static inline void cpuid_featureset_to_policy(
>>      p->feat._7a1  = fs[FEATURESET_7a1];
>>  }
>>  
>> +static inline uint64_t cpuid_policy_xcr0(const struct cpuid_policy *p)
>> +{
>> +    return ((uint64_t)p->xstate.xcr0_high << 32) | p->xstate.xcr0_low;
>> +}
>> +
>> +static inline uint64_t cpuid_policy_xstates(const struct cpuid_policy *p)
>> +{
>> +    uint64_t val = p->xstate.xcr0_high | p->xstate.xss_high;
>> +
>> +    return (val << 32) | p->xstate.xcr0_low | p->xstate.xss_low;
>> +}
> How about also having cpuid_policy_xss() (or cpuid_policy_xss_max())
> and then simply making cpuid_policy_xstates() combine the two
> results?

I started with that, but the resulting code was a little awkward to
read, and the asm generation was a little worse due to promoting
everything first.

I don't think we need cpuid_policy_xss{,_max}() until we actually
implement something for guests (most likely CET at this rate).

>
> Anyway, as I can also live with things as they are, with or without
> either of the suggested changes
> Reviewed-by: Jan Beulich <jbeulich@suse.com>

Thanks (although I'm still happy to play around with naming).

~Andrew
Jan Beulich May 23, 2019, 12:08 p.m. UTC | #3
>>> On 23.05.19 at 13:59, <andrew.cooper3@citrix.com> wrote:
> On 23/05/2019 12:52, Jan Beulich wrote:
>>>>> On 23.05.19 at 12:27, <andrew.cooper3@citrix.com> wrote:
>>> --- a/xen/include/xen/lib/x86/cpuid.h
>>> +++ b/xen/include/xen/lib/x86/cpuid.h
>>> @@ -308,6 +308,18 @@ static inline void cpuid_featureset_to_policy(
>>>      p->feat._7a1  = fs[FEATURESET_7a1];
>>>  }
>>>  
>>> +static inline uint64_t cpuid_policy_xcr0(const struct cpuid_policy *p)
>>> +{
>>> +    return ((uint64_t)p->xstate.xcr0_high << 32) | p->xstate.xcr0_low;
>>> +}
>>> +
>>> +static inline uint64_t cpuid_policy_xstates(const struct cpuid_policy *p)
>>> +{
>>> +    uint64_t val = p->xstate.xcr0_high | p->xstate.xss_high;
>>> +
>>> +    return (val << 32) | p->xstate.xcr0_low | p->xstate.xss_low;
>>> +}
>> How about also having cpuid_policy_xss() (or cpuid_policy_xss_max())
>> and then simply making cpuid_policy_xstates() combine the two
>> results?
> 
> I started with that, but the resulting code was a little awkward to
> read, and the asm generation was a little worse due to promoting
> everything first.
> 
> I don't think we need cpuid_policy_xss{,_max}() until we actually
> implement something for guests (most likely CET at this rate).

Well, let's stick to what you have then.

Jan
diff mbox series

Patch

diff --git a/xen/arch/x86/xstate.c b/xen/arch/x86/xstate.c
index 3da609a..04da569 100644
--- a/xen/arch/x86/xstate.c
+++ b/xen/arch/x86/xstate.c
@@ -660,9 +660,7 @@  static bool valid_xcr0(u64 xcr0)
 int validate_xstate(const struct domain *d, uint64_t xcr0, uint64_t xcr0_accum,
                     const struct xsave_hdr *hdr)
 {
-    const struct cpuid_policy *cp = d->arch.cpuid;
-    uint64_t xcr0_max =
-        ((uint64_t)cp->xstate.xcr0_high << 32) | cp->xstate.xcr0_low;
+    uint64_t xcr0_max = cpuid_policy_xcr0(d->arch.cpuid);
     unsigned int i;
 
     if ( (hdr->xstate_bv & ~xcr0_accum) ||
@@ -686,9 +684,7 @@  int validate_xstate(const struct domain *d, uint64_t xcr0, uint64_t xcr0_accum,
 int handle_xsetbv(u32 index, u64 new_bv)
 {
     struct vcpu *curr = current;
-    const struct cpuid_policy *cp = curr->domain->arch.cpuid;
-    uint64_t xcr0_max =
-        ((uint64_t)cp->xstate.xcr0_high << 32) | cp->xstate.xcr0_low;
+    uint64_t xcr0_max = cpuid_policy_xcr0(curr->domain->arch.cpuid);
     u64 mask;
 
     if ( index != XCR_XFEATURE_ENABLED_MASK )
diff --git a/xen/include/xen/lib/x86/cpuid.h b/xen/include/xen/lib/x86/cpuid.h
index 252d2c9..ea4db5b 100644
--- a/xen/include/xen/lib/x86/cpuid.h
+++ b/xen/include/xen/lib/x86/cpuid.h
@@ -308,6 +308,18 @@  static inline void cpuid_featureset_to_policy(
     p->feat._7a1  = fs[FEATURESET_7a1];
 }
 
+static inline uint64_t cpuid_policy_xcr0(const struct cpuid_policy *p)
+{
+    return ((uint64_t)p->xstate.xcr0_high << 32) | p->xstate.xcr0_low;
+}
+
+static inline uint64_t cpuid_policy_xstates(const struct cpuid_policy *p)
+{
+    uint64_t val = p->xstate.xcr0_high | p->xstate.xss_high;
+
+    return (val << 32) | p->xstate.xcr0_low | p->xstate.xss_low;
+}
+
 const uint32_t *x86_cpuid_lookup_deep_deps(uint32_t feature);
 
 /**
diff --git a/xen/lib/x86/cpuid.c b/xen/lib/x86/cpuid.c
index 23619c7..74c5b18 100644
--- a/xen/lib/x86/cpuid.c
+++ b/xen/lib/x86/cpuid.c
@@ -144,8 +144,7 @@  void x86_cpuid_policy_fill_native(struct cpuid_policy *p)
         cpuid_count_leaf(0xd, 0, &p->xstate.raw[0]);
         cpuid_count_leaf(0xd, 1, &p->xstate.raw[1]);
 
-        xstates  = ((uint64_t)(p->xstate.xcr0_high | p->xstate.xss_high) << 32);
-        xstates |=            (p->xstate.xcr0_low  | p->xstate.xss_low);
+        xstates = cpuid_policy_xstates(p);
 
         for ( i = 2; i < min_t(unsigned int, 63,
                                ARRAY_SIZE(p->xstate.raw)); ++i )