diff mbox series

[i-g-t,v5] lib/i915/gem_mman: Add a helper for obtaining MMAP_GTT interface version

Message ID 20190531103034.10173-1-janusz.krzysztofik@linux.intel.com (mailing list archive)
State New, archived
Headers show
Series [i-g-t,v5] lib/i915/gem_mman: Add a helper for obtaining MMAP_GTT interface version | expand

Commit Message

Janusz Krzysztofik May 31, 2019, 10:30 a.m. UTC
From: Janusz Krzysztofik <janusz.krzysztofik@intel.com>

If a test calls a function which depends on availability of a specific
version of MMAP_GTT interface, an error may occur on unsupported hardware.
That may negatively affect results reported by a test framework even if
that test ignores the failure and succeedes.

This helper wraps up an IOCTL call which returns a version number of
MMAP_GTT interface.  It may be used by tests which should adjust their
scope depending on availability of a specific version of MMAP_GTT
interface.

Signed-off-by: Janusz Krzysztofik <janusz.krzysztofik@intel.com>
Cc: Antonio Argenziano <antonio.argenziano@intel.com>
Cc: Michal Wajdeczko <michal.wajdeczko@intel.com>
---
Changelog:
v4 -> v5:
- change sign of errno before it is returned (Chris - thanks!),
- validate -errno with igt_assume() (Chris - thanks!),
- follow coding style suggested by Chris - thanks!
To be honest, I think Chris should be somehow officially credited in
the commit tags for his contributions but I'm not sure how. Would a
Suggested-by: clause be OK, or Co-develped-by: maybe?

v3 -> v4:
- return errno value on failure (Chris - thanks!),
- clear errno before return, as other helpers do,
- reword the helper documentation and commit message again (Chris -
  thanks!).

v2 (internal) -> v3:
- make the code less obsucre, more explicit (Antonio - thanks!),
- reword the helper documentation and commit message.

v1 (internal) -> v2 (internal):
- minimize future potential conflicts with 
  https://patchwork.freedesktop.org/patch/294053/?series=58551&rev=1
  (no progress with than one so not waiting for it any longer):
  - convert the helper to a drop-in replacement of the one from the
    above mentioned patch, returning mappable aperture version, not
    only information on its availability,
  - drop any other wrappers,
- document the helper,
- reword commit message.

 lib/i915/gem_mman.c | 25 +++++++++++++++++++++++++
 lib/i915/gem_mman.h |  1 +
 2 files changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/lib/i915/gem_mman.c b/lib/i915/gem_mman.c
index 3cf9a6bb..27c437da 100644
--- a/lib/i915/gem_mman.c
+++ b/lib/i915/gem_mman.c
@@ -40,6 +40,31 @@ 
 #define VG(x) do {} while (0)
 #endif
 
+/**
+ * gem_mmap__gtt_version:
+ * @fd: open i915 drm file descriptor
+ *
+ * This functions wraps up an IOCTL to obtain MMAP_GTT interface version
+ *
+ * Returns: MMAP_GTT interface version, kernel error code on failure.
+ */
+int gem_mmap__gtt_version(int fd)
+{
+	int result = -EIO;
+	struct drm_i915_getparam gp = {
+		.param = I915_PARAM_MMAP_GTT_VERSION,
+		.value = &result,
+	};
+
+	if (ioctl(fd, DRM_IOCTL_I915_GETPARAM, &gp)) {
+		result = -errno;
+		igt_assume(result);
+	}
+
+	errno = 0;
+	return result;
+}
+
 /**
  * __gem_mmap__gtt:
  * @fd: open i915 drm file descriptor
diff --git a/lib/i915/gem_mman.h b/lib/i915/gem_mman.h
index f7242ed7..ab12e566 100644
--- a/lib/i915/gem_mman.h
+++ b/lib/i915/gem_mman.h
@@ -25,6 +25,7 @@ 
 #ifndef GEM_MMAN_H
 #define GEM_MMAN_H
 
+int gem_mmap__gtt_version(int fd);
 void *gem_mmap__gtt(int fd, uint32_t handle, uint64_t size, unsigned prot);
 void *gem_mmap__cpu(int fd, uint32_t handle, uint64_t offset, uint64_t size, unsigned prot);