[isar-cip-core] kernel: change default kernel version to 4.19
diff mbox series

Message ID 20190603074118.28430-1-daniel.sangorrin@toshiba.co.jp
State New
Headers show
Series
  • [isar-cip-core] kernel: change default kernel version to 4.19
Related show

Commit Message

Daniel Sangorrin June 3, 2019, 7:41 a.m. UTC
To revert to version 4.4 users need to add :opt-4.4.yaml to
the kas command line.

Signed-off-by: Daniel Sangorrin <daniel.sangorrin@toshiba.co.jp>
---
 README.md                 |  2 +-
 conf/distro/cip-core.conf |  4 ++--
 opt-4.4.yml               | 18 ++++++++++++++++++
 3 files changed, 21 insertions(+), 3 deletions(-)
 create mode 100644 opt-4.4.yml

Comments

Jan Kiszka June 3, 2019, 11:03 a.m. UTC | #1
On 03.06.19 09:41, Daniel Sangorrin wrote:
> To revert to version 4.4 users need to add :opt-4.4.yaml to
> the kas command line.
> 
> Signed-off-by: Daniel Sangorrin <daniel.sangorrin@toshiba.co.jp>
> ---
>   README.md                 |  2 +-
>   conf/distro/cip-core.conf |  4 ++--
>   opt-4.4.yml               | 18 ++++++++++++++++++
>   3 files changed, 21 insertions(+), 3 deletions(-)
>   create mode 100644 opt-4.4.yml
> 
> diff --git a/README.md b/README.md
> index dfd9ef1..184744a 100644
> --- a/README.md
> +++ b/README.md
> @@ -27,7 +27,7 @@ This image can be run using `start-qemu.sh x86`.
>   
>   The BeagleBone Black target is selected by `... kas.yml:board-bbb.yml`. In
>   order to build the image with the PREEMPT-RT kernel, append `:opt-rt.yml` to
> -the above.
> +the above. Append ':opt-4.4.yml' to use the kernel version 4.4 instead of 4.19.
>   
>   Physical targets will generate ready-to-boot images under
>   `build/tmp/deploy/images/`. To flash, e.g., the BeagleBone Black image to an SD
> diff --git a/conf/distro/cip-core.conf b/conf/distro/cip-core.conf
> index d06ba3b..4e873de 100644
> --- a/conf/distro/cip-core.conf
> +++ b/conf/distro/cip-core.conf
> @@ -12,7 +12,7 @@
>   require conf/distro/debian-stretch.conf
>   
>   KERNEL_NAME ?= "cip"
> -PREFERRED_VERSION_linux-cip ?= "4.4.%"
> -PREFERRED_VERSION_linux-cip-rt ?= "4.4.%"
> +PREFERRED_VERSION_linux-cip ?= "4.19.%"
> +PREFERRED_VERSION_linux-cip-rt ?= "4.19.%"
>   
>   WKS_FILE ?= "${MACHINE}.wks"
> diff --git a/opt-4.4.yml b/opt-4.4.yml
> new file mode 100644
> index 0000000..87be777
> --- /dev/null
> +++ b/opt-4.4.yml
> @@ -0,0 +1,18 @@
> +#
> +# CIP Core, generic profile
> +#
> +# Copyright (c) Toshiba corp., 2019
> +#
> +# Authors:
> +#  Daniel Sangorrin <daniel.sangorrin@toshiba.co.jp>
> +#
> +# SPDX-License-Identifier: MIT
> +#
> +
> +header:
> +  version: 8
> +
> +local_conf_header:
> +  kernel-version: |
> +    PREFERRED_VERSION_linux-cip = "4.4.%"
> +    PREFERRED_VERSION_linux-cip-rt = "4.4.%"
> 

Thanks, applied.

Update the (non-rt) kernel versions at this chance as well.

Jan
Zoran S July 8, 2019, 1:35 p.m. UTC | #2
I think the kernel 5+ should be main pivot point for CIP project for
next two years... But anyway, kernel version for Debian Buster is (by
Ben Hutchinson) already fixed to 4.19... I see/read on many places
that this rule is not ONLY applied on/for CIP (many people/maintainers
follow)... Well!

Zoran

Patch
diff mbox series

diff --git a/README.md b/README.md
index dfd9ef1..184744a 100644
--- a/README.md
+++ b/README.md
@@ -27,7 +27,7 @@  This image can be run using `start-qemu.sh x86`.
 
 The BeagleBone Black target is selected by `... kas.yml:board-bbb.yml`. In
 order to build the image with the PREEMPT-RT kernel, append `:opt-rt.yml` to
-the above.
+the above. Append ':opt-4.4.yml' to use the kernel version 4.4 instead of 4.19.
 
 Physical targets will generate ready-to-boot images under
 `build/tmp/deploy/images/`. To flash, e.g., the BeagleBone Black image to an SD
diff --git a/conf/distro/cip-core.conf b/conf/distro/cip-core.conf
index d06ba3b..4e873de 100644
--- a/conf/distro/cip-core.conf
+++ b/conf/distro/cip-core.conf
@@ -12,7 +12,7 @@ 
 require conf/distro/debian-stretch.conf
 
 KERNEL_NAME ?= "cip"
-PREFERRED_VERSION_linux-cip ?= "4.4.%"
-PREFERRED_VERSION_linux-cip-rt ?= "4.4.%"
+PREFERRED_VERSION_linux-cip ?= "4.19.%"
+PREFERRED_VERSION_linux-cip-rt ?= "4.19.%"
 
 WKS_FILE ?= "${MACHINE}.wks"
diff --git a/opt-4.4.yml b/opt-4.4.yml
new file mode 100644
index 0000000..87be777
--- /dev/null
+++ b/opt-4.4.yml
@@ -0,0 +1,18 @@ 
+#
+# CIP Core, generic profile
+#
+# Copyright (c) Toshiba corp., 2019
+#
+# Authors:
+#  Daniel Sangorrin <daniel.sangorrin@toshiba.co.jp>
+#
+# SPDX-License-Identifier: MIT
+#
+
+header:
+  version: 8
+
+local_conf_header:
+  kernel-version: |
+    PREFERRED_VERSION_linux-cip = "4.4.%"
+    PREFERRED_VERSION_linux-cip-rt = "4.4.%"