diff mbox series

[v2] x86/cpu: Add Ice Lake NNPI to Intel family

Message ID 20190606012419.13250-1-rajneesh.bhardwaj@linux.intel.com (mailing list archive)
State Not Applicable, archived
Headers show
Series [v2] x86/cpu: Add Ice Lake NNPI to Intel family | expand

Commit Message

Bhardwaj, Rajneesh June 6, 2019, 1:24 a.m. UTC
Add the CPUID model number of Ice Lake Neural Network Processor for Deep
Learning Inference (ICL-NNPI) to the Intel family list. Ice Lake NNPI uses
model number 0x9D and this will be documented in a future version of Intel
Software Development Manual.

Cc: Borislav Petkov <bp@alien8.de>
Cc: Dave Hansen <dave.hansen@linux.intel.com>
Cc: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Cc: "H. Peter Anvin" <hpa@zytor.com>
Cc: Ingo Molnar <mingo@redhat.com>
Cc: Kan Liang <kan.liang@linux.intel.com>
Cc: Peter Zijlstra <peterz@infradead.org>
Cc: platform-driver-x86@vger.kernel.org
Cc: Qiuxu Zhuo <qiuxu.zhuo@intel.com>
Cc: Srinivas Pandruvada <srinivas.pandruvada@linux.intel.com>
Cc: Len Brown <lenb@kernel.org>
Cc: Thomas Gleixner <tglx@linutronix.de>
Cc: x86-ml <x86@kernel.org>
Cc: Linux PM <linux-pm@vger.kernel.org>
Signed-off-by: Rajneesh Bhardwaj <rajneesh.bhardwaj@linux.intel.com>
---

Changes in v2:
 * Renamed Icelake to Ice Lake in the commit msg

 arch/x86/include/asm/intel-family.h | 1 +
 1 file changed, 1 insertion(+)

Comments

Andy Shevchenko June 12, 2019, 9:52 a.m. UTC | #1
On Thu, Jun 06, 2019 at 06:54:19AM +0530, Rajneesh Bhardwaj wrote:
> Add the CPUID model number of Ice Lake Neural Network Processor for Deep
> Learning Inference (ICL-NNPI) to the Intel family list. Ice Lake NNPI uses
> model number 0x9D and this will be documented in a future version of Intel
> Software Development Manual.

>  #define INTEL_FAM6_ICELAKE_MOBILE	0x7E
> +#define INTEL_FAM6_ICELAKE_NNPI		0x9D

What "I" stands for?

For me sounds like it's redundant here or something like NNP_DLI would be
better (because somewhere we have _NP as for Network Processor).
Dave Hansen June 12, 2019, 2:51 p.m. UTC | #2
On 6/12/19 2:52 AM, Andy Shevchenko wrote:
>>  #define INTEL_FAM6_ICELAKE_MOBILE	0x7E
>> +#define INTEL_FAM6_ICELAKE_NNPI		0x9D
> What "I" stands for?
> 
> For me sounds like it's redundant here or something like NNP_DLI would be
> better (because somewhere we have _NP as for Network Processor).

Let's not bikeshed this too much.  These things aren't used that widely
and mostly they're just used for figuring out the processor generation.
 It's exceedingly rare to have something like:


	if (model == INTEL_FAM6_ICELAKE_MOBILE)
		foo();
	else if (model == INTEL_FAM6_ICELAKE_NNPI)
		bar();

where what you suggest would matter.

Preserving the ability to google "ice lake nnpi" is pretty important, so
preserving the Intel name makes a lot of sense here when possible.

Do we *HAVE* an Ice Lake network processor?
Andy Shevchenko June 12, 2019, 4:29 p.m. UTC | #3
On Wed, Jun 12, 2019 at 07:51:26AM -0700, Dave Hansen wrote:
> On 6/12/19 2:52 AM, Andy Shevchenko wrote:
> >>  #define INTEL_FAM6_ICELAKE_MOBILE	0x7E
> >> +#define INTEL_FAM6_ICELAKE_NNPI		0x9D
> > What "I" stands for?
> > 
> > For me sounds like it's redundant here or something like NNP_DLI would be
> > better (because somewhere we have _NP as for Network Processor).
> 
> Let's not bikeshed this too much.  These things aren't used that widely
> and mostly they're just used for figuring out the processor generation.
>  It's exceedingly rare to have something like:
> 
> 
> 	if (model == INTEL_FAM6_ICELAKE_MOBILE)
> 		foo();
> 	else if (model == INTEL_FAM6_ICELAKE_NNPI)
> 		bar();
> 
> where what you suggest would matter.
> 
> Preserving the ability to google "ice lake nnpi" is pretty important, so
> preserving the Intel name makes a lot of sense here when possible.

What I'm talking is a consistency among suffixes. If there is a real
abbreviation (NNPI) which anybody can google, I'm totally for it to be used.

> Do we *HAVE* an Ice Lake network processor?

Not Ice Lake, something else.
Dave Hansen June 12, 2019, 4:33 p.m. UTC | #4
On 6/12/19 9:29 AM, Andy Shevchenko wrote:
> What I'm talking is a consistency among suffixes. If there is a real
> abbreviation (NNPI) which anybody can google, 

There is and you can. :)
Andy Shevchenko June 12, 2019, 5:08 p.m. UTC | #5
On Wed, Jun 12, 2019 at 09:33:30AM -0700, Dave Hansen wrote:
> On 6/12/19 9:29 AM, Andy Shevchenko wrote:
> > What I'm talking is a consistency among suffixes. If there is a real
> > abbreviation (NNPI) which anybody can google, 
> 
> There is and you can. :)

Good, I have no objections.
Bhardwaj, Rajneesh June 12, 2019, 5:12 p.m. UTC | #6
On 12-Jun-19 10:38 PM, Andy Shevchenko wrote:
> On Wed, Jun 12, 2019 at 09:33:30AM -0700, Dave Hansen wrote:
>> On 6/12/19 9:29 AM, Andy Shevchenko wrote:
>>> What I'm talking is a consistency among suffixes. If there is a real
>>> abbreviation (NNPI) which anybody can google,
>> There is and you can. :)
> Good, I have no objections.


Great, thanks Andy and Dave for your valuable comments. I see that 
Thomas has accepted this one, thanks a lot, Thomas!

https://git.kernel.org/pub/scm/linux/kernel/git/tip/tip.git/commit/?id=61caa8621b9979a78b04e353ab2ee44a47ef7a62&anzwix=1 


>
diff mbox series

Patch

diff --git a/arch/x86/include/asm/intel-family.h b/arch/x86/include/asm/intel-family.h
index 9f15384c504a..087de5d3b93a 100644
--- a/arch/x86/include/asm/intel-family.h
+++ b/arch/x86/include/asm/intel-family.h
@@ -53,6 +53,7 @@ 
 #define INTEL_FAM6_CANNONLAKE_MOBILE	0x66
 
 #define INTEL_FAM6_ICELAKE_MOBILE	0x7E
+#define INTEL_FAM6_ICELAKE_NNPI		0x9D
 
 /* "Small Core" Processors (Atom) */