[1/1] doc(stash): clarify the description of `save`
diff mbox series

Message ID 572c7d0c51ffc68dc4603752d05fa7a418dbdd71.1570702000.git.gitgitgadget@gmail.com
State New
Headers show
Series
  • Make the description of git stash save clearer
Related show

Commit Message

Utsav Shah via GitGitGadget Oct. 10, 2019, 10:06 a.m. UTC
From: Johannes Schindelin <johannes.schindelin@gmx.de>

The original phrasing of this paragraph made at least one person stumble
over the word "from" (thinking that it was a typo and "from" was
intended), and other readers chimed in, agreeing that it was confusing:
https://public-inbox.org/git/0102016b8d597569-c1f6cfdc-cb45-4428-8737-cb1bc30655d8-000000@eu-west-1.amazonses.com/#t

Let's rewrite that paragraph for clarity.

Inspired-by-a-patch-by: Catalin Criste <cris_linu_w@yahoo.com>
Signed-off-by: Johannes Schindelin <johannes.schindelin@gmx.de>
---
 Documentation/git-stash.txt | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Thomas Gummerer Oct. 10, 2019, 10:28 a.m. UTC | #1
On 10/10, Johannes Schindelin via GitGitGadget wrote:
> From: Johannes Schindelin <johannes.schindelin@gmx.de>
> 
> The original phrasing of this paragraph made at least one person stumble
> over the word "from" (thinking that it was a typo and "from" was
> intended), and other readers chimed in, agreeing that it was confusing:
> https://public-inbox.org/git/0102016b8d597569-c1f6cfdc-cb45-4428-8737-cb1bc30655d8-000000@eu-west-1.amazonses.com/#t
> 
> Let's rewrite that paragraph for clarity.
> 
> Inspired-by-a-patch-by: Catalin Criste <cris_linu_w@yahoo.com>
> Signed-off-by: Johannes Schindelin <johannes.schindelin@gmx.de>

Thanks for picking this thread up again, I had already forgotten about
it.  The updated wording sounds like an improvement to me.

> ---
>  Documentation/git-stash.txt | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/Documentation/git-stash.txt b/Documentation/git-stash.txt
> index 8fbe12c66c..53e1a1205d 100644
> --- a/Documentation/git-stash.txt
> +++ b/Documentation/git-stash.txt
> @@ -87,8 +87,9 @@ The `--patch` option implies `--keep-index`.  You can use
>  save [-p|--patch] [-k|--[no-]keep-index] [-u|--include-untracked] [-a|--all] [-q|--quiet] [<message>]::
>  
>  	This option is deprecated in favour of 'git stash push'.  It
> -	differs from "stash push" in that it cannot take pathspecs,
> -	and any non-option arguments form the message.
> +	differs from "stash push" in that it cannot take pathspecs.
> +	Instead, all non-option arguments are concatenated to form the stash
> +	message.
>  
>  list [<options>]::
>  
> -- 
> gitgitgadget
Junio C Hamano Oct. 11, 2019, 5:29 a.m. UTC | #2
Thomas Gummerer <t.gummerer@gmail.com> writes:

> On 10/10, Johannes Schindelin via GitGitGadget wrote:
>> From: Johannes Schindelin <johannes.schindelin@gmx.de>
>> 
>> The original phrasing of this paragraph made at least one person stumble
>> over the word "from" (thinking that it was a typo and "from" was
>> intended), and other readers chimed in, agreeing that it was confusing:
>> https://public-inbox.org/git/0102016b8d597569-c1f6cfdc-cb45-4428-8737-cb1bc30655d8-000000@eu-west-1.amazonses.com/#t
>> 
>> Let's rewrite that paragraph for clarity.
>> 
>> Inspired-by-a-patch-by: Catalin Criste <cris_linu_w@yahoo.com>
>> Signed-off-by: Johannes Schindelin <johannes.schindelin@gmx.de>
>
> Thanks for picking this thread up again, I had already forgotten about
> it.  The updated wording sounds like an improvement to me.

To me too.  I would have just done s/form/become/ out of laziness
and aiming for conciseness, but the new and separate sentence is
good, too.

Thanks, both.

>
>> ---
>>  Documentation/git-stash.txt | 5 +++--
>>  1 file changed, 3 insertions(+), 2 deletions(-)
>> 
>> diff --git a/Documentation/git-stash.txt b/Documentation/git-stash.txt
>> index 8fbe12c66c..53e1a1205d 100644
>> --- a/Documentation/git-stash.txt
>> +++ b/Documentation/git-stash.txt
>> @@ -87,8 +87,9 @@ The `--patch` option implies `--keep-index`.  You can use
>>  save [-p|--patch] [-k|--[no-]keep-index] [-u|--include-untracked] [-a|--all] [-q|--quiet] [<message>]::
>>  
>>  	This option is deprecated in favour of 'git stash push'.  It
>> -	differs from "stash push" in that it cannot take pathspecs,
>> -	and any non-option arguments form the message.
>> +	differs from "stash push" in that it cannot take pathspecs.
>> +	Instead, all non-option arguments are concatenated to form the stash
>> +	message.
>>  
>>  list [<options>]::
>>  
>> -- 
>> gitgitgadget

Patch
diff mbox series

diff --git a/Documentation/git-stash.txt b/Documentation/git-stash.txt
index 8fbe12c66c..53e1a1205d 100644
--- a/Documentation/git-stash.txt
+++ b/Documentation/git-stash.txt
@@ -87,8 +87,9 @@  The `--patch` option implies `--keep-index`.  You can use
 save [-p|--patch] [-k|--[no-]keep-index] [-u|--include-untracked] [-a|--all] [-q|--quiet] [<message>]::
 
 	This option is deprecated in favour of 'git stash push'.  It
-	differs from "stash push" in that it cannot take pathspecs,
-	and any non-option arguments form the message.
+	differs from "stash push" in that it cannot take pathspecs.
+	Instead, all non-option arguments are concatenated to form the stash
+	message.
 
 list [<options>]::