diff mbox series

[4/5] drm/dsi: rename MIPI_DCS_SET_PARTIAL_AREA to MIPI_DCS_SET_PARTIAL_ROWS

Message ID c14255c3cecea4d2c593ff4edd5e8134ab7568d3.1571738674.git.jani.nikula@intel.com (mailing list archive)
State New, archived
Headers show
Series drm/dsi: cleanups and compression helpers | expand

Commit Message

Jani Nikula Oct. 22, 2019, 10:09 a.m. UTC
The DCS command has been named SET_PARTIAL_ROWS in the DCS spec since
v1.02, for more than a decade. Rename the enumeration to match the spec.

Cc: David Lechner <david@lechnology.com>
Cc: Vandita Kulkarni <vandita.kulkarni@intel.com>
Signed-off-by: Jani Nikula <jani.nikula@intel.com>
---
 drivers/gpu/drm/tiny/st7586.c | 2 +-
 include/video/mipi_display.h  | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

David Lechner Oct. 22, 2019, 2:31 p.m. UTC | #1
On 10/22/19 5:09 AM, Jani Nikula wrote:
> The DCS command has been named SET_PARTIAL_ROWS in the DCS spec since
> v1.02, for more than a decade. Rename the enumeration to match the spec.
> 
> Cc: David Lechner <david@lechnology.com>
> Cc: Vandita Kulkarni <vandita.kulkarni@intel.com>
> Signed-off-by: Jani Nikula <jani.nikula@intel.com>
> ---

I guess all of my documents are old and say set_partial_area, but I will
take your word for it.

It could be helpful to leave a comment in the code about the renaming
so that if people with old docs search for SET_PARTIAL_AREA, they can
still find it.
Jani Nikula Oct. 23, 2019, 7:32 a.m. UTC | #2
On Tue, 22 Oct 2019, David Lechner <david@lechnology.com> wrote:
> On 10/22/19 5:09 AM, Jani Nikula wrote:
>> The DCS command has been named SET_PARTIAL_ROWS in the DCS spec since
>> v1.02, for more than a decade. Rename the enumeration to match the spec.
>> 
>> Cc: David Lechner <david@lechnology.com>
>> Cc: Vandita Kulkarni <vandita.kulkarni@intel.com>
>> Signed-off-by: Jani Nikula <jani.nikula@intel.com>
>> ---
>
> I guess all of my documents are old and say set_partial_area, but I will
> take your word for it.
>
> It could be helpful to leave a comment in the code about the renaming
> so that if people with old docs search for SET_PARTIAL_AREA, they can
> still find it.

Something like this?

	MIPI_DCS_SET_PARTIAL_ROWS	= 0x30,		/* aka MIPI_DCS_SET_PARTIAL_AREA */

It's also a possibility to define both:

	MIPI_DCS_SET_PARTIAL_AREA	= 0x30,		/* _ROWS since MIPI DCS 1.02 */
	MIPI_DCS_SET_PARTIAL_ROWS	= 0x30,

I don't mind either way.

BR,
Jani.
diff mbox series

Patch

diff --git a/drivers/gpu/drm/tiny/st7586.c b/drivers/gpu/drm/tiny/st7586.c
index 3cc21a1b30c8..060cc756194f 100644
--- a/drivers/gpu/drm/tiny/st7586.c
+++ b/drivers/gpu/drm/tiny/st7586.c
@@ -240,7 +240,7 @@  static void st7586_pipe_enable(struct drm_simple_display_pipe *pipe,
 
 	mipi_dbi_command(dbi, ST7586_SET_DISP_DUTY, 0x7f);
 	mipi_dbi_command(dbi, ST7586_SET_PART_DISP, 0xa0);
-	mipi_dbi_command(dbi, MIPI_DCS_SET_PARTIAL_AREA, 0x00, 0x00, 0x00, 0x77);
+	mipi_dbi_command(dbi, MIPI_DCS_SET_PARTIAL_ROWS, 0x00, 0x00, 0x00, 0x77);
 	mipi_dbi_command(dbi, MIPI_DCS_EXIT_INVERT_MODE);
 
 	msleep(100);
diff --git a/include/video/mipi_display.h b/include/video/mipi_display.h
index 928f8c4b6658..e3dc94fe1098 100644
--- a/include/video/mipi_display.h
+++ b/include/video/mipi_display.h
@@ -108,7 +108,7 @@  enum {
 	MIPI_DCS_WRITE_MEMORY_START	= 0x2C,
 	MIPI_DCS_WRITE_LUT		= 0x2D,
 	MIPI_DCS_READ_MEMORY_START	= 0x2E,
-	MIPI_DCS_SET_PARTIAL_AREA	= 0x30,
+	MIPI_DCS_SET_PARTIAL_ROWS	= 0x30,
 	MIPI_DCS_SET_PARTIAL_COLUMNS	= 0x31,
 	MIPI_DCS_SET_SCROLL_AREA	= 0x33,
 	MIPI_DCS_SET_TEAR_OFF		= 0x34,