mbox series

[PULL] topic/drm-mipi-dsi-dsc-updates

Message ID 87tv7a4eq3.fsf@intel.com (mailing list archive)
State New, archived
Headers show
Series [PULL] topic/drm-mipi-dsi-dsc-updates | expand

Pull-request

git://anongit.freedesktop.org/drm/drm-intel tags/topic/drm-mipi-dsi-dsc-updates-2019-11-11

Message

Jani Nikula Nov. 11, 2019, 3:25 p.m. UTC
Hi Sean, Maarten and Maxime -

Here's the topic branch about DSI changes as I wrote in [1]. Once you've
pulled this in drm-misc, I'll follow suit in i915.


Thanks,
Jani.

[1] http://marc.info/?i=87sgmz6cw0.fsf@intel.com



topic/drm-mipi-dsi-dsc-updates-2019-11-11:
Core Changes:
- Update DSI data type and command definitions
- Add helpers for sending compression mode and PPS packets

Driver Changes:
- Update tiny/st7586 to reflect a definition change


The following changes since commit 54ecb8f7028c5eb3d740bb82b0f1d90f2df63c5c:

  Linux 5.4-rc1 (2019-09-30 10:35:40 -0700)

are available in the Git repository at:

  git://anongit.freedesktop.org/drm/drm-intel tags/topic/drm-mipi-dsi-dsc-updates-2019-11-11

for you to fetch changes up to f4dea1aaa9a12486f5813fada574192feb3850cd:

  drm/dsi: add helpers for DSI compression mode and PPS packets (2019-11-07 15:00:16 +0200)

----------------------------------------------------------------
Core Changes:
- Update DSI data type and command definitions
- Add helpers for sending compression mode and PPS packets

Driver Changes:
- Update tiny/st7586 to reflect a definition change

----------------------------------------------------------------
Jani Nikula (5):
      drm/dsi: clean up DSI data type definitions
      drm/dsi: add missing DSI data types
      drm/dsi: add missing DSI DCS commands
      drm/dsi: rename MIPI_DCS_SET_PARTIAL_AREA to MIPI_DCS_SET_PARTIAL_ROWS
      drm/dsi: add helpers for DSI compression mode and PPS packets

 drivers/gpu/drm/drm_mipi_dsi.c | 57 ++++++++++++++++++++++++++++++++++++++++--
 drivers/gpu/drm/tiny/st7586.c  |  2 +-
 include/drm/drm_mipi_dsi.h     |  4 +++
 include/video/mipi_display.h   | 24 +++++++++++++-----
 4 files changed, 78 insertions(+), 9 deletions(-)

Comments

Jani Nikula Nov. 14, 2019, 2:35 p.m. UTC | #1
On Mon, 11 Nov 2019, Jani Nikula <jani.nikula@intel.com> wrote:
> Hi Sean, Maarten and Maxime -
>
> Here's the topic branch about DSI changes as I wrote in [1]. Once you've
> pulled this in drm-misc, I'll follow suit in i915.

Ping.

FWIW Daniel acked the approach on IRC.

BR,
Jani.


>
>
> Thanks,
> Jani.
>
> [1] http://marc.info/?i=87sgmz6cw0.fsf@intel.com
>
>
>
> topic/drm-mipi-dsi-dsc-updates-2019-11-11:
> Core Changes:
> - Update DSI data type and command definitions
> - Add helpers for sending compression mode and PPS packets
>
> Driver Changes:
> - Update tiny/st7586 to reflect a definition change
>
>
> The following changes since commit 54ecb8f7028c5eb3d740bb82b0f1d90f2df63c5c:
>
>   Linux 5.4-rc1 (2019-09-30 10:35:40 -0700)
>
> are available in the Git repository at:
>
>   git://anongit.freedesktop.org/drm/drm-intel tags/topic/drm-mipi-dsi-dsc-updates-2019-11-11
>
> for you to fetch changes up to f4dea1aaa9a12486f5813fada574192feb3850cd:
>
>   drm/dsi: add helpers for DSI compression mode and PPS packets (2019-11-07 15:00:16 +0200)
>
> ----------------------------------------------------------------
> Core Changes:
> - Update DSI data type and command definitions
> - Add helpers for sending compression mode and PPS packets
>
> Driver Changes:
> - Update tiny/st7586 to reflect a definition change
>
> ----------------------------------------------------------------
> Jani Nikula (5):
>       drm/dsi: clean up DSI data type definitions
>       drm/dsi: add missing DSI data types
>       drm/dsi: add missing DSI DCS commands
>       drm/dsi: rename MIPI_DCS_SET_PARTIAL_AREA to MIPI_DCS_SET_PARTIAL_ROWS
>       drm/dsi: add helpers for DSI compression mode and PPS packets
>
>  drivers/gpu/drm/drm_mipi_dsi.c | 57 ++++++++++++++++++++++++++++++++++++++++--
>  drivers/gpu/drm/tiny/st7586.c  |  2 +-
>  include/drm/drm_mipi_dsi.h     |  4 +++
>  include/video/mipi_display.h   | 24 +++++++++++++-----
>  4 files changed, 78 insertions(+), 9 deletions(-)
Maarten Lankhorst Nov. 20, 2019, 1:16 p.m. UTC | #2
Op 14-11-2019 om 15:35 schreef Jani Nikula:
> On Mon, 11 Nov 2019, Jani Nikula <jani.nikula@intel.com> wrote:
>> Hi Sean, Maarten and Maxime -
>>
>> Here's the topic branch about DSI changes as I wrote in [1]. Once you've
>> pulled this in drm-misc, I'll follow suit in i915.
> Ping.
>
> FWIW Daniel acked the approach on IRC.
>
> BR,
> Jani.
>
>
Pushed, thanks. :)
Jani Nikula Nov. 20, 2019, 2:04 p.m. UTC | #3
On Wed, 20 Nov 2019, Maarten Lankhorst <maarten.lankhorst@linux.intel.com> wrote:
> Op 14-11-2019 om 15:35 schreef Jani Nikula:
>> On Mon, 11 Nov 2019, Jani Nikula <jani.nikula@intel.com> wrote:
>>> Hi Sean, Maarten and Maxime -
>>>
>>> Here's the topic branch about DSI changes as I wrote in [1]. Once you've
>>> pulled this in drm-misc, I'll follow suit in i915.
>> Ping.
>>
>> FWIW Daniel acked the approach on IRC.
>>
>> BR,
>> Jani.
>>
>>
> Pushed, thanks. :)

Thanks; also pulled to drm-intel-next-queued now.

BR,
Jani.