diff mbox series

[v5,7/7] drm/i915/display: Add comment to a function that probably can be removed

Message ID 20191220152954.83276-7-jose.souza@intel.com (mailing list archive)
State New, archived
Headers show
Series [v5,1/7] drm/i915: Introduce intel_crtc_state_alloc() | expand

Commit Message

Souza, Jose Dec. 20, 2019, 3:29 p.m. UTC
This function is only called from port sync and it is identical to
what will be executed again in intel_update_crtc() over port sync
pipes.
If it is really necessary it at least deserves a better name and a
comment, leaving it to people working on port sync.

Cc: Ville Syrjälä <ville.syrjala@linux.intel.com>
Cc: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>
Cc: Manasi Navare <manasi.d.navare@intel.com>
Signed-off-by: José Roberto de Souza <jose.souza@intel.com>
---
 drivers/gpu/drm/i915/display/intel_display.c | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Ville Syrjälä Dec. 20, 2019, 3:48 p.m. UTC | #1
On Fri, Dec 20, 2019 at 07:29:54AM -0800, José Roberto de Souza wrote:
> This function is only called from port sync and it is identical to
> what will be executed again in intel_update_crtc() over port sync
> pipes.
> If it is really necessary it at least deserves a better name and a
> comment, leaving it to people working on port sync.

IMO if we need special cases for port sync we should refactor
the current code to accomodate that instead of copypasting
the whole current implementation, as was done when port sync
went it. But yeah, future work.

Reviewed-by: Ville Syrjälä <ville.syrjala@linux.intel.com>

> 
> Cc: Ville Syrjälä <ville.syrjala@linux.intel.com>
> Cc: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>
> Cc: Manasi Navare <manasi.d.navare@intel.com>
> Signed-off-by: José Roberto de Souza <jose.souza@intel.com>
> ---
>  drivers/gpu/drm/i915/display/intel_display.c | 4 ++++
>  1 file changed, 4 insertions(+)
> 
> diff --git a/drivers/gpu/drm/i915/display/intel_display.c b/drivers/gpu/drm/i915/display/intel_display.c
> index 11f2c13ec23e..592c843f2f3b 100644
> --- a/drivers/gpu/drm/i915/display/intel_display.c
> +++ b/drivers/gpu/drm/i915/display/intel_display.c
> @@ -14479,6 +14479,10 @@ static void intel_set_dp_tp_ctl_normal(struct intel_crtc *crtc,
>  	intel_dp_stop_link_train(intel_dp);
>  }
>  
> +/*
> + * TODO: This is only called from port sync and it is identical to what will be
> + * executed again in intel_update_crtc() over port sync pipes
> + */
>  static void intel_post_crtc_enable_updates(struct intel_crtc *crtc,
>  					   struct intel_atomic_state *state)
>  {
> -- 
> 2.24.1
diff mbox series

Patch

diff --git a/drivers/gpu/drm/i915/display/intel_display.c b/drivers/gpu/drm/i915/display/intel_display.c
index 11f2c13ec23e..592c843f2f3b 100644
--- a/drivers/gpu/drm/i915/display/intel_display.c
+++ b/drivers/gpu/drm/i915/display/intel_display.c
@@ -14479,6 +14479,10 @@  static void intel_set_dp_tp_ctl_normal(struct intel_crtc *crtc,
 	intel_dp_stop_link_train(intel_dp);
 }
 
+/*
+ * TODO: This is only called from port sync and it is identical to what will be
+ * executed again in intel_update_crtc() over port sync pipes
+ */
 static void intel_post_crtc_enable_updates(struct intel_crtc *crtc,
 					   struct intel_atomic_state *state)
 {