diff mbox series

[01/18] staging: exfat: Rename function "ffsUmountVol" to "ffs_umount_vol"

Message ID 20200211123859.10429-2-pragat.pandya@gmail.com (mailing list archive)
State New, archived
Headers show
Series Rename some identifier and functions. | expand

Commit Message

Pragat Pandya Feb. 11, 2020, 12:38 p.m. UTC
Fix checkpatch warning: Avoid CamelCase
Change all occurrences of function "ffsUmountVol" to "ffs_umount_vol"
in the source.

Signed-off-by: Pragat Pandya <pragat.pandya@gmail.com>
---
 drivers/staging/exfat/exfat_super.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Greg Kroah-Hartman Feb. 11, 2020, 7:27 p.m. UTC | #1
On Tue, Feb 11, 2020 at 06:08:42PM +0530, Pragat Pandya wrote:
> Fix checkpatch warning: Avoid CamelCase
> Change all occurrences of function "ffsUmountVol" to "ffs_umount_vol"
> in the source.

I've said this before about this type of change, but there's no need for
the "ffs" prefix at all for almost all of these functions.  Can you just
name them sanely instead?

thanks,

greg k-h
diff mbox series

Patch

diff --git a/drivers/staging/exfat/exfat_super.c b/drivers/staging/exfat/exfat_super.c
index b81d2a87b82e..1e47bfcebed5 100644
--- a/drivers/staging/exfat/exfat_super.c
+++ b/drivers/staging/exfat/exfat_super.c
@@ -439,7 +439,7 @@  static int ffsMountVol(struct super_block *sb)
 	return ret;
 }
 
-static int ffsUmountVol(struct super_block *sb)
+static int ffs_umount_vol(struct super_block *sb)
 {
 	struct fs_info_t *p_fs = &(EXFAT_SB(sb)->fs_info);
 	int err = 0;
@@ -3301,7 +3301,7 @@  static void exfat_put_super(struct super_block *sb)
 	if (__is_sb_dirty(sb))
 		exfat_write_super(sb);
 
-	ffsUmountVol(sb);
+	ffs_umount_vol(sb);
 
 	sb->s_fs_info = NULL;
 	exfat_free_super(sbi);
@@ -3753,7 +3753,7 @@  static int exfat_fill_super(struct super_block *sb, void *data, int silent)
 	return 0;
 
 out_fail2:
-	ffsUmountVol(sb);
+	ffs_umount_vol(sb);
 out_fail:
 	if (root_inode)
 		iput(root_inode);