diff mbox series

mm/slub: Fix incorrect checkings of s->offset

Message ID 20200427020212.5222-1-longman@redhat.com (mailing list archive)
State New, archived
Headers show
Series mm/slub: Fix incorrect checkings of s->offset | expand

Commit Message

Waiman Long April 27, 2020, 2:02 a.m. UTC
In a couple of places in the slub memory allocator, the code uses
"s->offset" as a check to see if the free pointer is put right after the
object. That check is no longer true with commit 3202fa62fb43 ("slub:
relocate freelist pointer to middle of object").

As a result, echoing "1" into the validate sysfs file, e.g. of dentry,
may cause a bunch of "Freepointer corrupt" error reports to appear with
the system in panic afterwards.

To fix it, use the check "s->offset == s->inuse" instead.

Fixes: 3202fa62fb43 ("slub: relocate freelist pointer to middle of object")
Signed-off-by: Waiman Long <longman@redhat.com>
---
 mm/slub.c | 18 +++++++-----------
 1 file changed, 7 insertions(+), 11 deletions(-)

Comments

Matthew Wilcox April 27, 2020, 12:38 p.m. UTC | #1
On Sun, Apr 26, 2020 at 10:02:12PM -0400, Waiman Long wrote:
> In a couple of places in the slub memory allocator, the code uses
> "s->offset" as a check to see if the free pointer is put right after the
> object. That check is no longer true with commit 3202fa62fb43 ("slub:
> relocate freelist pointer to middle of object").
> 
> As a result, echoing "1" into the validate sysfs file, e.g. of dentry,
> may cause a bunch of "Freepointer corrupt" error reports to appear with
> the system in panic afterwards.
> 
> To fix it, use the check "s->offset == s->inuse" instead.

I think a little refactoring would make this more clear.

unsigned int track_offset(const struct kmem_cache *s)
{
	return s->inuse + (s->offset == s->inuse) ? sizeof(void *) : 0;
}

> @@ -556,10 +556,8 @@ static struct track *get_track(struct kmem_cache *s, void *object,
>  {
>  	struct track *p;
>  
> -	if (s->offset)
> -		p = object + s->offset + sizeof(void *);
> -	else
> -		p = object + s->inuse;
> +	p = object + s->inuse +
> +	    ((s->offset == s->inuse) ? sizeof(void *) : 0);

	p = object + track_offset(s);

>  	return p + alloc;
>  }
> @@ -693,10 +691,8 @@ static void print_trailer(struct kmem_cache *s, struct page *page, u8 *p)
>  		print_section(KERN_ERR, "Redzone ", p + s->object_size,
>  			s->inuse - s->object_size);
>  
> -	if (s->offset)
> -		off = s->offset + sizeof(void *);
> -	else
> -		off = s->inuse;
> +	off = s->inuse +
> +	      ((s->offset == s->inuse) ? sizeof(void *) : 0);

	off = track_offset(s);

> @@ -826,7 +822,7 @@ static int check_pad_bytes(struct kmem_cache *s, struct page *page, u8 *p)
>  {
>  	unsigned long off = s->inuse;	/* The end of info */
>  
> -	if (s->offset)
> +	if (s->offset == s->inuse)
>  		/* Freepointer is placed after the object. */
>  		off += sizeof(void *);

	unsigned long off = track_offset(s);
Waiman Long April 27, 2020, 1:18 p.m. UTC | #2
On 4/27/20 8:38 AM, Matthew Wilcox wrote:
> On Sun, Apr 26, 2020 at 10:02:12PM -0400, Waiman Long wrote:
>> In a couple of places in the slub memory allocator, the code uses
>> "s->offset" as a check to see if the free pointer is put right after the
>> object. That check is no longer true with commit 3202fa62fb43 ("slub:
>> relocate freelist pointer to middle of object").
>>
>> As a result, echoing "1" into the validate sysfs file, e.g. of dentry,
>> may cause a bunch of "Freepointer corrupt" error reports to appear with
>> the system in panic afterwards.
>>
>> To fix it, use the check "s->offset == s->inuse" instead.
> I think a little refactoring would make this more clear.
>
> unsigned int track_offset(const struct kmem_cache *s)
> {
> 	return s->inuse + (s->offset == s->inuse) ? sizeof(void *) : 0;
> }

Yes, that was what I am thinking of doing in v2.

Thanks,
Longman
Waiman Long April 27, 2020, 1:29 p.m. UTC | #3
On 4/27/20 9:18 AM, Waiman Long wrote:
> On 4/27/20 8:38 AM, Matthew Wilcox wrote:
>> On Sun, Apr 26, 2020 at 10:02:12PM -0400, Waiman Long wrote:
>>> In a couple of places in the slub memory allocator, the code uses
>>> "s->offset" as a check to see if the free pointer is put right after 
>>> the
>>> object. That check is no longer true with commit 3202fa62fb43 ("slub:
>>> relocate freelist pointer to middle of object").
>>>
>>> As a result, echoing "1" into the validate sysfs file, e.g. of dentry,
>>> may cause a bunch of "Freepointer corrupt" error reports to appear with
>>> the system in panic afterwards.
>>>
>>> To fix it, use the check "s->offset == s->inuse" instead.
>> I think a little refactoring would make this more clear.
>>
>> unsigned int track_offset(const struct kmem_cache *s)
>> {
>>     return s->inuse + (s->offset == s->inuse) ? sizeof(void *) : 0;
>> }
>
> Yes, that was what I am thinking of doing in v2. 

BTW, "+" has a higher priority than "?:". So we need a parenthesis 
around "?:".

Cheers,
Longman
Matthew Wilcox April 27, 2020, 1:38 p.m. UTC | #4
On Mon, Apr 27, 2020 at 09:29:41AM -0400, Waiman Long wrote:
> On 4/27/20 9:18 AM, Waiman Long wrote:
> > On 4/27/20 8:38 AM, Matthew Wilcox wrote:
> > > On Sun, Apr 26, 2020 at 10:02:12PM -0400, Waiman Long wrote:
> > > > In a couple of places in the slub memory allocator, the code uses
> > > > "s->offset" as a check to see if the free pointer is put right
> > > > after the
> > > > object. That check is no longer true with commit 3202fa62fb43 ("slub:
> > > > relocate freelist pointer to middle of object").
> > > > 
> > > > As a result, echoing "1" into the validate sysfs file, e.g. of dentry,
> > > > may cause a bunch of "Freepointer corrupt" error reports to appear with
> > > > the system in panic afterwards.
> > > > 
> > > > To fix it, use the check "s->offset == s->inuse" instead.
> > > I think a little refactoring would make this more clear.
> > > 
> > > unsigned int track_offset(const struct kmem_cache *s)
> > > {
> > >     return s->inuse + (s->offset == s->inuse) ? sizeof(void *) : 0;
> > > }
> > 
> > Yes, that was what I am thinking of doing in v2.
> 
> BTW, "+" has a higher priority than "?:". So we need a parenthesis around
> "?:".

That seems like a good reason to not use ?:

unsigned int track_offset(const struct kmem_cache *s)
{
	if (s->offset != s->inuse)
		return s->inuse;
	return s->inuse + sizeof(void *);
}

Also this needs a comment about why we're doing this ... something about
the freelist pointer, I think?
Waiman Long April 27, 2020, 1:56 p.m. UTC | #5
On 4/27/20 9:38 AM, Matthew Wilcox wrote:
> On Mon, Apr 27, 2020 at 09:29:41AM -0400, Waiman Long wrote:
>> On 4/27/20 9:18 AM, Waiman Long wrote:
>>> On 4/27/20 8:38 AM, Matthew Wilcox wrote:
>>>> On Sun, Apr 26, 2020 at 10:02:12PM -0400, Waiman Long wrote:
>>>>> In a couple of places in the slub memory allocator, the code uses
>>>>> "s->offset" as a check to see if the free pointer is put right
>>>>> after the
>>>>> object. That check is no longer true with commit 3202fa62fb43 ("slub:
>>>>> relocate freelist pointer to middle of object").
>>>>>
>>>>> As a result, echoing "1" into the validate sysfs file, e.g. of dentry,
>>>>> may cause a bunch of "Freepointer corrupt" error reports to appear with
>>>>> the system in panic afterwards.
>>>>>
>>>>> To fix it, use the check "s->offset == s->inuse" instead.
>>>> I think a little refactoring would make this more clear.
>>>>
>>>> unsigned int track_offset(const struct kmem_cache *s)
>>>> {
>>>>      return s->inuse + (s->offset == s->inuse) ? sizeof(void *) : 0;
>>>> }
>>> Yes, that was what I am thinking of doing in v2.
>> BTW, "+" has a higher priority than "?:". So we need a parenthesis around
>> "?:".
> That seems like a good reason to not use ?:
>
> unsigned int track_offset(const struct kmem_cache *s)
> {
> 	if (s->offset != s->inuse)
> 		return s->inuse;
> 	return s->inuse + sizeof(void *);
> }
>
> Also this needs a comment about why we're doing this ... something about
> the freelist pointer, I think?
>
I can see a simple if-else to make it easier to read.

Thanks,
Longman
diff mbox series

Patch

diff --git a/mm/slub.c b/mm/slub.c
index 0e736d66bb42..99952d01e7e0 100644
--- a/mm/slub.c
+++ b/mm/slub.c
@@ -556,10 +556,8 @@  static struct track *get_track(struct kmem_cache *s, void *object,
 {
 	struct track *p;
 
-	if (s->offset)
-		p = object + s->offset + sizeof(void *);
-	else
-		p = object + s->inuse;
+	p = object + s->inuse +
+	    ((s->offset == s->inuse) ? sizeof(void *) : 0);
 
 	return p + alloc;
 }
@@ -693,10 +691,8 @@  static void print_trailer(struct kmem_cache *s, struct page *page, u8 *p)
 		print_section(KERN_ERR, "Redzone ", p + s->object_size,
 			s->inuse - s->object_size);
 
-	if (s->offset)
-		off = s->offset + sizeof(void *);
-	else
-		off = s->inuse;
+	off = s->inuse +
+	      ((s->offset == s->inuse) ? sizeof(void *) : 0);
 
 	if (s->flags & SLAB_STORE_USER)
 		off += 2 * sizeof(struct track);
@@ -790,7 +786,7 @@  static int check_bytes_and_report(struct kmem_cache *s, struct page *page,
  * object address
  * 	Bytes of the object to be managed.
  * 	If the freepointer may overlay the object then the free
- * 	pointer is the first word of the object.
+ *	pointer is at the middle of the object.
  *
  * 	Poisoning uses 0x6b (POISON_FREE) and the last byte is
  * 	0xa5 (POISON_END)
@@ -826,7 +822,7 @@  static int check_pad_bytes(struct kmem_cache *s, struct page *page, u8 *p)
 {
 	unsigned long off = s->inuse;	/* The end of info */
 
-	if (s->offset)
+	if (s->offset == s->inuse)
 		/* Freepointer is placed after the object. */
 		off += sizeof(void *);
 
@@ -915,7 +911,7 @@  static int check_object(struct kmem_cache *s, struct page *page,
 		check_pad_bytes(s, page, p);
 	}
 
-	if (!s->offset && val == SLUB_RED_ACTIVE)
+	if ((s->offset != s->inuse) && val == SLUB_RED_ACTIVE)
 		/*
 		 * Object and freepointer overlap. Cannot check
 		 * freepointer while object is allocated.