diff mbox series

[v6,5/5] input: mt: cleanup open-coded __set_bit()

Message ID cf1dda3a372896cb01033ce084a7deb9620df7aa.1594599118.git.mirq-linux@rere.qmqm.pl (mailing list archive)
State Accepted
Commit 606e7022078410ce4456e760e80f5e4b68c63476
Headers show
Series input: elants: Support Asus TF300T touchscreen | expand

Commit Message

Michał Mirosław July 13, 2020, 12:24 a.m. UTC
Replace open-coded __set_bit() with the function.

Signed-off-by: Michał Mirosław <mirq-linux@rere.qmqm.pl>
---
 drivers/input/input-mt.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Dmitry Torokhov July 16, 2020, 12:30 a.m. UTC | #1
On Mon, Jul 13, 2020 at 02:24:55AM +0200, Michał Mirosław wrote:
> Replace open-coded __set_bit() with the function.
> 
> Signed-off-by: Michał Mirosław <mirq-linux@rere.qmqm.pl>

Applied, thank you.
Dmitry Osipenko Aug. 13, 2020, 6:33 p.m. UTC | #2
16.07.2020 03:30, Dmitry Torokhov пишет:
> On Mon, Jul 13, 2020 at 02:24:55AM +0200, Michał Mirosław wrote:
>> Replace open-coded __set_bit() with the function.
>>
>> Signed-off-by: Michał Mirosław <mirq-linux@rere.qmqm.pl>
> 
> Applied, thank you.
> 

Hello, Dmitry!

Could you please let us know how we could proceed with applying the rest
of the patches?

The device-tree for Nexus 7 2012 [1] has been merged into upcoming v5.9
and I'd want to add the touchscreen support.

[1]
https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/commit/?id=2720008f4239cf36d57b8d0b3cb2a49d4368a378

The missing elants_i2c driver functionality doesn't really block making
a device-tree change since elants_i2c.yaml DT binding already supports
the ektf3624 TS model, but will be nice to get a full featured support.

Thanks in advance!
diff mbox series

Patch

diff --git a/drivers/input/input-mt.c b/drivers/input/input-mt.c
index a81e14148407..f699538bdac4 100644
--- a/drivers/input/input-mt.c
+++ b/drivers/input/input-mt.c
@@ -16,7 +16,7 @@  static void copy_abs(struct input_dev *dev, unsigned int dst, unsigned int src)
 	if (dev->absinfo && test_bit(src, dev->absbit)) {
 		dev->absinfo[dst] = dev->absinfo[src];
 		dev->absinfo[dst].fuzz = 0;
-		dev->absbit[BIT_WORD(dst)] |= BIT_MASK(dst);
+		__set_bit(dst, dev->absbit);
 	}
 }