diff mbox series

[06/29] wil6210: Fix a couple of formatting issues in 'wil6210_debugfs_init'

Message ID 20200910065431.657636-7-lee.jones@linaro.org (mailing list archive)
State Rejected
Delegated to: Kalle Valo
Headers show
Series Rid W=1 warnings in Wireless | expand

Commit Message

Lee Jones Sept. 10, 2020, 6:54 a.m. UTC
Kerneldoc expects attributes/parameters to be in '@*.: ' format and
gets confused if the variable does not follow the type/attribute
definitions.

Fixes the following W=1 kernel build warning(s):

 drivers/net/wireless/ath/wil6210/debugfs.c:456: warning: Function parameter or member 'wil' not described in 'wil6210_debugfs_init_offset'
 drivers/net/wireless/ath/wil6210/debugfs.c:456: warning: Function parameter or member 'dbg' not described in 'wil6210_debugfs_init_offset'
 drivers/net/wireless/ath/wil6210/debugfs.c:456: warning: Function parameter or member 'base' not described in 'wil6210_debugfs_init_offset'
 drivers/net/wireless/ath/wil6210/debugfs.c:456: warning: Function parameter or member 'tbl' not described in 'wil6210_debugfs_init_offset'

Cc: Kalle Valo <kvalo@codeaurora.org>
Cc: "David S. Miller" <davem@davemloft.net>
Cc: Jakub Kicinski <kuba@kernel.org>
Cc: linux-wireless@vger.kernel.org
Cc: wil6210@qti.qualcomm.com
Cc: netdev@vger.kernel.org
Reviewed-by: Maya Erez <merez@codeaurora.org>
Signed-off-by: Lee Jones <lee.jones@linaro.org>
---
 drivers/net/wireless/ath/wil6210/debugfs.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

Comments

Kalle Valo Sept. 12, 2020, 6:34 a.m. UTC | #1
Lee Jones <lee.jones@linaro.org> wrote:

> Kerneldoc expects attributes/parameters to be in '@*.: ' format and
> gets confused if the variable does not follow the type/attribute
> definitions.
> 
> Fixes the following W=1 kernel build warning(s):
> 
>  drivers/net/wireless/ath/wil6210/debugfs.c:456: warning: Function parameter or member 'wil' not described in 'wil6210_debugfs_init_offset'
>  drivers/net/wireless/ath/wil6210/debugfs.c:456: warning: Function parameter or member 'dbg' not described in 'wil6210_debugfs_init_offset'
>  drivers/net/wireless/ath/wil6210/debugfs.c:456: warning: Function parameter or member 'base' not described in 'wil6210_debugfs_init_offset'
>  drivers/net/wireless/ath/wil6210/debugfs.c:456: warning: Function parameter or member 'tbl' not described in 'wil6210_debugfs_init_offset'
> 
> Cc: Kalle Valo <kvalo@codeaurora.org>
> Cc: "David S. Miller" <davem@davemloft.net>
> Cc: Jakub Kicinski <kuba@kernel.org>
> Cc: linux-wireless@vger.kernel.org
> Cc: wil6210@qti.qualcomm.com
> Cc: netdev@vger.kernel.org
> Reviewed-by: Maya Erez <merez@codeaurora.org>
> Signed-off-by: Lee Jones <lee.jones@linaro.org>

Aren't these also applied already? Please don't resend already applied
patches.

8 patches set to Rejected.

11766845 [06/29] wil6210: Fix a couple of formatting issues in 'wil6210_debugfs_init'
11766747 [16/29] wil6210: wmi: Fix formatting and demote non-conforming function headers
11766827 [17/29] wil6210: interrupt: Demote comment header which is clearly not kernel-doc
11766825 [18/29] wil6210: txrx: Demote obvious abuse of kernel-doc
11766823 [19/29] wil6210: txrx_edma: Demote comments which are clearly not kernel-doc
11766821 [20/29] wil6210: pmc: Demote a few nonconformant kernel-doc function headers
11766819 [21/29] wil6210: wil_platform: Demote kernel-doc header to standard comment block
11766817 [22/29] wil6210: wmi: Correct misnamed function parameter 'ptr_'
Lee Jones Sept. 15, 2020, 9:17 a.m. UTC | #2
On Sat, 12 Sep 2020, Kalle Valo wrote:

> Lee Jones <lee.jones@linaro.org> wrote:
> 
> > Kerneldoc expects attributes/parameters to be in '@*.: ' format and
> > gets confused if the variable does not follow the type/attribute
> > definitions.
> > 
> > Fixes the following W=1 kernel build warning(s):
> > 
> >  drivers/net/wireless/ath/wil6210/debugfs.c:456: warning: Function parameter or member 'wil' not described in 'wil6210_debugfs_init_offset'
> >  drivers/net/wireless/ath/wil6210/debugfs.c:456: warning: Function parameter or member 'dbg' not described in 'wil6210_debugfs_init_offset'
> >  drivers/net/wireless/ath/wil6210/debugfs.c:456: warning: Function parameter or member 'base' not described in 'wil6210_debugfs_init_offset'
> >  drivers/net/wireless/ath/wil6210/debugfs.c:456: warning: Function parameter or member 'tbl' not described in 'wil6210_debugfs_init_offset'
> > 
> > Cc: Kalle Valo <kvalo@codeaurora.org>
> > Cc: "David S. Miller" <davem@davemloft.net>
> > Cc: Jakub Kicinski <kuba@kernel.org>
> > Cc: linux-wireless@vger.kernel.org
> > Cc: wil6210@qti.qualcomm.com
> > Cc: netdev@vger.kernel.org
> > Reviewed-by: Maya Erez <merez@codeaurora.org>
> > Signed-off-by: Lee Jones <lee.jones@linaro.org>
> 
> Aren't these also applied already? Please don't resend already applied
> patches.

Not at the time I rebased them.

> 8 patches set to Rejected.
> 
> 11766845 [06/29] wil6210: Fix a couple of formatting issues in 'wil6210_debugfs_init'
> 11766747 [16/29] wil6210: wmi: Fix formatting and demote non-conforming function headers
> 11766827 [17/29] wil6210: interrupt: Demote comment header which is clearly not kernel-doc
> 11766825 [18/29] wil6210: txrx: Demote obvious abuse of kernel-doc
> 11766823 [19/29] wil6210: txrx_edma: Demote comments which are clearly not kernel-doc
> 11766821 [20/29] wil6210: pmc: Demote a few nonconformant kernel-doc function headers
> 11766819 [21/29] wil6210: wil_platform: Demote kernel-doc header to standard comment block
> 11766817 [22/29] wil6210: wmi: Correct misnamed function parameter 'ptr_'
diff mbox series

Patch

diff --git a/drivers/net/wireless/ath/wil6210/debugfs.c b/drivers/net/wireless/ath/wil6210/debugfs.c
index 11d0c79e90562..2d618f90afa7b 100644
--- a/drivers/net/wireless/ath/wil6210/debugfs.c
+++ b/drivers/net/wireless/ath/wil6210/debugfs.c
@@ -443,10 +443,10 @@  DEFINE_DEBUGFS_ATTRIBUTE(wil_fops_ulong, wil_debugfs_ulong_get,
 
 /**
  * wil6210_debugfs_init_offset - create set of debugfs files
- * @wil - driver's context, used for printing
- * @dbg - directory on the debugfs, where files will be created
- * @base - base address used in address calculation
- * @tbl - table with file descriptions. Should be terminated with empty element.
+ * @wil: driver's context, used for printing
+ * @dbg: directory on the debugfs, where files will be created
+ * @base: base address used in address calculation
+ * @tbl: table with file descriptions. Should be terminated with empty element.
  *
  * Creates files accordingly to the @tbl.
  */