mount: make sure mount correctly when kernel not support NFSv4
diff mbox

Message ID 4CEDFA23.5030103@cn.fujitsu.com
State Superseded, archived
Headers show

Commit Message

Mi Jinlong Nov. 25, 2010, 5:54 a.m. UTC
None

Patch
diff mbox

diff --git a/utils/mount/stropts.c b/utils/mount/stropts.c
index 50a1a2a..e880c45 100644
--- a/utils/mount/stropts.c
+++ b/utils/mount/stropts.c
@@ -788,6 +788,10 @@  static int nfs_autonegotiate(struct nfsmount_info *mi)
 		/* Linux servers prior to 2.6.25 may return
 		 * EPERM when NFS version 4 is not supported. */
 		goto fall_back;
+	case EINVAL:
+		/* If Linux kernel don't support NFSv4, the EINVAL
+		 * will be return for parsing option (vers=4) fail. */
+		goto fall_back;
 	default:
 		return result;
 	}