[2/4] ASoC: esai: Add Vybird and LS1+ compatibles support.
diff mbox

Message ID 1396516257-25354-3-git-send-email-Li.Xiubo@freescale.com
State New, archived
Headers show

Commit Message

Xiubo Li April 3, 2014, 9:10 a.m. UTC
Signed-off-by: Xiubo Li <Li.Xiubo@freescale.com>
---
 sound/soc/fsl/fsl_esai.c | 2 ++
 1 file changed, 2 insertions(+)

Comments

Nicolin Chen April 3, 2014, 11:19 a.m. UTC | #1
On Thu, Apr 03, 2014 at 05:10:55PM +0800, Xiubo Li wrote:
> Signed-off-by: Xiubo Li <Li.Xiubo@freescale.com>
> ---
>  sound/soc/fsl/fsl_esai.c | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/sound/soc/fsl/fsl_esai.c b/sound/soc/fsl/fsl_esai.c
> index 8efc89e..b84951b 100644
> --- a/sound/soc/fsl/fsl_esai.c
> +++ b/sound/soc/fsl/fsl_esai.c
> @@ -818,6 +818,8 @@ static int fsl_esai_probe(struct platform_device *pdev)
>  
>  static const struct of_device_id fsl_esai_dt_ids[] = {
>  	{ .compatible = "fsl,imx35-esai", },
> +	{ .compatible = "fsl,vybird-esai", },

vybird or vybrid?

> +	{ .compatible = "fsl,ls1+-esai", },

Does ls1 differ vybrid on esai part? If not, it should be enough to use
vybrid for both of them, just like imx6q and imx6dl can also use imx35
compatible.

Thanks,
Nicolin

>  	{}
>  };
>  MODULE_DEVICE_TABLE(of, fsl_esai_dt_ids);
> -- 
> 1.8.4
> 
>
Xiubo Li April 4, 2014, 12:46 a.m. UTC | #2
> Subject: Re: [PATCH 2/4] ASoC: esai: Add Vybird and LS1+ compatibles support.
> 
> On Thu, Apr 03, 2014 at 05:10:55PM +0800, Xiubo Li wrote:
> > Signed-off-by: Xiubo Li <Li.Xiubo@freescale.com>
> > ---
> >  sound/soc/fsl/fsl_esai.c | 2 ++
> >  1 file changed, 2 insertions(+)
> >
> > diff --git a/sound/soc/fsl/fsl_esai.c b/sound/soc/fsl/fsl_esai.c
> > index 8efc89e..b84951b 100644
> > --- a/sound/soc/fsl/fsl_esai.c
> > +++ b/sound/soc/fsl/fsl_esai.c
> > @@ -818,6 +818,8 @@ static int fsl_esai_probe(struct platform_device *pdev)
> >
> >  static const struct of_device_id fsl_esai_dt_ids[] = {
> >  	{ .compatible = "fsl,imx35-esai", },
> > +	{ .compatible = "fsl,vybird-esai", },
> 
> vybird or vybrid?
> 
> > +	{ .compatible = "fsl,ls1+-esai", },
> 
> Does ls1 differ vybrid on esai part? If not, it should be enough to use
> vybrid for both of them, just like imx6q and imx6dl can also use imx35
> compatible.
> 

Just like the imx series as you described, and that looks nice.

Thanks,

> Thanks,
> Nicolin
> 
> >  	{}
> >  };
> >  MODULE_DEVICE_TABLE(of, fsl_esai_dt_ids);
> > --
> > 1.8.4
> >
> >

Patch
diff mbox

diff --git a/sound/soc/fsl/fsl_esai.c b/sound/soc/fsl/fsl_esai.c
index 8efc89e..b84951b 100644
--- a/sound/soc/fsl/fsl_esai.c
+++ b/sound/soc/fsl/fsl_esai.c
@@ -818,6 +818,8 @@  static int fsl_esai_probe(struct platform_device *pdev)
 
 static const struct of_device_id fsl_esai_dt_ids[] = {
 	{ .compatible = "fsl,imx35-esai", },
+	{ .compatible = "fsl,vybird-esai", },
+	{ .compatible = "fsl,ls1+-esai", },
 	{}
 };
 MODULE_DEVICE_TABLE(of, fsl_esai_dt_ids);