diff mbox

[4/7] vga_switcheroo: Cleanup header comment

Message ID 1431082249-18681-5-git-send-email-thierry.reding@gmail.com (mailing list archive)
State New, archived
Headers show

Commit Message

Thierry Reding May 8, 2015, 10:50 a.m. UTC
From: Thierry Reding <treding@nvidia.com>

The header comment uses a weird combination of formatting styles. Make
it consistent.

Signed-off-by: Thierry Reding <treding@nvidia.com>
---
 drivers/gpu/vga/vga_switcheroo.c | 18 +++++++++---------
 1 file changed, 9 insertions(+), 9 deletions(-)

Comments

Lukas Wunner May 8, 2015, 1:18 p.m. UTC | #1
Hi Thierry,

On Fri, May 08, 2015 at 12:50:46PM +0200, Thierry Reding wrote:
> + *
> + * Switcher interface - methods require for ATPX and DCM
> + * - switchto - this throws the output MUX switch
> + * - discrete_set_power - sets the power state for the discrete card
> + *
> + * GPU driver interface
> + * - set_gpu_state - this should do the equiv of s/r for the card
> + *                 - this should *not* set the discrete power state
> + * - switch_check  - check if the device is in a position to switch now

That documentation is actually wrong, I fixed it in my MacBook Pro
gpu switching patchset but that is still under development and thus
not merged. Might as well fix it with this patch (if you want):

s/discrete_set_power - sets the power state for the discrete card/power_state - sets the power state for either GPU/
s/switch_check/can_switch/

Best regards,

Lukas
diff mbox

Patch

diff --git a/drivers/gpu/vga/vga_switcheroo.c b/drivers/gpu/vga/vga_switcheroo.c
index 0611ea8a5c49..610e2cd72563 100644
--- a/drivers/gpu/vga/vga_switcheroo.c
+++ b/drivers/gpu/vga/vga_switcheroo.c
@@ -6,15 +6,15 @@ 
  * Licensed under GPLv2
  *
  * vga_switcheroo.c - Support for laptop with dual GPU using one set of outputs
-
- Switcher interface - methods require for ATPX and DCM
- - switchto - this throws the output MUX switch
- - discrete_set_power - sets the power state for the discrete card
-
- GPU driver interface
- - set_gpu_state - this should do the equiv of s/r for the card
-		  - this should *not* set the discrete power state
- - switch_check  - check if the device is in a position to switch now
+ *
+ * Switcher interface - methods require for ATPX and DCM
+ * - switchto - this throws the output MUX switch
+ * - discrete_set_power - sets the power state for the discrete card
+ *
+ * GPU driver interface
+ * - set_gpu_state - this should do the equiv of s/r for the card
+ *                 - this should *not* set the discrete power state
+ * - switch_check  - check if the device is in a position to switch now
  */
 
 #include <linux/module.h>