diff mbox

[v4,3/17] video: fbdev: gbefb: use arch_phys_wc_add() and devm_ioremap_wc()

Message ID 1432859434-17821-3-git-send-email-mcgrof@do-not-panic.com (mailing list archive)
State New, archived
Headers show

Commit Message

Luis R. Rodriguez May 29, 2015, 12:30 a.m. UTC
From: "Luis R. Rodriguez" <mcgrof@suse.com>

Convert the driver from using the x86 specific MTRR code to
the architecture agnostic arch_phys_wc_add(). arch_phys_wc_add()
will avoid MTRR if write-combining is available, in order to
take advantage of that also ensure the ioremap'd area is requested
as write-combining.

There are a few motivations for this:

a) Take advantage of PAT when available

b) Help bury MTRR code away, MTRR is architecture specific and on
   x86 its replaced by PAT

c) Help with the goal of eventually using _PAGE_CACHE_UC over
   _PAGE_CACHE_UC_MINUS on x86 on ioremap_nocache() (see commit
   de33c442e titled "x86 PAT: fix performance drop for glx,
   use UC minus for ioremap(), ioremap_nocache() and
   pci_mmap_page_range()")

The conversion done is expressed by the following Coccinelle
SmPL patch, it additionally required manual intervention to
address all the #ifdery and removal of redundant things which
arch_phys_wc_add() already addresses such as verbose message
about when MTRR fails and doing nothing when we didn't get
an MTRR.

@ mtrr_found @
expression index, base, size;
@@

-index = mtrr_add(base, size, MTRR_TYPE_WRCOMB, 1);
+index = arch_phys_wc_add(base, size);

@ mtrr_rm depends on mtrr_found @
expression mtrr_found.index, mtrr_found.base, mtrr_found.size;
@@

-mtrr_del(index, base, size);
+arch_phys_wc_del(index);

@ mtrr_rm_zero_arg depends on mtrr_found @
expression mtrr_found.index;
@@

-mtrr_del(index, 0, 0);
+arch_phys_wc_del(index);

@ mtrr_rm_fb_info depends on mtrr_found @
struct fb_info *info;
expression mtrr_found.index;
@@

-mtrr_del(index, info->fix.smem_start, info->fix.smem_len);
+arch_phys_wc_del(index);

@ ioremap_replace_nocache depends on mtrr_found @
struct fb_info *info;
expression base, size;
@@

-info->screen_base = ioremap_nocache(base, size);
+info->screen_base = ioremap_wc(base, size);

@ ioremap_replace_default depends on mtrr_found @
struct fb_info *info;
expression base, size;
@@

-info->screen_base = ioremap(base, size);
+info->screen_base = ioremap_wc(base, size);

Generated-by: Coccinelle SmPL
Cc: Thomas Gleixner <tglx@linutronix.de>
Cc: Juergen Gross <jgross@suse.com>
Cc: Jingoo Han <jg1.han@samsung.com>
Cc: Daniel Vetter <daniel.vetter@ffwll.ch>
Cc: Masanari Iida <standby24x7@gmail.com>
Cc: Suresh Siddha <sbsiddha@gmail.com>
Cc: Ingo Molnar <mingo@elte.hu>
Cc: Andy Lutomirski <luto@amacapital.net>
Cc: Dave Airlie <airlied@redhat.com>
Cc: Antonino Daplas <adaplas@gmail.com>
Cc: Jean-Christophe Plagniol-Villard <plagnioj@jcrosoft.com>
Cc: Tomi Valkeinen <tomi.valkeinen@ti.com>
Cc: linux-fbdev@vger.kernel.org
Cc: linux-kernel@vger.kernel.org
Signed-off-by: Luis R. Rodriguez <mcgrof@suse.com>
---
 drivers/video/fbdev/gbefb.c | 26 +++++++-------------------
 1 file changed, 7 insertions(+), 19 deletions(-)

Comments

Ingo Molnar May 29, 2015, 6:41 a.m. UTC | #1
* Luis R. Rodriguez <mcgrof@do-not-panic.com> wrote:

> +		gbe_mem = devm_ioremap_wc(&p_dev->dev, gbe_mem_phys,
> +					  gbe_mem_size);

> +		gbe_mem = dma_alloc_writecombine(NULL, gbe_mem_size,
> +						 &gbe_dma_addr, GFP_KERNEL);

> +	par->wc_cookie = arch_phys_wc_add(gbe_mem_phys, gbe_mem_size);

> +	arch_phys_wc_del(par->wc_cookie);

> +	arch_phys_wc_del(par->wc_cookie);

Could we _please_ rename dma_*_writecombine() to dma_*_wc(), so that the naming is 
coherent across the various APIs?

Thanks,

	Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-fbdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Luis Chamberlain May 30, 2015, 12:32 a.m. UTC | #2
On Fri, May 29, 2015 at 08:41:44AM +0200, Ingo Molnar wrote:
> 
> * Luis R. Rodriguez <mcgrof@do-not-panic.com> wrote:
> 
> > +		gbe_mem = devm_ioremap_wc(&p_dev->dev, gbe_mem_phys,
> > +					  gbe_mem_size);
> 
> > +		gbe_mem = dma_alloc_writecombine(NULL, gbe_mem_size,
> > +						 &gbe_dma_addr, GFP_KERNEL);
> 
> > +	par->wc_cookie = arch_phys_wc_add(gbe_mem_phys, gbe_mem_size);
> 
> > +	arch_phys_wc_del(par->wc_cookie);
> 
> > +	arch_phys_wc_del(par->wc_cookie);
> 
> Could we _please_ rename dma_*_writecombine() to dma_*_wc(), so that the naming is 
> coherent across the various APIs?

Sure, OK done. Will send once this series is merged and visible on linux-next.
But who's tree should this go through? Since it depends on this series which
goes through Tomi's tree should it go through there?

 Luis
--
To unsubscribe from this list: send the line "unsubscribe linux-fbdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Ingo Molnar June 1, 2015, 8:53 a.m. UTC | #3
* Luis R. Rodriguez <mcgrof@suse.com> wrote:

> On Fri, May 29, 2015 at 08:41:44AM +0200, Ingo Molnar wrote:
> > 
> > * Luis R. Rodriguez <mcgrof@do-not-panic.com> wrote:
> > 
> > > +		gbe_mem = devm_ioremap_wc(&p_dev->dev, gbe_mem_phys,
> > > +					  gbe_mem_size);
> > 
> > > +		gbe_mem = dma_alloc_writecombine(NULL, gbe_mem_size,
> > > +						 &gbe_dma_addr, GFP_KERNEL);
> > 
> > > +	par->wc_cookie = arch_phys_wc_add(gbe_mem_phys, gbe_mem_size);
> > 
> > > +	arch_phys_wc_del(par->wc_cookie);
> > 
> > > +	arch_phys_wc_del(par->wc_cookie);
> > 
> > Could we _please_ rename dma_*_writecombine() to dma_*_wc(), so that the naming is 
> > coherent across the various APIs?
> 
> Sure, OK done. Will send once this series is merged and visible on linux-next. 
> But who's tree should this go through? Since it depends on this series which 
> goes through Tomi's tree should it go through there?

So we could do the rename near the end of the merge window, when all the patches 
have drained from maintainer trees into Linus's tree. Mind keeping it in your tree 
until then?

Thanks,

	Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-fbdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Luis Chamberlain June 1, 2015, 3:57 p.m. UTC | #4
On Mon, Jun 1, 2015 at 1:53 AM, Ingo Molnar <mingo@kernel.org> wrote:
>
> * Luis R. Rodriguez <mcgrof@suse.com> wrote:
>
>> On Fri, May 29, 2015 at 08:41:44AM +0200, Ingo Molnar wrote:
>> >
>> > * Luis R. Rodriguez <mcgrof@do-not-panic.com> wrote:
>> >
>> > > +         gbe_mem = devm_ioremap_wc(&p_dev->dev, gbe_mem_phys,
>> > > +                                   gbe_mem_size);
>> >
>> > > +         gbe_mem = dma_alloc_writecombine(NULL, gbe_mem_size,
>> > > +                                          &gbe_dma_addr, GFP_KERNEL);
>> >
>> > > + par->wc_cookie = arch_phys_wc_add(gbe_mem_phys, gbe_mem_size);
>> >
>> > > + arch_phys_wc_del(par->wc_cookie);
>> >
>> > > + arch_phys_wc_del(par->wc_cookie);
>> >
>> > Could we _please_ rename dma_*_writecombine() to dma_*_wc(), so that the naming is
>> > coherent across the various APIs?
>>
>> Sure, OK done. Will send once this series is merged and visible on linux-next.
>> But who's tree should this go through? Since it depends on this series which
>> goes through Tomi's tree should it go through there?
>
> So we could do the rename near the end of the merge window, when all the patches
> have drained from maintainer trees into Linus's tree.

OK.

> Mind keeping it in your tree until then?

You got it.

 Luis
--
To unsubscribe from this list: send the line "unsubscribe linux-fbdev" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
diff mbox

Patch

diff --git a/drivers/video/fbdev/gbefb.c b/drivers/video/fbdev/gbefb.c
index 4e54faa06..d2601808 100644
--- a/drivers/video/fbdev/gbefb.c
+++ b/drivers/video/fbdev/gbefb.c
@@ -22,9 +22,6 @@ 
 #include <linux/module.h>
 #include <linux/io.h>
 
-#ifdef CONFIG_X86
-#include <asm/mtrr.h>
-#endif
 #ifdef CONFIG_MIPS
 #include <asm/addrspace.h>
 #endif
@@ -1176,8 +1173,8 @@  static int gbefb_probe(struct platform_device *p_dev)
 
 	if (gbe_mem_phys) {
 		/* memory was allocated at boot time */
-		gbe_mem = devm_ioremap_nocache(&p_dev->dev, gbe_mem_phys,
-					       gbe_mem_size);
+		gbe_mem = devm_ioremap_wc(&p_dev->dev, gbe_mem_phys,
+					  gbe_mem_size);
 		if (!gbe_mem) {
 			printk(KERN_ERR "gbefb: couldn't map framebuffer\n");
 			ret = -ENOMEM;
@@ -1188,8 +1185,8 @@  static int gbefb_probe(struct platform_device *p_dev)
 	} else {
 		/* try to allocate memory with the classical allocator
 		 * this has high chance to fail on low memory machines */
-		gbe_mem = dma_alloc_coherent(NULL, gbe_mem_size, &gbe_dma_addr,
-					     GFP_KERNEL);
+		gbe_mem = dma_alloc_writecombine(NULL, gbe_mem_size,
+						 &gbe_dma_addr, GFP_KERNEL);
 		if (!gbe_mem) {
 			printk(KERN_ERR "gbefb: couldn't allocate framebuffer memory\n");
 			ret = -ENOMEM;
@@ -1200,10 +1197,7 @@  static int gbefb_probe(struct platform_device *p_dev)
 	}
 
 	par = info->par;
-#ifdef CONFIG_X86
-	par->wc_cookie = mtrr_add(gbe_mem_phys, gbe_mem_size,
-				   MTRR_TYPE_WRCOMB, 1);
-#endif
+	par->wc_cookie = arch_phys_wc_add(gbe_mem_phys, gbe_mem_size);
 
 	/* map framebuffer memory into tiles table */
 	for (i = 0; i < (gbe_mem_size >> TILE_SHIFT); i++)
@@ -1242,10 +1236,7 @@  static int gbefb_probe(struct platform_device *p_dev)
 	return 0;
 
 out_gbe_unmap:
-#ifdef CONFIG_MTRR
-	if (par->wc_cookie >= 0)
-		mtrr_del(par->wc_cookie, 0, 0);
-#endif
+	arch_phys_wc_del(par->wc_cookie);
 	if (gbe_dma_addr)
 		dma_free_coherent(NULL, gbe_mem_size, gbe_mem, gbe_mem_phys);
 out_tiles_free:
@@ -1266,10 +1257,7 @@  static int gbefb_remove(struct platform_device* p_dev)
 
 	unregister_framebuffer(info);
 	gbe_turn_off();
-#ifdef CONFIG_MTRR
-	if (par->wc_cookie >= 0)
-		mtrr_del(par->wc_cookie, 0, 0);
-#endif
+	arch_phys_wc_del(par->wc_cookie);
 	if (gbe_dma_addr)
 		dma_free_coherent(NULL, gbe_mem_size, gbe_mem, gbe_mem_phys);
 	dma_free_coherent(NULL, GBE_TLB_SIZE * sizeof(uint16_t),