diff mbox

[RFC,v3,2/3] ia64: rename migrate_irqs() to avoid compiling error

Message ID 1442375907-11496-3-git-send-email-yangyingliang@huawei.com (mailing list archive)
State New, archived
Headers show

Commit Message

Yang Yingliang Sept. 16, 2015, 3:58 a.m. UTC
To avoid multi-declaration error after adding migrate_irqs into
kernel/irq/migration.c, rename migrate_irqs() to move_irqs().

Cc: Jiang Liu <jiang.liu@linux.intel.com>
Cc: Thomas Gleixner <tglx@linutronix.de>
Cc: Marc Zyngier <marc.zyngier@arm.com>
Cc: Mark Rutland <mark.rutland@arm.com>
Cc: Will Deacon <will.deacon@arm.com>
Cc: Russell King - ARM Linux <linux@arm.linux.org.uk>
Cc: Hanjun Guo <hanjun.guo@linaro.org>
Signed-off-by: Yang Yingliang <yangyingliang@huawei.com>
---
 arch/ia64/kernel/irq.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Thomas Gleixner Sept. 16, 2015, 8:21 a.m. UTC | #1
On Wed, 16 Sep 2015, Yang Yingliang wrote:

> To avoid multi-declaration error after adding migrate_irqs into
> kernel/irq/migration.c, rename migrate_irqs() to move_irqs().

And why can't you chose a different name for the generic function
instead of creating useless churn in IA64?
 
Thanks,

	tglx
Yang Yingliang Sept. 16, 2015, 11:13 a.m. UTC | #2
On 2015/9/16 16:21, Thomas Gleixner wrote:
> On Wed, 16 Sep 2015, Yang Yingliang wrote:
>
>> To avoid multi-declaration error after adding migrate_irqs into
>> kernel/irq/migration.c, rename migrate_irqs() to move_irqs().
>
> And why can't you chose a different name for the generic function
> instead of creating useless churn in IA64?

I am not sure which way is better at first. Never mind, I will chose a 
new name for the generic function.

Thanks,
Yang
>
> Thanks,
>
> 	tglx
>
> .
>
diff mbox

Patch

diff --git a/arch/ia64/kernel/irq.c b/arch/ia64/kernel/irq.c
index de4fc00..005f339 100644
--- a/arch/ia64/kernel/irq.c
+++ b/arch/ia64/kernel/irq.c
@@ -98,7 +98,7 @@  unsigned int vectors_in_migration[NR_IRQS];
  * Since cpu_online_mask is already updated, we just need to check for
  * affinity that has zeros
  */
-static void migrate_irqs(void)
+static void move_irqs(void)
 {
 	int 		irq, new_cpu;
 
@@ -167,7 +167,7 @@  void fixup_irqs(void)
 	 * Phase 1: Locate IRQs bound to this cpu and
 	 * relocate them for cpu removal.
 	 */
-	migrate_irqs();
+	move_irqs();
 
 	/*
 	 * Phase 2: Perform interrupt processing for all entries reported in