[PULL,1/3] spice/gl: Enable dmabuf only for spice >= 0.13.1
diff mbox

Message ID 1456742670-808-2-git-send-email-kraxel@redhat.com
State New
Headers show

Commit Message

Gerd Hoffmann Feb. 29, 2016, 10:44 a.m. UTC
From: Michal Privoznik <mprivozn@redhat.com>

After 474114b7 the dmabuf feature is enabled whenever spice
greater than or equal to spice 0.13.0 is found. This is because
two new functions are required: spice_qxl_gl_scanout and
spice_qxl_gl_draw_async. These were, however, introduce in 0.13.1
release. Well, technically they haven't been released yet, but
for sure they are not going to be part of 0.13.0 release (for the
ABI stability sake).

Signed-off-by: Michal Privoznik <mprivozn@redhat.com>
Message-id: 1a724e97cb587624d6f6009c15395496bccfa32b.1456317738.git.mprivozn@redhat.com
Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
---
 include/ui/spice-display.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch
diff mbox

diff --git a/include/ui/spice-display.h b/include/ui/spice-display.h
index 69a222b..30ccfe3 100644
--- a/include/ui/spice-display.h
+++ b/include/ui/spice-display.h
@@ -25,7 +25,7 @@ 
 #include "sysemu/sysemu.h"
 
 #if defined(CONFIG_OPENGL_DMABUF)
-# if SPICE_SERVER_VERSION >= 0x000d00 /* release 0.13.0 */
+# if SPICE_SERVER_VERSION >= 0x000d01 /* release 0.13.1 */
 #  define HAVE_SPICE_GL 1
 #  include "ui/egl-helpers.h"
 #  include "ui/egl-context.h"