diff mbox

xl: rename variable pause to pause_after_migration

Message ID 1469003417-19529-1-git-send-email-wei.liu2@citrix.com (mailing list archive)
State New, archived
Headers show

Commit Message

Wei Liu July 20, 2016, 8:30 a.m. UTC
Gcc 4.4.4 complained that the "pause" variable introduced in 22b430e0
("xl: add option to leave domain paused after migration") shadowed
pause(2) declaration in unistd.h.

Rename "pause" to "pause_after_migration" to fix this issue.

Reported-by: Boris Ostrovsky <boris.ostrovsky@oracle.com>
Signed-off-by: Wei Liu <wei.liu2@citrix.com>
---
Cc: Ian Jackson <ian.jackson@eu.citrix.com>
Cc: Roger Pau Monne <roger.pau@citrix.com>
Cc: Boris Ostrovsky <boris.ostrovsky@oracle.com>
---
 tools/libxl/xl_cmdimpl.c | 17 +++++++++--------
 1 file changed, 9 insertions(+), 8 deletions(-)

Comments

Roger Pau Monne July 20, 2016, 9:43 a.m. UTC | #1
On Wed, Jul 20, 2016 at 09:30:17AM +0100, Wei Liu wrote:
> Gcc 4.4.4 complained that the "pause" variable introduced in 22b430e0
> ("xl: add option to leave domain paused after migration") shadowed
> pause(2) declaration in unistd.h.
> 
> Rename "pause" to "pause_after_migration" to fix this issue.
> 
> Reported-by: Boris Ostrovsky <boris.ostrovsky@oracle.com>
> Signed-off-by: Wei Liu <wei.liu2@citrix.com>

Acked-by: Roger Pau Monné <roger.pau@citrix.com>

Thanks, I haven't noticied that it was shadowing pause(2).
Wei Liu July 20, 2016, 10:34 a.m. UTC | #2
On Wed, Jul 20, 2016 at 11:43:19AM +0200, Roger Pau Monne wrote:
> On Wed, Jul 20, 2016 at 09:30:17AM +0100, Wei Liu wrote:
> > Gcc 4.4.4 complained that the "pause" variable introduced in 22b430e0
> > ("xl: add option to leave domain paused after migration") shadowed
> > pause(2) declaration in unistd.h.
> > 
> > Rename "pause" to "pause_after_migration" to fix this issue.
> > 
> > Reported-by: Boris Ostrovsky <boris.ostrovsky@oracle.com>
> > Signed-off-by: Wei Liu <wei.liu2@citrix.com>
> 
> Acked-by: Roger Pau Monné <roger.pau@citrix.com>
> 
> Thanks, I haven't noticied that it was shadowing pause(2).

My compile test passed. Newer gcc is happy with that. I didn't bother to
look into the differences between different gcc versions though.

Wei.
Ian Jackson July 20, 2016, 12:12 p.m. UTC | #3
Wei Liu writes ("[PATCH] xl: rename variable pause to pause_after_migration"):
> Gcc 4.4.4 complained that the "pause" variable introduced in 22b430e0
> ("xl: add option to leave domain paused after migration") shadowed
> pause(2) declaration in unistd.h.
> 
> Rename "pause" to "pause_after_migration" to fix this issue.

Acked-by: Ian Jackson <ian.jackson@eu.citrix.com>
Wei Liu July 20, 2016, 3:24 p.m. UTC | #4
Pushed.
diff mbox

Patch

diff --git a/tools/libxl/xl_cmdimpl.c b/tools/libxl/xl_cmdimpl.c
index 82d6254..9267de8 100644
--- a/tools/libxl/xl_cmdimpl.c
+++ b/tools/libxl/xl_cmdimpl.c
@@ -4778,7 +4778,8 @@  static void migrate_domain(uint32_t domid, const char *rune, int debug,
     exit(EXIT_FAILURE);
 }
 
-static void migrate_receive(int debug, int daemonize, int monitor, int pause,
+static void migrate_receive(int debug, int daemonize, int monitor,
+                            int pause_after_migration,
                             int send_fd, int recv_fd,
                             libxl_checkpointed_stream checkpointed,
                             char *colo_proxy_script)
@@ -4888,7 +4889,7 @@  static void migrate_receive(int debug, int daemonize, int monitor, int pause,
         if (rc) goto perhaps_destroy_notify_rc;
     }
 
-    if (!pause) {
+    if (!pause_after_migration) {
         rc = libxl_domain_unpause(ctx, domid);
         if (rc) goto perhaps_destroy_notify_rc;
     }
@@ -5005,7 +5006,7 @@  int main_restore(int argc, char **argv)
 
 int main_migrate_receive(int argc, char **argv)
 {
-    int debug = 0, daemonize = 1, monitor = 1, pause = 0;
+    int debug = 0, daemonize = 1, monitor = 1, pause_after_migration = 0;
     libxl_checkpointed_stream checkpointed = LIBXL_CHECKPOINTED_STREAM_NONE;
     int opt;
     char *script = NULL;
@@ -5037,7 +5038,7 @@  int main_migrate_receive(int argc, char **argv)
         script = optarg;
         break;
     case 'p':
-        pause = 1;
+        pause_after_migration = 1;
         break;
     }
 
@@ -5045,7 +5046,7 @@  int main_migrate_receive(int argc, char **argv)
         help("migrate-receive");
         return EXIT_FAILURE;
     }
-    migrate_receive(debug, daemonize, monitor, pause,
+    migrate_receive(debug, daemonize, monitor, pause_after_migration,
                     STDOUT_FILENO, STDIN_FILENO,
                     checkpointed, script);
 
@@ -5091,7 +5092,7 @@  int main_migrate(int argc, char **argv)
     const char *ssh_command = "ssh";
     char *rune = NULL;
     char *host;
-    int opt, daemonize = 1, monitor = 1, debug = 0, pause = 0;
+    int opt, daemonize = 1, monitor = 1, debug = 0, pause_after_migration = 0;
     static struct option opts[] = {
         {"debug", 0, 0, 0x100},
         {"live", 0, 0, 0x200},
@@ -5113,7 +5114,7 @@  int main_migrate(int argc, char **argv)
         monitor = 0;
         break;
     case 'p':
-        pause = 1;
+        pause_after_migration = 1;
         break;
     case 0x100: /* --debug */
         debug = 1;
@@ -5148,7 +5149,7 @@  int main_migrate(int argc, char **argv)
                   verbose_len, verbose_buf,
                   daemonize ? "" : " -e",
                   debug ? " -d" : "",
-                  pause ? " -p" : "");
+                  pause_after_migration ? " -p" : "");
     }
 
     migrate_domain(domid, rune, debug, config_filename);