[0035/1285] Replace numeric parameter like 0444 with macro
diff mbox

Message ID 20160802103604.16105-1-baolex.ni@intel.com
State New
Headers show

Commit Message

baolex.ni Aug. 2, 2016, 10:36 a.m. UTC
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
 arch/x86/kvm/mmu_audit.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch
diff mbox

diff --git a/arch/x86/kvm/mmu_audit.c b/arch/x86/kvm/mmu_audit.c
index dcce533..d649495 100644
--- a/arch/x86/kvm/mmu_audit.c
+++ b/arch/x86/kvm/mmu_audit.c
@@ -303,4 +303,4 @@  static const struct kernel_param_ops audit_param_ops = {
 	.get = param_get_bool,
 };
 
-arch_param_cb(mmu_audit, &audit_param_ops, &mmu_audit, 0644);
+arch_param_cb(mmu_audit, &audit_param_ops, &mmu_audit, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);