From patchwork Tue Aug 2 10:56:49 2016 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: "baolex.ni" X-Patchwork-Id: 9259253 Return-Path: Received: from mail.wl.linuxfoundation.org (pdx-wl-mail.web.codeaurora.org [172.30.200.125]) by pdx-korg-patchwork.web.codeaurora.org (Postfix) with ESMTP id AEFBB608A1 for ; Tue, 2 Aug 2016 17:17:41 +0000 (UTC) Received: from mail.wl.linuxfoundation.org (localhost [127.0.0.1]) by mail.wl.linuxfoundation.org (Postfix) with ESMTP id 9BBE8279B3 for ; Tue, 2 Aug 2016 17:17:41 +0000 (UTC) Received: by mail.wl.linuxfoundation.org (Postfix, from userid 486) id 9098928532; Tue, 2 Aug 2016 17:17:41 +0000 (UTC) X-Spam-Checker-Version: SpamAssassin 3.3.1 (2010-03-16) on pdx-wl-mail.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-6.9 required=2.0 tests=BAYES_00,RCVD_IN_DNSWL_HI autolearn=ham version=3.3.1 Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by mail.wl.linuxfoundation.org (Postfix) with ESMTP id 4057F28407 for ; Tue, 2 Aug 2016 17:17:41 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S935723AbcHBRQr (ORCPT ); Tue, 2 Aug 2016 13:16:47 -0400 Received: from mga01.intel.com ([192.55.52.88]:19687 "EHLO mga01.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1756404AbcHBLqn (ORCPT ); Tue, 2 Aug 2016 07:46:43 -0400 Received: from fmsmga002.fm.intel.com ([10.253.24.26]) by fmsmga101.fm.intel.com with ESMTP; 02 Aug 2016 04:34:31 -0700 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1033571324" Received: from shsibuild003.sh.intel.com ([10.239.146.225]) by fmsmga002.fm.intel.com with ESMTP; 02 Aug 2016 04:34:28 -0700 From: Baole Ni To: dmitry.torokhov@gmail.com, hal.rosenstock@gmail.com, dledford@redhat.com, sean.hefty@intel.com, bp@alien8.de Cc: linux-input@vger.kernel.org, linux-kernel@vger.kernel.org, aduggan@synaptics.com, cheiny@synaptics.com, robh@kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com Subject: [PATCH 0286/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:56:49 +0800 Message-Id: <20160802105649.432-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-input-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-input@vger.kernel.org X-Virus-Scanned: ClamAV using ClamSMTP I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/input/rmi4/rmi_bus.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/input/rmi4/rmi_bus.c b/drivers/input/rmi4/rmi_bus.c index b368b05..818e6bf 100644 --- a/drivers/input/rmi4/rmi_bus.c +++ b/drivers/input/rmi4/rmi_bus.c @@ -20,7 +20,7 @@ #include "rmi_driver.h" static int debug_flags; -module_param(debug_flags, int, 0644); +module_param(debug_flags, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(debug_flags, "control debugging information"); void rmi_dbg(int flags, struct device *dev, const char *fmt, ...)