[Bug,76490] Hang during boot when DPM is on (R9 270X)
diff mbox

Message ID bug-76490-502-G8Z6JmsZiY@http.bugs.freedesktop.org/
State New
Headers show

Commit Message

bugzilla-daemon@freedesktop.org Sept. 28, 2016, 8:08 p.m. UTC
https://bugs.freedesktop.org/show_bug.cgi?id=76490

--- Comment #117 from Daniel Exner <dex+fdobugzilla@dragonslave.de> ---
(In reply to Alex Deucher from comment #116)
> Created attachment 126814 [details] [review]
> possible fix
> 
> Does this patch help?

I applied the patch on Kernel 4.8.0-rc8-00771-g8ab293e: result is a stable
system as before, so at least it didn't introduce a regression.

Then I disabled the override for my card below:


Result is the same as without your patch: black screen and non responsive
system.

Should I also revert "drm/radeon: load different smc firmware on some SI
variants"?

Patch
diff mbox

diff --git a/drivers/gpu/drm/radeon/si_dpm.c b/drivers/gpu/drm/radeon/si_dpm.c
index e6abc09..bcaa675 100644
--- a/drivers/gpu/drm/radeon/si_dpm.c
+++ b/drivers/gpu/drm/radeon/si_dpm.c
@@ -2924,7 +2924,6 @@  struct si_dpm_quirk {
 /* cards with dpm stability problems */
 static struct si_dpm_quirk si_dpm_quirk_list[] = {
        /* PITCAIRN - https://bugs.freedesktop.org/show_bug.cgi?id=76490 */
-       { PCI_VENDOR_ID_ATI, 0x6810, 0x1462, 0x3036, 0, 120000 },
        { PCI_VENDOR_ID_ATI, 0x6811, 0x174b, 0xe271, 0, 120000 },
        { PCI_VENDOR_ID_ATI, 0x6811, 0x174b, 0x2015, 0, 120000 },
        { PCI_VENDOR_ID_ATI, 0x6810, 0x174b, 0xe271, 85000, 90000 },