[5/7] ALSA: hda: add default value for max_inflight_bytes
diff mbox

Message ID 1475239410-16548-6-git-send-email-subhransu.s.prusty@intel.com
State New
Headers show

Commit Message

Subhransu S. Prusty Sept. 30, 2016, 12:43 p.m. UTC
From: Pierre-Louis Bossart <pierre-louis.bossart@linux.intel.com>

set value to 128 bytes for legacy HDAudio, can be overridden
as needed (on a per-stream basis) for enhanced hardware with
more buffering capabilities

Signed-off-by: Pierre-Louis Bossart <pierre-louis.bossart@linux.intel.com>
Signed-off-by: Subhransu S. Prusty <subhransu.s.prusty@intel.com>
---
 sound/pci/hda/hda_controller.c | 1 +
 1 file changed, 1 insertion(+)

Comments

Shah, Hardik T Oct. 3, 2016, 8:48 a.m. UTC | #1
On Fri, Sep 30, 2016 at 06:13:28PM +0530, Subhransu S. Prusty wrote:
> From: Pierre-Louis Bossart <pierre-louis.bossart@linux.intel.com>
> 
> set value to 128 bytes for legacy HDAudio, can be overridden
> as needed (on a per-stream basis) for enhanced hardware with
> more buffering capabilities
> 
> Signed-off-by: Pierre-Louis Bossart <pierre-louis.bossart@linux.intel.com>
> Signed-off-by: Subhransu S. Prusty <subhransu.s.prusty@intel.com>
> ---
>  sound/pci/hda/hda_controller.c | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/sound/pci/hda/hda_controller.c b/sound/pci/hda/hda_controller.c
> index 2ad3b44..922d7b9 100644
> --- a/sound/pci/hda/hda_controller.c
> +++ b/sound/pci/hda/hda_controller.c
> @@ -587,6 +587,7 @@ static struct snd_pcm_hardware azx_pcm_hw = {
>  	.periods_min =		2,
>  	.periods_max =		AZX_MAX_FRAG,
>  	.fifo_size =		0,
> +	.max_inflight_bytes = 128 /* default value for all legacy HDAudio controllers, override as needed */

This line is going beyond 100 chars

>  };
>  
>  static int azx_pcm_open(struct snd_pcm_substream *substream)
> -- 
> 1.9.1
>
Pierre-Louis Bossart Oct. 3, 2016, 2:44 p.m. UTC | #2
>> --- a/sound/pci/hda/hda_controller.c
>> +++ b/sound/pci/hda/hda_controller.c
>> @@ -587,6 +587,7 @@ static struct snd_pcm_hardware azx_pcm_hw = {
>>  	.periods_min =		2,
>>  	.periods_max =		AZX_MAX_FRAG,
>>  	.fifo_size =		0,
>> +	.max_inflight_bytes = 128 /* default value for all legacy HDAudio controllers, override as needed */
>
> This line is going beyond 100 chars

introducing multi-line comments makes the structure less readable so 
even if checkpatch complains with a warning I used a single line. If you 
disagree please suggest a format that leaves the readable AND meets the 
80 char/line rule.

Patch
diff mbox

diff --git a/sound/pci/hda/hda_controller.c b/sound/pci/hda/hda_controller.c
index 2ad3b44..922d7b9 100644
--- a/sound/pci/hda/hda_controller.c
+++ b/sound/pci/hda/hda_controller.c
@@ -587,6 +587,7 @@  static struct snd_pcm_hardware azx_pcm_hw = {
 	.periods_min =		2,
 	.periods_max =		AZX_MAX_FRAG,
 	.fifo_size =		0,
+	.max_inflight_bytes = 128 /* default value for all legacy HDAudio controllers, override as needed */
 };
 
 static int azx_pcm_open(struct snd_pcm_substream *substream)