diff mbox

[10/21] header: rename wait_queue_entry_t to wait_queue_t

Message ID 20170821222817.17376-11-hauke@hauke-m.de (mailing list archive)
State Accepted
Headers show

Commit Message

Hauke Mehrtens Aug. 21, 2017, 10:28 p.m. UTC
In kernel 4.13 wait_queue_t was renamed to wait_queue_entry_t, reverse
this for older kernel versions.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---
 backport/backport-include/linux/wait.h | 4 ++++
 1 file changed, 4 insertions(+)
diff mbox

Patch

diff --git a/backport/backport-include/linux/wait.h b/backport/backport-include/linux/wait.h
index 3059ff1d..c4b1114e 100644
--- a/backport/backport-include/linux/wait.h
+++ b/backport/backport-include/linux/wait.h
@@ -76,4 +76,8 @@  wait_on_bit_timeout(void *word, int bit, unsigned mode, unsigned long timeout)
 #endif
 #endif
 
+#if LINUX_VERSION_IS_LESS(4,13,0)
+#define wait_queue_entry_t wait_queue_t
+#endif
+
 #endif /* __BACKPORT_LINUX_WAIT_H */