diff mbox

drm: rename u32 in __u32 in uapi

Message ID 20170824150814.5878-1-lionel.g.landwerlin@intel.com (mailing list archive)
State New, archived
Headers show

Commit Message

Lionel Landwerlin Aug. 24, 2017, 3:08 p.m. UTC
All other fields use __

Cc: Ben Widawsky <ben@bwidawsk.net>
Fixes: db1689aa61b ("drm: Create a format/modifier blob")
Signed-off-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com>
Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
---
 include/uapi/drm/drm_mode.h | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

Comments

Lionel Landwerlin Aug. 24, 2017, 3:10 p.m. UTC | #1
Forgot to Cc the appropriate people :/

On 24/08/17 16:08, Lionel Landwerlin wrote:
> All other fields use __
>
> Cc: Ben Widawsky <ben@bwidawsk.net>
> Fixes: db1689aa61b ("drm: Create a format/modifier blob")
> Signed-off-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com>
> Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
> ---
>   include/uapi/drm/drm_mode.h | 14 +++++++-------
>   1 file changed, 7 insertions(+), 7 deletions(-)
>
> diff --git a/include/uapi/drm/drm_mode.h b/include/uapi/drm/drm_mode.h
> index a2bb7161f020..54fc38c3c3f1 100644
> --- a/include/uapi/drm/drm_mode.h
> +++ b/include/uapi/drm/drm_mode.h
> @@ -715,24 +715,24 @@ struct drm_mode_atomic {
>   struct drm_format_modifier_blob {
>   #define FORMAT_BLOB_CURRENT 1
>   	/* Version of this blob format */
> -	u32 version;
> +	__u32 version;
>   
>   	/* Flags */
> -	u32 flags;
> +	__u32 flags;
>   
>   	/* Number of fourcc formats supported */
> -	u32 count_formats;
> +	__u32 count_formats;
>   
>   	/* Where in this blob the formats exist (in bytes) */
> -	u32 formats_offset;
> +	__u32 formats_offset;
>   
>   	/* Number of drm_format_modifiers */
> -	u32 count_modifiers;
> +	__u32 count_modifiers;
>   
>   	/* Where in this blob the modifiers exist (in bytes) */
> -	u32 modifiers_offset;
> +	__u32 modifiers_offset;
>   
> -	/* u32 formats[] */
> +	/* __u32 formats[] */
>   	/* struct drm_format_modifier modifiers[] */
>   };
>
Emil Velikov Aug. 24, 2017, 4:55 p.m. UTC | #2
On 24 August 2017 at 16:08, Lionel Landwerlin
<lionel.g.landwerlin@intel.com> wrote:
> All other fields use __
>
Fairly sure I mentioned it at some point - I might have been tad vague
though :-\

Thanks for the fix, Lionel.
Reviewed-by: Emil Velikov <emil.l.velikov@gmail.com>

-Emil
Ben Widawsky Aug. 24, 2017, 5:15 p.m. UTC | #3
On 17-08-24 17:55:35, Emil Velikov wrote:
>On 24 August 2017 at 16:08, Lionel Landwerlin
><lionel.g.landwerlin@intel.com> wrote:
>> All other fields use __
>>
>Fairly sure I mentioned it at some point - I might have been tad vague
>though :-\
>
>Thanks for the fix, Lionel.
>Reviewed-by: Emil Velikov <emil.l.velikov@gmail.com>

I'm sure it was fixed at some point.

    v5:
    Rename modifiers to modifiers_property (Ville)
    Use sizeof(__u32) instead to reflect UAPI nature (Ville)
    Make BUILD_BUG_ON for blob header size

Reviewed-by: Ben Widawsky <ben@bwidawsk.net>

>
>-Emil
diff mbox

Patch

diff --git a/include/uapi/drm/drm_mode.h b/include/uapi/drm/drm_mode.h
index a2bb7161f020..54fc38c3c3f1 100644
--- a/include/uapi/drm/drm_mode.h
+++ b/include/uapi/drm/drm_mode.h
@@ -715,24 +715,24 @@  struct drm_mode_atomic {
 struct drm_format_modifier_blob {
 #define FORMAT_BLOB_CURRENT 1
 	/* Version of this blob format */
-	u32 version;
+	__u32 version;
 
 	/* Flags */
-	u32 flags;
+	__u32 flags;
 
 	/* Number of fourcc formats supported */
-	u32 count_formats;
+	__u32 count_formats;
 
 	/* Where in this blob the formats exist (in bytes) */
-	u32 formats_offset;
+	__u32 formats_offset;
 
 	/* Number of drm_format_modifiers */
-	u32 count_modifiers;
+	__u32 count_modifiers;
 
 	/* Where in this blob the modifiers exist (in bytes) */
-	u32 modifiers_offset;
+	__u32 modifiers_offset;
 
-	/* u32 formats[] */
+	/* __u32 formats[] */
 	/* struct drm_format_modifier modifiers[] */
 };