Message ID | 20250317-sound-avs-kcalloc-v2-0-20e2a132b18f@ethancedwards.com (mailing list archive) |
---|---|
Headers | show |
Series | ASoC: Intel: avs: Replace devm_kzalloc() with devm_kcalloc() | expand |
On 2025-03-17 1:21 PM, Ethan Carter Edwards wrote: > Open coded arithmetic in allocator arguments is discouraged. Helper > functions like kcalloc or, in this case, devm_kcalloc are preferred. Not > only for readability purposes but safety purposes. > > The changes move `devm_kzalloc(dev, sizeof(var) * n, GFP_KERNEL)` to > the helper function `devm_kcalloc(dev, n, sizeof(var), GFP_KERNEL)`. > > Here is a series of four patches within the Intel/avs drivers that make > these changes. They are all compile tested only but should have no > effect on runtime behaviour. > > Link: https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments > Link: https://github.com/KSPP/linux/issues/162 > > Signed-off-by: Ethan Carter Edwards <ethan@ethancedwards.com> Thank you for addressing the review comments. Reviewed-by: Cezary Rojewski <cezary.rojewski@intel.com> > --- > Changes in v2: > - change subjects to include avs > - change commit message to Replace devm_kzalloc() with devm_kcalloc > - Change from Link: to [1]: > - Link to v1: https://lore.kernel.org/r/20250314-sound-avs-kcalloc-v1-0-985f2734c020@ethancedwards.com > > --- > Ethan Carter Edwards (4): > ASoC: Intel: avs: Replace devm_kzalloc() with devm_kcalloc() > ASoC: Intel: avs: ssm4567: Replace devm_kzalloc() with devm_kcalloc() > ASoC: Intel: avs: max98373: Replace devm_kzalloc() with devm_kcalloc() > ASoC: Intel: avs: max98927: Replace devm_kzalloc() with devm_kcalloc() > > sound/soc/intel/avs/boards/max98373.c | 2 +- > sound/soc/intel/avs/boards/max98927.c | 2 +- > sound/soc/intel/avs/boards/ssm4567.c | 2 +- > sound/soc/intel/avs/pcm.c | 2 +- > 4 files changed, 4 insertions(+), 4 deletions(-) > --- > base-commit: da920b7df701770e006928053672147075587fb2 > change-id: 20250314-sound-avs-kcalloc-91cedbc47074 > > Best regards,
On Mon, 17 Mar 2025 08:21:55 -0400, Ethan Carter Edwards wrote: > Open coded arithmetic in allocator arguments is discouraged. Helper > functions like kcalloc or, in this case, devm_kcalloc are preferred. Not > only for readability purposes but safety purposes. > > The changes move `devm_kzalloc(dev, sizeof(var) * n, GFP_KERNEL)` to > the helper function `devm_kcalloc(dev, n, sizeof(var), GFP_KERNEL)`. > > [...] Applied to https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-next Thanks! [1/4] ASoC: Intel: avs: Replace devm_kzalloc() with devm_kcalloc() commit: 6d9d66626c58bcd9b949574aca7d47149b8ad9e1 [2/4] ASoC: Intel: avs: ssm4567: Replace devm_kzalloc() with devm_kcalloc() commit: 61b1a1bddf7d166946d7ca7054b6cbced29b72f5 [3/4] ASoC: Intel: avs: max98373: Replace devm_kzalloc() with devm_kcalloc() commit: bde479694a7da7c127bb5bba98e2e4773f1d7951 [4/4] ASoC: Intel: avs: max98927: Replace devm_kzalloc() with devm_kcalloc() commit: 3602571baf9a6864bde89422d179e422a3ea4d8d All being well this means that it will be integrated into the linux-next tree (usually sometime in the next 24 hours) and sent to Linus during the next merge window (or sooner if it is a bug fix), however if problems are discovered then the patch may be dropped or reverted. You may get further e-mails resulting from automated or manual testing and review of the tree, please engage with people reporting problems and send followup patches addressing any issues that are reported if needed. If any updates are required or you are submitting further changes they should be sent as incremental updates against current git, existing patches will not be replaced. Please add any relevant lists and maintainers to the CCs when replying to this mail. Thanks, Mark
Open coded arithmetic in allocator arguments is discouraged. Helper functions like kcalloc or, in this case, devm_kcalloc are preferred. Not only for readability purposes but safety purposes. The changes move `devm_kzalloc(dev, sizeof(var) * n, GFP_KERNEL)` to the helper function `devm_kcalloc(dev, n, sizeof(var), GFP_KERNEL)`. Here is a series of four patches within the Intel/avs drivers that make these changes. They are all compile tested only but should have no effect on runtime behaviour. Link: https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments Link: https://github.com/KSPP/linux/issues/162 Signed-off-by: Ethan Carter Edwards <ethan@ethancedwards.com> --- Changes in v2: - change subjects to include avs - change commit message to Replace devm_kzalloc() with devm_kcalloc - Change from Link: to [1]: - Link to v1: https://lore.kernel.org/r/20250314-sound-avs-kcalloc-v1-0-985f2734c020@ethancedwards.com --- Ethan Carter Edwards (4): ASoC: Intel: avs: Replace devm_kzalloc() with devm_kcalloc() ASoC: Intel: avs: ssm4567: Replace devm_kzalloc() with devm_kcalloc() ASoC: Intel: avs: max98373: Replace devm_kzalloc() with devm_kcalloc() ASoC: Intel: avs: max98927: Replace devm_kzalloc() with devm_kcalloc() sound/soc/intel/avs/boards/max98373.c | 2 +- sound/soc/intel/avs/boards/max98927.c | 2 +- sound/soc/intel/avs/boards/ssm4567.c | 2 +- sound/soc/intel/avs/pcm.c | 2 +- 4 files changed, 4 insertions(+), 4 deletions(-) --- base-commit: da920b7df701770e006928053672147075587fb2 change-id: 20250314-sound-avs-kcalloc-91cedbc47074 Best regards,