diff mbox series

PATCH: ALSA USB MIDI: Fix case when USB MIDI interface has more than one extra endpoint descriptor

Message ID 00decacc4cac6a9d88fe696f94a077284fb8bbb9.camel@domdv.de (mailing list archive)
State New, archived
Headers show
Series PATCH: ALSA USB MIDI: Fix case when USB MIDI interface has more than one extra endpoint descriptor | expand

Commit Message

Andreas Steinmetz March 26, 2020, 5:18 p.m. UTC
The Miditech MIDIFACE 16x16 (USB ID 1290:1749) has more than one extra
endpoint descriptor.

The first extra descriptor is: 0x06 0x30 0x00 0x00 0x00 0x00

As the code in snd_usbmidi_get_ms_info() looks only at the
first extra descriptor to find USB_DT_CS_ENDPOINT the device
as such is recognized but there is neither input nor output
configured.

The patch iterates through the extra descriptors to find the
proper one. With this patch the device is correctly configured.

Signed-off-by: Andreas Steinmetz <ast@domdv.de>

Comments

Takashi Iwai March 29, 2020, 8:45 a.m. UTC | #1
On Thu, 26 Mar 2020 18:18:55 +0100,
Andreas Steinmetz wrote:
> 
> The Miditech MIDIFACE 16x16 (USB ID 1290:1749) has more than one extra
> endpoint descriptor.
> 
> The first extra descriptor is: 0x06 0x30 0x00 0x00 0x00 0x00
> 
> As the code in snd_usbmidi_get_ms_info() looks only at the
> first extra descriptor to find USB_DT_CS_ENDPOINT the device
> as such is recognized but there is neither input nor output
> configured.
> 
> The patch iterates through the extra descriptors to find the
> proper one. With this patch the device is correctly configured.
> 
> Signed-off-by: Andreas Steinmetz <ast@domdv.de>
> 
> --- a/sourd/usb/midi.c	2020-03-26 17:34:40.073929497 +0100
> +++ b/sound/usb/midi.c	2020-03-26 17:43:39.123252612 +0100
> @@ -1839,7 +1839,8 @@
>  	struct usb_host_endpoint *hostep;
>  	struct usb_endpoint_descriptor *ep;
>  	struct usb_ms_endpoint_descriptor *ms_ep;
> -	int i, epidx;
> +	int i, epidx, extralen;
> +	unsigned char *extra;
>  
>  	intf = umidi->iface;
>  	if (!intf)
> @@ -1863,12 +1864,21 @@
>  		ep = get_ep_desc(hostep);
>  		if (!usb_endpoint_xfer_bulk(ep) && !usb_endpoint_xfer_int(ep))
>  			continue;
> -		ms_ep = (struct usb_ms_endpoint_descriptor *)hostep->extra;
> -		if (hostep->extralen < 4 ||
> +		extralen = hostep->extralen;
> +		extra = hostep->extra;
> +repeat:		ms_ep = (struct usb_ms_endpoint_descriptor *)extra;
> +		if (extralen < 1)
> +			continue;
> +		if (extralen < 4 ||
>  		    ms_ep->bLength < 4 ||
>  		    ms_ep->bDescriptorType != USB_DT_CS_ENDPOINT ||
> -		    ms_ep->bDescriptorSubtype != UAC_MS_GENERAL)
> -			continue;
> +		    ms_ep->bDescriptorSubtype != UAC_MS_GENERAL) {
> +			if (!extra[0])
> +				continue;
> +			extralen -= extra[0];
> +			extra += extra[0];
> +			goto repeat;
> +		}

This kind of goto-loop in a loop is really cryptic and error-prone.
In general we use goto in the kernel code but only for limited
situations such as the unified error code path or the restart of the
whole loop after an error condition.  But this doesn't fit for such
exceptions and can be better rewritten with a simple loop (maybe even
better to factor out to a function).

So, could you revise the change to be more readable?


thanks,

Takashi
diff mbox series

Patch

--- a/sourd/usb/midi.c	2020-03-26 17:34:40.073929497 +0100
+++ b/sound/usb/midi.c	2020-03-26 17:43:39.123252612 +0100
@@ -1839,7 +1839,8 @@ 
 	struct usb_host_endpoint *hostep;
 	struct usb_endpoint_descriptor *ep;
 	struct usb_ms_endpoint_descriptor *ms_ep;
-	int i, epidx;
+	int i, epidx, extralen;
+	unsigned char *extra;
 
 	intf = umidi->iface;
 	if (!intf)
@@ -1863,12 +1864,21 @@ 
 		ep = get_ep_desc(hostep);
 		if (!usb_endpoint_xfer_bulk(ep) && !usb_endpoint_xfer_int(ep))
 			continue;
-		ms_ep = (struct usb_ms_endpoint_descriptor *)hostep->extra;
-		if (hostep->extralen < 4 ||
+		extralen = hostep->extralen;
+		extra = hostep->extra;
+repeat:		ms_ep = (struct usb_ms_endpoint_descriptor *)extra;
+		if (extralen < 1)
+			continue;
+		if (extralen < 4 ||
 		    ms_ep->bLength < 4 ||
 		    ms_ep->bDescriptorType != USB_DT_CS_ENDPOINT ||
-		    ms_ep->bDescriptorSubtype != UAC_MS_GENERAL)
-			continue;
+		    ms_ep->bDescriptorSubtype != UAC_MS_GENERAL) {
+			if (!extra[0])
+				continue;
+			extralen -= extra[0];
+			extra += extra[0];
+			goto repeat;
+		}
 		if (usb_endpoint_dir_out(ep)) {
 			if (endpoints[epidx].out_ep) {
 				if (++epidx >= MIDI_MAX_ENDPOINTS) {