diff mbox

[04/15] ASoC: wm5100: Update locking around use of DAPM pin API

Message ID 1392655903-24537-5-git-send-email-ckeepax@opensource.wolfsonmicro.com (mailing list archive)
State Changes Requested
Headers show

Commit Message

Charles Keepax Feb. 17, 2014, 4:51 p.m. UTC
The pin updates in this driver look like they are intended to be done
atomically, update to do so.

Signed-off-by: Charles Keepax <ckeepax@opensource.wolfsonmicro.com>
---
 sound/soc/codecs/wm5100.c |    9 +++++++--
 1 files changed, 7 insertions(+), 2 deletions(-)

Comments

Mark Brown Feb. 18, 2014, 12:47 a.m. UTC | #1
On Mon, Feb 17, 2014 at 04:51:32PM +0000, Charles Keepax wrote:

> +		snd_soc_dapm_force_enable_pin_locked(&codec->dapm, "CP2");
> +		snd_soc_dapm_force_enable_pin_locked(&codec->dapm, "SYSCLK");
> +
> +		mutex_unlock(&codec->dapm.card->dapm_mutex);
> +
>  		snd_soc_dapm_sync(&codec->dapm);

With all these patches it seems weird that we have to drop the lock to
do the sync which will immediately retake it.  It's not broken but it
looks off - it would be better to have a version of _sync() that we can
call within the lock.

Regarding the naming issue that Lars mentioned I think the current
operations are probably fine but calling them _unlocked() meaning they
don't do any locking (as distinct from the existing _locked() which take
locks) might be OK.
Charles Keepax Feb. 18, 2014, 9:24 a.m. UTC | #2
On Tue, Feb 18, 2014 at 09:47:29AM +0900, Mark Brown wrote:
> On Mon, Feb 17, 2014 at 04:51:32PM +0000, Charles Keepax wrote:
> 
> > +		snd_soc_dapm_force_enable_pin_locked(&codec->dapm, "CP2");
> > +		snd_soc_dapm_force_enable_pin_locked(&codec->dapm, "SYSCLK");
> > +
> > +		mutex_unlock(&codec->dapm.card->dapm_mutex);
> > +
> >  		snd_soc_dapm_sync(&codec->dapm);
> 
> With all these patches it seems weird that we have to drop the lock to
> do the sync which will immediately retake it.  It's not broken but it
> looks off - it would be better to have a version of _sync() that we can
> call within the lock.

No problem to add a version of sync that can be called from
within the lock, should help out with Dimtry's comments as well.

> 
> Regarding the naming issue that Lars mentioned I think the current
> operations are probably fine but calling them _unlocked() meaning they
> don't do any locking (as distinct from the existing _locked() which take
> locks) might be OK.

Yeah that would be good, since my original aim here was to avoid
updating every single usage of these functions.

Thanks,
Charles
diff mbox

Patch

diff --git a/sound/soc/codecs/wm5100.c b/sound/soc/codecs/wm5100.c
index 4e3e31a..c69992b 100644
--- a/sound/soc/codecs/wm5100.c
+++ b/sound/soc/codecs/wm5100.c
@@ -2117,8 +2117,13 @@  int wm5100_detect(struct snd_soc_codec *codec, struct snd_soc_jack *jack)
 				    WM5100_ACCDET_RATE_MASK);
 
 		/* We need the charge pump to power MICBIAS */
-		snd_soc_dapm_force_enable_pin(&codec->dapm, "CP2");
-		snd_soc_dapm_force_enable_pin(&codec->dapm, "SYSCLK");
+		mutex_lock(&codec->dapm.card->dapm_mutex);
+
+		snd_soc_dapm_force_enable_pin_locked(&codec->dapm, "CP2");
+		snd_soc_dapm_force_enable_pin_locked(&codec->dapm, "SYSCLK");
+
+		mutex_unlock(&codec->dapm.card->dapm_mutex);
+
 		snd_soc_dapm_sync(&codec->dapm);
 
 		/* We start off just enabling microphone detection - even a