diff mbox

[RFC,2/2] ALSA: hda - Use "Line Out" name instead of "PCM" when there are other outputs

Message ID 1413466426-2672-2-git-send-email-david.henningsson@canonical.com (mailing list archive)
State Accepted
Commit 3abb4f4d0e7aaad0d12004b5057f4486a688752b
Delegated to: Takashi Iwai
Headers show

Commit Message

David Henningsson Oct. 16, 2014, 1:33 p.m. UTC
In case there are speakers or headphones as well, anything that only
covers the line out should not be labelled "PCM". Let's name it
"Line Out" instead for clarity.

Signed-off-by: David Henningsson <david.henningsson@canonical.com>
---
 sound/pci/hda/hda_generic.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox

Patch

diff --git a/sound/pci/hda/hda_generic.c b/sound/pci/hda/hda_generic.c
index 1d742ea..c037bab 100644
--- a/sound/pci/hda/hda_generic.c
+++ b/sound/pci/hda/hda_generic.c
@@ -1055,7 +1055,7 @@  static const char *get_line_out_pfx(struct hda_codec *codec, int ch,
 
 	/* for a single channel output, we don't have to name the channel */
 	if (cfg->line_outs == 1 && !spec->multi_ios)
-		return "PCM";
+		return "Line Out";
 
 	if (ch >= ARRAY_SIZE(channel_name)) {
 		snd_BUG();