Message ID | 1422949119-9306-1-git-send-email-hofrat@osadl.org (mailing list archive) |
---|---|
State | Accepted |
Commit | 695758c6c4d67955f7d73bc9fd39288acfd4b222 |
Headers | show |
diff --git a/sound/usb/line6/driver.c b/sound/usb/line6/driver.c index 2328ec9..3cf12cc 100644 --- a/sound/usb/line6/driver.c +++ b/sound/usb/line6/driver.c @@ -166,7 +166,7 @@ void line6_start_timer(struct timer_list *timer, unsigned int msecs, void (*function)(unsigned long), unsigned long data) { setup_timer(timer, function, data); - mod_timer(timer, jiffies + msecs * HZ / 1000); + mod_timer(timer, jiffies + msecs_to_jiffies(msecs)); } EXPORT_SYMBOL_GPL(line6_start_timer);
This is only an API consolidation and should make things more readable it replaces var * HZ / 1000 by msecs_to_jiffies(var). Signed-off-by: Nicholas Mc Guire <hofrat@osadl.org> --- Converting milliseconds to jiffies by val * HZ / 1000 is technically not wrong but msecs_to_jiffies(val) is the cleaner solution and handles all corner cases correctly. This is a minor API cleanup only. Patch was only compile tested for x86_64_defconfig + CONFIG_SOUND=y, CONFIG_SND_USB_POD=m (implies CONFIG_SND_USB_LINE6=y) Patch is against 3.0.19-rc6 (localversion = -next-20150202) sound/usb/line6/driver.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)