diff mbox series

ALSA: hda: Assign boolean values to a bool variable

Message ID 1611559047-106928-1-git-send-email-abaci-bugfix@linux.alibaba.com (mailing list archive)
State New, archived
Headers show
Series ALSA: hda: Assign boolean values to a bool variable | expand

Commit Message

Abaci Team Jan. 25, 2021, 7:17 a.m. UTC
Fix the following coccicheck warnings:

./sound/pci/hda/hda_intel.c:2309:3-23: WARNING: Assignment of
0/1 to bool variable.

Reported-by: Abaci Robot <abaci@linux.alibaba.com>
Signed-off-by: Jiapeng Zhong <abaci-bugfix@linux.alibaba.com>
---
 sound/pci/hda/hda_intel.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Takashi Iwai Jan. 25, 2021, 8:01 a.m. UTC | #1
On Mon, 25 Jan 2021 08:17:27 +0100,
Jiapeng Zhong wrote:
> 
> Fix the following coccicheck warnings:
> 
> ./sound/pci/hda/hda_intel.c:2309:3-23: WARNING: Assignment of
> 0/1 to bool variable.
> 
> Reported-by: Abaci Robot <abaci@linux.alibaba.com>
> Signed-off-by: Jiapeng Zhong <abaci-bugfix@linux.alibaba.com>

Thanks, applied now.

But if you have some more similar changes, please try to convert at
once instead of submitting each change infrequently.  It's getting
annoying now, as the change itself hardly helps improving the
readability or code quality in general, although there is no strong
reason to object it.


Takashi
diff mbox series

Patch

diff --git a/sound/pci/hda/hda_intel.c b/sound/pci/hda/hda_intel.c
index 5a50d3a..24e9762 100644
--- a/sound/pci/hda/hda_intel.c
+++ b/sound/pci/hda/hda_intel.c
@@ -2304,7 +2304,7 @@  static int azx_probe_continue(struct azx *chip)
 
 		/* HSW/BDW controllers need this power */
 		if (CONTROLLER_IN_GPU(pci))
-			hda->need_i915_power = 1;
+			hda->need_i915_power = true;
 	}
 
 	/* Request display power well for the HDA controller or codec. For