diff mbox series

[v2,5/6] ASoC: Define a set of DAPM pre/post-up events

Message ID 20190625074937.2621-6-oleksandr.suvorov@toradex.com (mailing list archive)
State New, archived
Headers show
Series VAG power control improvement for sgtl5000 codec | expand

Commit Message

Oleksandr Suvorov June 25, 2019, 7:49 a.m. UTC
Prepare to use SND_SOC_DAPM_PRE_POST_PMU definition to
reduce coming code size and make it more readable.

Signed-off-by: Oleksandr Suvorov <oleksandr.suvorov@toradex.com>
---

 include/sound/soc-dapm.h | 2 ++
 1 file changed, 2 insertions(+)

Comments

Igor Opaniuk July 11, 2019, 10:24 a.m. UTC | #1
On Tue, Jun 25, 2019 at 10:55 AM Oleksandr Suvorov
<oleksandr.suvorov@toradex.com> wrote:
>
> Prepare to use SND_SOC_DAPM_PRE_POST_PMU definition to
> reduce coming code size and make it more readable.
>
> Signed-off-by: Oleksandr Suvorov <oleksandr.suvorov@toradex.com>
> ---
>
>  include/sound/soc-dapm.h | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/include/sound/soc-dapm.h b/include/sound/soc-dapm.h
> index c00a0b8ade086..6c66941601307 100644
> --- a/include/sound/soc-dapm.h
> +++ b/include/sound/soc-dapm.h
> @@ -353,6 +353,8 @@ struct device;
>  #define SND_SOC_DAPM_WILL_PMD   0x80    /* called at start of sequence */
>  #define SND_SOC_DAPM_PRE_POST_PMD \
>                                 (SND_SOC_DAPM_PRE_PMD | SND_SOC_DAPM_POST_PMD)
> +#define SND_SOC_DAPM_PRE_POST_PMU \
> +                               (SND_SOC_DAPM_PRE_PMU | SND_SOC_DAPM_POST_PMU)
>
>  /* convenience event type detection */
>  #define SND_SOC_DAPM_EVENT_ON(e)       \
> --
> 2.20.1
>

Reviewed-by: Igor Opaniuk <igor.opaniuk@toradex.com>
diff mbox series

Patch

diff --git a/include/sound/soc-dapm.h b/include/sound/soc-dapm.h
index c00a0b8ade086..6c66941601307 100644
--- a/include/sound/soc-dapm.h
+++ b/include/sound/soc-dapm.h
@@ -353,6 +353,8 @@  struct device;
 #define SND_SOC_DAPM_WILL_PMD   0x80    /* called at start of sequence */
 #define SND_SOC_DAPM_PRE_POST_PMD \
 				(SND_SOC_DAPM_PRE_PMD | SND_SOC_DAPM_POST_PMD)
+#define SND_SOC_DAPM_PRE_POST_PMU \
+				(SND_SOC_DAPM_PRE_PMU | SND_SOC_DAPM_POST_PMU)
 
 /* convenience event type detection */
 #define SND_SOC_DAPM_EVENT_ON(e)	\