Message ID | 20200208215523.36094-1-colin.king@canonical.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | ASoC: ti: davinci-mcasp: remove redundant assignment to variable ret | expand |
On Sat, Feb 08, 2020 at 09:55:23PM +0000, Colin King wrote: > From: Colin Ian King <colin.king@canonical.com> > > The assignment to ret is redundant as it is not used in the error > return path and hence can be removed. > > Addresses-Coverity: ("Unused value") > Signed-off-by: Colin Ian King <colin.king@canonical.com> > --- > sound/soc/ti/davinci-mcasp.c | 4 +--- > 1 file changed, 1 insertion(+), 3 deletions(-) > > diff --git a/sound/soc/ti/davinci-mcasp.c b/sound/soc/ti/davinci-mcasp.c > index e1e937eb1dc1..450c394b2882 100644 > --- a/sound/soc/ti/davinci-mcasp.c > +++ b/sound/soc/ti/davinci-mcasp.c > @@ -1764,10 +1764,8 @@ static struct davinci_mcasp_pdata *davinci_mcasp_set_pdata_from_of( > } else if (match) { > pdata = devm_kmemdup(&pdev->dev, match->data, sizeof(*pdata), > GFP_KERNEL); > - if (!pdata) { > - ret = -ENOMEM; > + if (!pdata) > return pdata; Use a literal NULL for readability. "return NULL;". regards, dan carpenter
diff --git a/sound/soc/ti/davinci-mcasp.c b/sound/soc/ti/davinci-mcasp.c index e1e937eb1dc1..450c394b2882 100644 --- a/sound/soc/ti/davinci-mcasp.c +++ b/sound/soc/ti/davinci-mcasp.c @@ -1764,10 +1764,8 @@ static struct davinci_mcasp_pdata *davinci_mcasp_set_pdata_from_of( } else if (match) { pdata = devm_kmemdup(&pdev->dev, match->data, sizeof(*pdata), GFP_KERNEL); - if (!pdata) { - ret = -ENOMEM; + if (!pdata) return pdata; - } } else { /* control shouldn't reach here. something is wrong */ ret = -EINVAL;