diff mbox series

[120/173] ASoC: rockchip: rockchip_i2s_tdm: Convert to platform remove callback returning void

Message ID 20230315150745.67084-121-u.kleine-koenig@pengutronix.de (mailing list archive)
State New, archived
Headers show
Series ALSA/ASoC: Convert to platform remove callback returning void | expand

Commit Message

Uwe Kleine-König March 15, 2023, 3:06 p.m. UTC
The .remove() callback for a platform driver returns an int which makes
many driver authors wrongly assume it's possible to do error handling by
returning an error code. However the value returned is (mostly) ignored
and this typically results in resource leaks. To improve here there is a
quest to make the remove callback return void. In the first step of this
quest all drivers are converted to .remove_new() which already returns
void.

Trivially convert this driver from always returning zero in the remove
callback to the void returning variant.

Signed-off-by: Uwe Kleine-König <u.kleine-koenig@pengutronix.de>
---
 sound/soc/rockchip/rockchip_i2s_tdm.c | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)

Comments

Nicolas Frattaroli March 15, 2023, 4 p.m. UTC | #1
On Mittwoch, 15. März 2023 16:06:52 CET Uwe Kleine-König wrote:
> The .remove() callback for a platform driver returns an int which makes
> many driver authors wrongly assume it's possible to do error handling by
> returning an error code. However the value returned is (mostly) ignored
> and this typically results in resource leaks. To improve here there is a
> quest to make the remove callback return void. In the first step of this
> quest all drivers are converted to .remove_new() which already returns
> void.
> 
> Trivially convert this driver from always returning zero in the remove
> callback to the void returning variant.
> 
> Signed-off-by: Uwe Kleine-König <u.kleine-koenig@pengutronix.de>

Hello,

this looks fine, but the commit prefix should either be
"ASoC: rockchip: i2s_tdm:" or "ASoC: rockchip: i2s-tdm" to align
with previous commits. We've already broken convention once before,
hence the two names, and I'd rather not have this convention broken
again.

Kind regards,
Nicolas Frattaroli

> ---
>  sound/soc/rockchip/rockchip_i2s_tdm.c | 6 ++----
>  1 file changed, 2 insertions(+), 4 deletions(-)
> 
> diff --git a/sound/soc/rockchip/rockchip_i2s_tdm.c b/sound/soc/rockchip/rockchip_i2s_tdm.c
> index 166257c6ae14..c2e9fd5ab05e 100644
> --- a/sound/soc/rockchip/rockchip_i2s_tdm.c
> +++ b/sound/soc/rockchip/rockchip_i2s_tdm.c
> @@ -1722,14 +1722,12 @@ static int rockchip_i2s_tdm_probe(struct platform_device *pdev)
>  	return ret;
>  }
>  
> -static int rockchip_i2s_tdm_remove(struct platform_device *pdev)
> +static void rockchip_i2s_tdm_remove(struct platform_device *pdev)
>  {
>  	if (!pm_runtime_status_suspended(&pdev->dev))
>  		i2s_tdm_runtime_suspend(&pdev->dev);
>  
>  	pm_runtime_disable(&pdev->dev);
> -
> -	return 0;
>  }
>  
>  static int __maybe_unused rockchip_i2s_tdm_suspend(struct device *dev)
> @@ -1764,7 +1762,7 @@ static const struct dev_pm_ops rockchip_i2s_tdm_pm_ops = {
>  
>  static struct platform_driver rockchip_i2s_tdm_driver = {
>  	.probe = rockchip_i2s_tdm_probe,
> -	.remove = rockchip_i2s_tdm_remove,
> +	.remove_new = rockchip_i2s_tdm_remove,
>  	.driver = {
>  		.name = DRV_NAME,
>  		.of_match_table = of_match_ptr(rockchip_i2s_tdm_match),
>
Uwe Kleine-König March 15, 2023, 4:25 p.m. UTC | #2
On Wed, Mar 15, 2023 at 05:00:49PM +0100, Nicolas Frattaroli wrote:
> On Mittwoch, 15. März 2023 16:06:52 CET Uwe Kleine-König wrote:
> > The .remove() callback for a platform driver returns an int which makes
> > many driver authors wrongly assume it's possible to do error handling by
> > returning an error code. However the value returned is (mostly) ignored
> > and this typically results in resource leaks. To improve here there is a
> > quest to make the remove callback return void. In the first step of this
> > quest all drivers are converted to .remove_new() which already returns
> > void.
> > 
> > Trivially convert this driver from always returning zero in the remove
> > callback to the void returning variant.
> > 
> > Signed-off-by: Uwe Kleine-König <u.kleine-koenig@pengutronix.de>
> 
> Hello,
> 
> this looks fine, but the commit prefix should either be
> "ASoC: rockchip: i2s_tdm:" or "ASoC: rockchip: i2s-tdm" to align
> with previous commits. We've already broken convention once before,
> hence the two names, and I'd rather not have this convention broken
> again.

I fixed that in my tree. I assume Mark will skip this patch when
applying and when I come around cleaning up the fall-out I will resend
this one with the subject fixed. (I picked the variant with _ now as
this seems to be the more recent one.)

Thanks for the feedback
Uwe
diff mbox series

Patch

diff --git a/sound/soc/rockchip/rockchip_i2s_tdm.c b/sound/soc/rockchip/rockchip_i2s_tdm.c
index 166257c6ae14..c2e9fd5ab05e 100644
--- a/sound/soc/rockchip/rockchip_i2s_tdm.c
+++ b/sound/soc/rockchip/rockchip_i2s_tdm.c
@@ -1722,14 +1722,12 @@  static int rockchip_i2s_tdm_probe(struct platform_device *pdev)
 	return ret;
 }
 
-static int rockchip_i2s_tdm_remove(struct platform_device *pdev)
+static void rockchip_i2s_tdm_remove(struct platform_device *pdev)
 {
 	if (!pm_runtime_status_suspended(&pdev->dev))
 		i2s_tdm_runtime_suspend(&pdev->dev);
 
 	pm_runtime_disable(&pdev->dev);
-
-	return 0;
 }
 
 static int __maybe_unused rockchip_i2s_tdm_suspend(struct device *dev)
@@ -1764,7 +1762,7 @@  static const struct dev_pm_ops rockchip_i2s_tdm_pm_ops = {
 
 static struct platform_driver rockchip_i2s_tdm_driver = {
 	.probe = rockchip_i2s_tdm_probe,
-	.remove = rockchip_i2s_tdm_remove,
+	.remove_new = rockchip_i2s_tdm_remove,
 	.driver = {
 		.name = DRV_NAME,
 		.of_match_table = of_match_ptr(rockchip_i2s_tdm_match),