diff mbox series

[-next] ALSA: core: timer: Use NSEC_PER_SEC macro

Message ID 20240902071622.3519787-1-ruanjinjie@huawei.com (mailing list archive)
State Accepted
Commit f48bd50a1c8d7d733b83a8fbabb3041e0d505fc7
Headers show
Series [-next] ALSA: core: timer: Use NSEC_PER_SEC macro | expand

Commit Message

Jinjie Ruan Sept. 2, 2024, 7:16 a.m. UTC
1000000000L is number of ns per second, use NSEC_PER_SEC macro to replace
it to make it more readable

Signed-off-by: Jinjie Ruan <ruanjinjie@huawei.com>
---
 sound/core/timer.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Takashi Iwai Sept. 2, 2024, 8:18 a.m. UTC | #1
On Mon, 02 Sep 2024 09:16:22 +0200,
Jinjie Ruan wrote:
> 
> 1000000000L is number of ns per second, use NSEC_PER_SEC macro to replace
> it to make it more readable
> 
> Signed-off-by: Jinjie Ruan <ruanjinjie@huawei.com>

Thanks, applied.


Takashi
diff mbox series

Patch

diff --git a/sound/core/timer.c b/sound/core/timer.c
index 7610f102360d..4315d1e98ebf 100644
--- a/sound/core/timer.c
+++ b/sound/core/timer.c
@@ -1174,7 +1174,7 @@  static int snd_timer_s_close(struct snd_timer *timer)
 static const struct snd_timer_hardware snd_timer_system =
 {
 	.flags =	SNDRV_TIMER_HW_FIRST | SNDRV_TIMER_HW_WORK,
-	.resolution =	1000000000L / HZ,
+	.resolution =	NSEC_PER_SEC / HZ,
 	.ticks =	10000000L,
 	.close =	snd_timer_s_close,
 	.start =	snd_timer_s_start,