diff mbox series

ASoC: amd: acp: don't set card long_name

Message ID 20240916061318.3147988-1-Vijendar.Mukunda@amd.com (mailing list archive)
State Accepted
Commit 8451a3c7879d8883fd3fbd9dd7cbe7ecc31e89ce
Headers show
Series ASoC: amd: acp: don't set card long_name | expand

Commit Message

Vijendar Mukunda Sept. 16, 2024, 6:13 a.m. UTC
UCM can load a board-specific file based on the card long_name. Remove
the constant "AMD Soundwire SOF" long_name so that the ASoC core can
set the long_name based on DMI information.

Signed-off-by: Vijendar Mukunda <Vijendar.Mukunda@amd.com>
---
 sound/soc/amd/acp/acp-sdw-sof-mach.c | 5 -----
 1 file changed, 5 deletions(-)

Comments

Jaroslav Kysela Sept. 16, 2024, 8:25 a.m. UTC | #1
On 16. 09. 24 8:13, Vijendar Mukunda wrote:
> UCM can load a board-specific file based on the card long_name. Remove
> the constant "AMD Soundwire SOF" long_name so that the ASoC core can
> set the long_name based on DMI information.
> 
> Signed-off-by: Vijendar Mukunda <Vijendar.Mukunda@amd.com>

I have to say, that DMI information in long name is really confusing for users 
for GUI. UCM can fetch DMI information directly using sysfs. This type of 
hardware identification is no longer required.

				Jaroslav
Mark Brown Sept. 17, 2024, 9:23 a.m. UTC | #2
On Mon, Sep 16, 2024 at 10:25:37AM +0200, Jaroslav Kysela wrote:
> On 16. 09. 24 8:13, Vijendar Mukunda wrote:
> > UCM can load a board-specific file based on the card long_name. Remove
> > the constant "AMD Soundwire SOF" long_name so that the ASoC core can
> > set the long_name based on DMI information.
> > 
> > Signed-off-by: Vijendar Mukunda <Vijendar.Mukunda@amd.com>
> 
> I have to say, that DMI information in long name is really confusing for
> users for GUI. UCM can fetch DMI information directly using sysfs. This type
> of hardware identification is no longer required.

I dunno, a lot of Windows sound cards seem to end up with something that
looks a lot like the sort of thing you might get from DMI showing right
up in the UI - vendors seem keen on it.
Mark Brown Sept. 18, 2024, 11:20 a.m. UTC | #3
On Mon, 16 Sep 2024 11:43:18 +0530, Vijendar Mukunda wrote:
> UCM can load a board-specific file based on the card long_name. Remove
> the constant "AMD Soundwire SOF" long_name so that the ASoC core can
> set the long_name based on DMI information.
> 
> 

Applied to

   https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-next

Thanks!

[1/1] ASoC: amd: acp: don't set card long_name
      commit: 8451a3c7879d8883fd3fbd9dd7cbe7ecc31e89ce

All being well this means that it will be integrated into the linux-next
tree (usually sometime in the next 24 hours) and sent to Linus during
the next merge window (or sooner if it is a bug fix), however if
problems are discovered then the patch may be dropped or reverted.

You may get further e-mails resulting from automated or manual testing
and review of the tree, please engage with people reporting problems and
send followup patches addressing any issues that are reported if needed.

If any updates are required or you are submitting further changes they
should be sent as incremental updates against current git, existing
patches will not be replaced.

Please add any relevant lists and maintainers to the CCs when replying
to this mail.

Thanks,
Mark
diff mbox series

Patch

diff --git a/sound/soc/amd/acp/acp-sdw-sof-mach.c b/sound/soc/amd/acp/acp-sdw-sof-mach.c
index 6c50c8276538..306854fb08e3 100644
--- a/sound/soc/amd/acp/acp-sdw-sof-mach.c
+++ b/sound/soc/amd/acp/acp-sdw-sof-mach.c
@@ -400,9 +400,6 @@  static int sof_card_dai_links_create(struct snd_soc_card *card)
 	return ret;
 }
 
-/* SoC card */
-static const char sdw_card_long_name[] = "AMD Soundwire SOF";
-
 static int mc_probe(struct platform_device *pdev)
 {
 	struct snd_soc_acpi_mach *mach = dev_get_platdata(&pdev->dev);
@@ -463,8 +460,6 @@  static int mc_probe(struct platform_device *pdev)
 	if (!card->components)
 		return -ENOMEM;
 
-	card->long_name = sdw_card_long_name;
-
 	/* Register the card */
 	ret = devm_snd_soc_register_card(card->dev, card);
 	if (ret) {