Message ID | 20241114075822.41614-1-zhangjiao2@cmss.chinamobile.com (mailing list archive) |
---|---|
State | New |
Headers | show |
Series | ALSA: ump: Fix the wrong format specifier | expand |
On Thu, 14 Nov 2024 08:58:22 +0100, zhangjiao2 wrote: > > From: zhang jiao <zhangjiao2@cmss.chinamobile.com> > > The format specifier of "unsigned int" in snprintf() > should be "%u", not "%d". > > Signed-off-by: zhang jiao <zhangjiao2@cmss.chinamobile.com> Applied now, thanks. Takashi
diff --git a/sound/core/ump.c b/sound/core/ump.c index ab4932dc499f..5d4dd207e5ab 100644 --- a/sound/core/ump.c +++ b/sound/core/ump.c @@ -387,7 +387,7 @@ int snd_ump_block_new(struct snd_ump_endpoint *ump, unsigned int blk, fb->info.first_group = first_group; fb->info.num_groups = num_groups; /* fill the default name, may be overwritten to a better name */ - snprintf(fb->info.name, sizeof(fb->info.name), "Group %d-%d", + snprintf(fb->info.name, sizeof(fb->info.name), "Group %u-%u", first_group + 1, first_group + num_groups); /* put the entry in the ordered list */