diff mbox series

[v2,17/29] ASoC: soc-component: add snd_soc_component_remove()

Message ID 871ryd5rlo.wl-kuninori.morimoto.gx@renesas.com (mailing list archive)
State Accepted
Commit 03b34dd7d87ce3493cb1837c9e59c3b3aac4724f
Headers show
Series ASoC: add soc-component.c | expand

Commit Message

Kuninori Morimoto July 26, 2019, 4:51 a.m. UTC
From: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>

Current ALSA SoC is directly using component->driver->xxx,
thus, it is deep nested, and makes code difficult to read,
and is not good for encapsulation.
This patch adds new snd_soc_component_remove() and use it.

Signed-off-by: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
---
v1 -> v2

	- no change

 include/sound/soc-component.h | 1 +
 sound/soc/soc-component.c     | 6 ++++++
 sound/soc/soc-core.c          | 3 +--
 3 files changed, 8 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/include/sound/soc-component.h b/include/sound/soc-component.h
index 34e774e..b8480d9 100644
--- a/include/sound/soc-component.h
+++ b/include/sound/soc-component.h
@@ -357,5 +357,6 @@  void snd_soc_component_suspend(struct snd_soc_component *component);
 void snd_soc_component_resume(struct snd_soc_component *component);
 int snd_soc_component_is_suspended(struct snd_soc_component *component);
 int snd_soc_component_probe(struct snd_soc_component *component);
+void snd_soc_component_remove(struct snd_soc_component *component);
 
 #endif /* __SOC_COMPONENT_H */
diff --git a/sound/soc/soc-component.c b/sound/soc/soc-component.c
index b2bfc03..eba77ea 100644
--- a/sound/soc/soc-component.c
+++ b/sound/soc/soc-component.c
@@ -374,3 +374,9 @@  int snd_soc_component_probe(struct snd_soc_component *component)
 
 	return 0;
 }
+
+void snd_soc_component_remove(struct snd_soc_component *component)
+{
+	if (component->driver->remove)
+		component->driver->remove(component);
+}
diff --git a/sound/soc/soc-core.c b/sound/soc/soc-core.c
index 6f3dea4..f228e99 100644
--- a/sound/soc/soc-core.c
+++ b/sound/soc/soc-core.c
@@ -970,8 +970,7 @@  static void soc_remove_component(struct snd_soc_component *component)
 	if (!component->card)
 		return;
 
-	if (component->driver->remove)
-		component->driver->remove(component);
+	snd_soc_component_remove(component);
 
 	soc_cleanup_component(component);
 }