diff mbox

[2/6] ASoC: soc-core: indicate unregister debug message once

Message ID 877fvrwlt0.wl%kuninori.morimoto.gx@renesas.com (mailing list archive)
State New, archived
Headers show

Commit Message

Kuninori Morimoto Feb. 9, 2015, 8:05 a.m. UTC
From: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>

Current snd_soc_unregister_card() indicates unregistered debug
message when it was called. But, it should be called only when
it was really unregistered.

Signed-off-by: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
---
 sound/soc/soc-core.c |    3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Mark Brown Feb. 9, 2015, 8:27 a.m. UTC | #1
On Mon, Feb 09, 2015 at 08:05:45AM +0000, Kuninori Morimoto wrote:
> From: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
> 
> Current snd_soc_unregister_card() indicates unregistered debug
> message when it was called. But, it should be called only when
> it was really unregistered.

This doesn't seem to apply against current code, can you please check?
Kuninori Morimoto Feb. 9, 2015, 8:49 a.m. UTC | #2
Hi Mark

> > From: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
> > 
> > Current snd_soc_unregister_card() indicates unregistered debug
> > message when it was called. But, it should be called only when
> > it was really unregistered.
> 
> This doesn't seem to apply against current code, can you please check?

Yes, I will send it soon in other mail thread
diff mbox

Patch

diff --git a/sound/soc/soc-core.c b/sound/soc/soc-core.c
index 985052b..11c28fd 100644
--- a/sound/soc/soc-core.c
+++ b/sound/soc/soc-core.c
@@ -2386,8 +2386,9 @@  int snd_soc_unregister_card(struct snd_soc_card *card)
 		card->instantiated = false;
 		snd_soc_dapm_shutdown(card);
 		soc_cleanup_card_resources(card);
+		dev_dbg(card->dev, "ASoC: Unregistered card '%s'\n",
+			card->name);
 	}
-	dev_dbg(card->dev, "ASoC: Unregistered card '%s'\n", card->name);
 
 	return 0;
 }