mbox series

[v2,0/4] ath10k: sdio: improve power consumption

Message ID 1587037859-28873-1-git-send-email-kvalo@codeaurora.org (mailing list archive)
Headers show
Series ath10k: sdio: improve power consumption | expand


Kalle Valo April 16, 2020, 11:50 a.m. UTC

here's a patchset for improving power consumption on SDIO with some refactoring
and some small cleanups afterwards.


* rename ath10k_hif_swap_mailbox() to make it usable for this

* small cleanups found while doing the refactoring

* compile tested only

Kalle Valo (3):
  ath10k: rename ath10k_hif_swap_mailbox() to ath10k_hif_start_post()
  ath10k: sdio: remove _hif_ prefix from functions not part of hif
  ath10k: hif: make send_complete_check op optional

Wen Gong (1):
  ath10k: improve power save performance for sdio

 drivers/net/wireless/ath/ath10k/core.c |   2 +-
 drivers/net/wireless/ath/ath10k/hif.h  |  11 ++-
 drivers/net/wireless/ath/ath10k/sdio.c | 168 +++++++++++++++++++++++----------
 drivers/net/wireless/ath/ath10k/sdio.h |  16 ++++
 drivers/net/wireless/ath/ath10k/usb.c  |  12 ---
 5 files changed, 139 insertions(+), 70 deletions(-)