mbox series

[0/2] ath11k: Rename soc_rx_stats to soc_dp_stats and add more dp stats

Message ID 1591768308-32005-1-git-send-email-srirrama@codeaurora.org (mailing list archive)
Headers show
Series ath11k: Rename soc_rx_stats to soc_dp_stats and add more dp stats | expand

Message

Sriram R June 10, 2020, 5:51 a.m. UTC
Currently, the debugfs "soc_rx_stats" in location '/sys/kernel/debug/ath11k/ipq8074/'
is used for getting only dp rx stats. This has been renamed to "soc_dp_stats"
as tx stats and other ring specific info would also be useful for
debug purpose and it would be good to have all these stats under similar
file.

This patchset adds support for tx error stats and ring backpressure
stats. More ring specific stats could be added here in future.

Sriram R (2):
  ath11k: Add dp tx err stats
  ath11k: Add support for ring backpressure stats

 drivers/net/wireless/ath/ath11k/core.h  |  34 ++++++++-
 drivers/net/wireless/ath/ath11k/debug.c | 128 ++++++++++++++++++++++++++++++--
 drivers/net/wireless/ath/ath11k/dp.h    |  42 +++++++++++
 drivers/net/wireless/ath/ath11k/dp_rx.c |  28 ++++++-
 drivers/net/wireless/ath/ath11k/dp_tx.c |   7 +-
 5 files changed, 229 insertions(+), 10 deletions(-)